aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2017-05-27 23:33:43 +0800
committerlinimon <linimon@FreeBSD.org>2017-05-27 23:33:43 +0800
commitd503867e5ad7b55ae5c95905ce34cbb6a3afcbb7 (patch)
tree22acc2e90158c53739d59d3a842854e86c477307 /net
parenta9f045f0c19175998a59c5ba4afa6c319df430a3 (diff)
downloadfreebsd-ports-gnome-d503867e5ad7b55ae5c95905ce34cbb6a3afcbb7.tar.gz
freebsd-ports-gnome-d503867e5ad7b55ae5c95905ce34cbb6a3afcbb7.tar.zst
freebsd-ports-gnome-d503867e5ad7b55ae5c95905ce34cbb6a3afcbb7.zip
Mark some ports failing on armv6: implicit declaration of function
'cp15_pmccntr_get' is invalid in C99. While here, pet portlint. Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'net')
-rw-r--r--net/aoe/Makefile10
-rw-r--r--net/intel-em-kmod/Makefile6
2 files changed, 8 insertions, 8 deletions
diff --git a/net/aoe/Makefile b/net/aoe/Makefile
index d71523c0afbf..a0d02a708e94 100644
--- a/net/aoe/Makefile
+++ b/net/aoe/Makefile
@@ -11,6 +11,11 @@ DISTNAME= ${PORTNAME}-freebsd-${PORTVERSION}
MAINTAINER= fjoe@FreeBSD.org
COMMENT= FreeBSD driver for ATA over Ethernet (AoE)
+BROKEN_aarch64= fails to compile: redefinition of frame
+BROKEN_armv6= fails to compile: implicit declaration of function 'cp15_pmccntr_get' is invalid in C99
+BROKEN_powerpc64= fails to compile: pcpu.h: size of array '__assert_0' is negative
+BROKEN_sparc64= fails to compile: redefinition of frame
+
USES= kmod
WRKSRC= ${WRKDIR}/dev/aoe
@@ -18,11 +23,6 @@ KMODDIR= ${PREFIX}/lib/aoe
USE_RC_SUBR= aoe
-BROKEN_aarch64= fails to compile: error: redefinition of frame
-BROKEN_armv6= fails to compile: error: redefinition of frame
-BROKEN_powerpc64= fails to compile: pcpu.h: size of array '__assert_0' is negative
-BROKEN_sparc64= fails to compile: error: redefinition of frame
-
do-install:
${INSTALL_KLD} ${WRKSRC}/aoe.ko ${STAGEDIR}${PREFIX}/lib/aoe
${INSTALL_MAN} ${WRKDIR}/aoe.4 ${STAGEDIR}${PREFIX}/man/man4/
diff --git a/net/intel-em-kmod/Makefile b/net/intel-em-kmod/Makefile
index fa65f50e1bbf..62c7ba7bdb3a 100644
--- a/net/intel-em-kmod/Makefile
+++ b/net/intel-em-kmod/Makefile
@@ -8,11 +8,11 @@ MASTER_SITE_SUBDIR= 17509/eng
MAINTAINER= franco@opnsense.org
COMMENT= Gigabit FreeBSD Base Drivers for Intel(R) Ethernet
+BROKEN_armv6= fails to compile: implicit declaration of function 'cp15_pmccntr_get' is invalid in C99
+BROKEN_powerpc64= fails to compile: pcpu.h: size of array '__assert_0' is negative
+
MASTERDIR= ${.CURDIR}/../intel-ixl-kmod
PKGDIR= ${.CURDIR}
DISTINFO_FILE= ${.CURDIR}/distinfo
-BROKEN_armv6= fails to compile: implicit declaration of function 'cp15_pmccntr_get' is invalid in C99
-BROKEN_powerpc64= fails to compile: pcpu.h: size of array '__assert_0' is negative
-
.include "${MASTERDIR}/Makefile"