aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2017-05-21 22:56:44 +0800
committersunpoet <sunpoet@FreeBSD.org>2017-05-21 22:56:44 +0800
commitd5a2dd5a645d691ded5ef6fe0f255bdbf8c2f03d (patch)
treefc3083910a645ab98e4b12b6e12345b697e6d00e /net
parent4fee44e6d74aa1484a3e0ea8baec4d7f841055d3 (diff)
downloadfreebsd-ports-gnome-d5a2dd5a645d691ded5ef6fe0f255bdbf8c2f03d.tar.gz
freebsd-ports-gnome-d5a2dd5a645d691ded5ef6fe0f255bdbf8c2f03d.tar.zst
freebsd-ports-gnome-d5a2dd5a645d691ded5ef6fe0f255bdbf8c2f03d.zip
Add go-madonctl 1.1.0
madonctl is a Golang command line interface for the Mastodon API. WWW: https://github.com/McKael/madonctl
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/go-madonctl/Makefile52
-rw-r--r--net/go-madonctl/distinfo53
-rw-r--r--net/go-madonctl/pkg-descr3
4 files changed, 109 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index b18456e7b04c..ab32bd319161 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -180,6 +180,7 @@
SUBDIR += go-geoip
SUBDIR += go-httppath
SUBDIR += go-httptreemux
+ SUBDIR += go-mastodon
SUBDIR += go-nats
SUBDIR += go.net
SUBDIR += gofish
diff --git a/net/go-madonctl/Makefile b/net/go-madonctl/Makefile
new file mode 100644
index 000000000000..f2b1ce975394
--- /dev/null
+++ b/net/go-madonctl/Makefile
@@ -0,0 +1,52 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= madonctl
+PORTVERSION= 1.1.0
+DISTVERSIONPREFIX= v
+CATEGORIES= net
+PKGNAMEPREFIX= go-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= CLI client for the Mastodon social network API
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+GO_PKGNAME= github.com/${GH_ACCOUNT}/${GH_PROJECT}
+USES= go
+
+PLIST_FILES= bin/madonctl
+
+GH_TUPLE= McKael:${PORTNAME}:${DISTVERSIONFULL} \
+ McKael:madon:v1.5.0:madon/../src/github.com/McKael/madon \
+ fsnotify:fsnotify:v1.4.2:fsnotify/../src/github.com/fsnotify/fsnotify \
+ ghodss:yaml:v1.0.0:yaml/../src/github.com/ghodss/yaml \
+ go-yaml:yaml:cd8b52f:yaml2/../src/gopkg.in/yaml.v2 \
+ golang:net:5139290:net/../src/golang.org/x/net \
+ golang:oauth2:f047394:oauth2/../src/golang.org/x/oauth2 \
+ golang:sys:a2e06a1:sys/../src/golang.org/x/sys \
+ golang:text:19e5161:text/../src/golang.org/x/text \
+ gorilla:websocket:v1.1.0:websocket/../src/github.com/gorilla/websocket \
+ hashicorp:hcl:392dba7:hcl/../src/github.com/hashicorp/hcl \
+ kr:text:7cafcd8:text2/../src/github.com/kr/text \
+ m0t0k1ch1:gomif:v0.3.0:gomif/../src/github.com/m0t0k1ch1/gomif \
+ magiconair:properties:v1.7.2:properties/../src/github.com/magiconair/properties \
+ mattn:go-isatty:v0.0.2:goisatty/../src/github.com/mattn/go-isatty \
+ mitchellh:mapstructure:cc8532a:mapstructure/../src/github.com/mitchellh/mapstructure \
+ pelletier:go-toml:v0.5.0:gotoml/../src/github.com/pelletier/go-toml \
+ pelletier:go-buffruneio:v0.2.0:buffruneio/../src/github.com/pelletier/go-buffruneio \
+ pkg:errors:v0.8.0:errors/../src/github.com/pkg/errors \
+ sendgrid:rest:v2.4.0:rest/../src/github.com/sendgrid/rest \
+ spf13:afero:9be6508:afero/../src/github.com/spf13/afero \
+ spf13:cast:v1.1.0:cast/../src/github.com/spf13/cast \
+ spf13:cobra:ca57f0f:cobra/../src/github.com/spf13/cobra \
+ spf13:jWalterWeatherman:8f07c83:jWalterWeatherman/../src/github.com/spf13/jwalterweatherman \
+ spf13:pflag:e57e3ee:pflag/../src/github.com/spf13/pflag \
+ spf13:viper:0967fc9:viper/../src/github.com/spf13/viper
+USE_GITHUB= yes
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKDIR}/bin/madonctl ${STAGEDIR}${PREFIX}/bin/madonctl
+
+.include <bsd.port.mk>
diff --git a/net/go-madonctl/distinfo b/net/go-madonctl/distinfo
new file mode 100644
index 000000000000..32384a03979c
--- /dev/null
+++ b/net/go-madonctl/distinfo
@@ -0,0 +1,53 @@
+TIMESTAMP = 1495377712
+SHA256 (McKael-madonctl-v1.1.0_GH0.tar.gz) = 0d27b37f4e73ef92830f7f2ef54f4134afe91ce6c9ac6f05da62f2b04b4ba100
+SIZE (McKael-madonctl-v1.1.0_GH0.tar.gz) = 36833
+SHA256 (McKael-madon-v1.5.0_GH0.tar.gz) = a7a5c6ce0c0ab12a246cc1c27efca1c2f755ec13bc18533652d567129f5b5838
+SIZE (McKael-madon-v1.5.0_GH0.tar.gz) = 14099
+SHA256 (fsnotify-fsnotify-v1.4.2_GH0.tar.gz) = 4a1fd9beeb0496b9cf6084ac83654ece19188e9b2ffa041652d1071d4b225415
+SIZE (fsnotify-fsnotify-v1.4.2_GH0.tar.gz) = 29552
+SHA256 (ghodss-yaml-v1.0.0_GH0.tar.gz) = 8a76b47cd171944612aae1cfa08bbb971b63fec16794c839252808392097de44
+SIZE (ghodss-yaml-v1.0.0_GH0.tar.gz) = 11772
+SHA256 (go-yaml-yaml-cd8b52f_GH0.tar.gz) = b1c9f89593f27734ba7fe9cf8573bac332641e59d7cfe17383db1572960913b6
+SIZE (go-yaml-yaml-cd8b52f_GH0.tar.gz) = 60718
+SHA256 (golang-net-5139290_GH0.tar.gz) = ffa9394cb35945498cd2cee5b137d6bd1cee43b9bb6f775b06c11101981ea65a
+SIZE (golang-net-5139290_GH0.tar.gz) = 884961
+SHA256 (golang-oauth2-f047394_GH0.tar.gz) = aff836b991d53169696e57727ecfd58a4f081630aeb82701dfaf695eb8d6365f
+SIZE (golang-oauth2-f047394_GH0.tar.gz) = 38172
+SHA256 (golang-sys-a2e06a1_GH0.tar.gz) = 3e6b0295c28b9b515ba3e7be3b341a3361b09fdd7d31c45e09c6defb73f0e18a
+SIZE (golang-sys-a2e06a1_GH0.tar.gz) = 713083
+SHA256 (golang-text-19e5161_GH0.tar.gz) = 05e0c53b51e833c700312b9fa259fbddb66712669a26aaae9747c218869b0d58
+SIZE (golang-text-19e5161_GH0.tar.gz) = 4551121
+SHA256 (gorilla-websocket-v1.1.0_GH0.tar.gz) = 7580ff112797d4070f2b104ea9af090b73ff951a30323e4cdffa56129d05e56b
+SIZE (gorilla-websocket-v1.1.0_GH0.tar.gz) = 38809
+SHA256 (hashicorp-hcl-392dba7_GH0.tar.gz) = a9ec781e8590fe45a11f84833cb3a6ad56d7da069ee95750f53f8e133bc679e8
+SIZE (hashicorp-hcl-392dba7_GH0.tar.gz) = 69728
+SHA256 (kr-text-7cafcd8_GH0.tar.gz) = 218bd56a3927283e4c9232b4ee15e0fcc989ace72a2a0be14863ce3795ad3c90
+SIZE (kr-text-7cafcd8_GH0.tar.gz) = 8584
+SHA256 (m0t0k1ch1-gomif-v0.3.0_GH0.tar.gz) = a461a47535562bf3a191a2faa8f6cd8d8be5ae53cc61077fcced9fbd6268245b
+SIZE (m0t0k1ch1-gomif-v0.3.0_GH0.tar.gz) = 3979
+SHA256 (magiconair-properties-v1.7.2_GH0.tar.gz) = a6ce98cc33353043b02f27bea626392285d90916661d9a077e208499fdc99c00
+SIZE (magiconair-properties-v1.7.2_GH0.tar.gz) = 26985
+SHA256 (mattn-go-isatty-v0.0.2_GH0.tar.gz) = c0681d72b185a8d4aa8f6a557d181bf25c6e3e7f3874711de507e550b25408bf
+SIZE (mattn-go-isatty-v0.0.2_GH0.tar.gz) = 3258
+SHA256 (mitchellh-mapstructure-cc8532a_GH0.tar.gz) = 4d5bcdcf567fd8d6b30250e8194cc6b5b9d15d2a79d67125a5c1118740af7c81
+SIZE (mitchellh-mapstructure-cc8532a_GH0.tar.gz) = 15613
+SHA256 (pelletier-go-toml-v0.5.0_GH0.tar.gz) = b9017683f1db2e93fd5cef931a7c16f47f655bff8ce1accde94d92939e0c8c9b
+SIZE (pelletier-go-toml-v0.5.0_GH0.tar.gz) = 38749
+SHA256 (pelletier-go-buffruneio-v0.2.0_GH0.tar.gz) = 2a838bbc3240d323549c9e6820cbf66199296d2706e72697685ee9576affd49f
+SIZE (pelletier-go-buffruneio-v0.2.0_GH0.tar.gz) = 3028
+SHA256 (pkg-errors-v0.8.0_GH0.tar.gz) = bacf6c58e490911398cee61742ddc6a90c560733e4c9dcb3d867b17a894c9dd5
+SIZE (pkg-errors-v0.8.0_GH0.tar.gz) = 11344
+SHA256 (sendgrid-rest-v2.4.0_GH0.tar.gz) = 24e41723e08b86487f4c254addbc46daa652e04bd028d4c43301724ef5354a67
+SIZE (sendgrid-rest-v2.4.0_GH0.tar.gz) = 9806
+SHA256 (spf13-afero-9be6508_GH0.tar.gz) = 6814d3c2e2c55540cbc190def53324924cf44b06ac4ec39b4cb09c3416a5dcb5
+SIZE (spf13-afero-9be6508_GH0.tar.gz) = 40630
+SHA256 (spf13-cast-v1.1.0_GH0.tar.gz) = 2758eb969dd8707c0ff165fda4191fd8811e19b0c5d29d3dced0fba1b4410ad4
+SIZE (spf13-cast-v1.1.0_GH0.tar.gz) = 9592
+SHA256 (spf13-cobra-ca57f0f_GH0.tar.gz) = a7046d354f82b36200980441efae97ad88dcf9dd0791efcf42c65e9c570ccc9f
+SIZE (spf13-cobra-ca57f0f_GH0.tar.gz) = 96573
+SHA256 (spf13-jWalterWeatherman-8f07c83_GH0.tar.gz) = f54eef5f84832260fc7448732ac666c445e7f4784670bea34b92e36e2f4d0107
+SIZE (spf13-jWalterWeatherman-8f07c83_GH0.tar.gz) = 6230
+SHA256 (spf13-pflag-e57e3ee_GH0.tar.gz) = 16556b4873f12211cffec75aa4d3a6332efa26e64ff0476fdbd99f672ca37d51
+SIZE (spf13-pflag-e57e3ee_GH0.tar.gz) = 38998
+SHA256 (spf13-viper-0967fc9_GH0.tar.gz) = 29aa393a01b5e899b1f72709349661120a2030e0741b6db4a91f10bb9c36badd
+SIZE (spf13-viper-0967fc9_GH0.tar.gz) = 30669
diff --git a/net/go-madonctl/pkg-descr b/net/go-madonctl/pkg-descr
new file mode 100644
index 000000000000..dbf77587ea31
--- /dev/null
+++ b/net/go-madonctl/pkg-descr
@@ -0,0 +1,3 @@
+madonctl is a Golang command line interface for the Mastodon API.
+
+WWW: https://github.com/McKael/madonctl