aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2018-09-27 16:56:06 +0800
committermadpilot <madpilot@FreeBSD.org>2018-09-27 16:56:06 +0800
commitd6eb6a8e042b33e9a290b8c572b196601e3069da (patch)
tree5d121ffc5c33196e7a379834b7e254b74f00b711 /net
parentafd2e0e2a27fc6e90ad7345ffce8706f374b562f (diff)
downloadfreebsd-ports-gnome-d6eb6a8e042b33e9a290b8c572b196601e3069da.tar.gz
freebsd-ports-gnome-d6eb6a8e042b33e9a290b8c572b196601e3069da.tar.zst
freebsd-ports-gnome-d6eb6a8e042b33e9a290b8c572b196601e3069da.zip
- Update net/babeld to 1.8.2
- Add startup script - Add sample configuration file PR: 229785 Submitted by: Max Stucchi ?<max@stucchi.ch> Approved by: Maintainer timeout
Diffstat (limited to 'net')
-rw-r--r--net/babeld/Makefile8
-rw-r--r--net/babeld/distinfo6
-rw-r--r--net/babeld/files/babeld.conf35
-rw-r--r--net/babeld/files/babeld.in35
4 files changed, 79 insertions, 5 deletions
diff --git a/net/babeld/Makefile b/net/babeld/Makefile
index f1f162501f04..604dc69944d3 100644
--- a/net/babeld/Makefile
+++ b/net/babeld/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= babeld
-PORTVERSION= 1.8.1
+PORTVERSION= 1.8.2
CATEGORIES= net
MASTER_SITES= http://www.pps.univ-paris-diderot.fr/~jch/software/files/
@@ -14,10 +14,14 @@ LICENSE= MIT
MAKE_ARGS= CDEBUGFLAGS="-O2 -g -Wall"
PLIST_FILES= bin/babeld \
- man/man8/babeld.8.gz
+ man/man8/babeld.8.gz \
+ "@sample etc/babeld.conf.sample"
+
+USE_RC_SUBR= babeld
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/babeld ${STAGEDIR}${PREFIX}/bin/
${INSTALL_MAN} ${WRKSRC}/babeld.man ${STAGEDIR}${PREFIX}/man/man8/babeld.8
+ ${INSTALL_DATA} ${FILESDIR}/babeld.conf ${STAGEDIR}${PREFIX}/etc/babeld.conf.sample
.include <bsd.port.mk>
diff --git a/net/babeld/distinfo b/net/babeld/distinfo
index 61bb0fa8d62a..a796f1bc2491 100644
--- a/net/babeld/distinfo
+++ b/net/babeld/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1525712441
-SHA256 (babeld-1.8.1.tar.gz) = 9c249c73f5292ec18d1dd70934195edf2cbfa51f0a0fca937e16104f7fc006bf
-SIZE (babeld-1.8.1.tar.gz) = 92784
+TIMESTAMP = 1531659508
+SHA256 (babeld-1.8.2.tar.gz) = 07edecb132386d5561a767482bc5200e04239b18e48c2f0f47ae1c78d60fe5dc
+SIZE (babeld-1.8.2.tar.gz) = 92852
diff --git a/net/babeld/files/babeld.conf b/net/babeld/files/babeld.conf
new file mode 100644
index 000000000000..74023d605982
--- /dev/null
+++ b/net/babeld/files/babeld.conf
@@ -0,0 +1,35 @@
+# babel config file
+#
+# This config file simply documents sample entries.
+# "redistribute" means: redistribute routes from other routing protocols
+# into babel. "local" means addresses assigned to local interfaces.
+
+# the default rules are:
+#
+## redistribute local
+## redistribute deny
+#
+# this says, redistribute local addresses but no other routes
+
+
+# redistribute IPv4 default route into babel
+# redistribute local ip 0.0.0.0/0 le 0 metric 128
+
+# same but for IPv6
+# redistribute local ip ::/0 le 0 metric 128
+
+
+# don't redistribute all local addresses, only selected ones
+# after the first line, the "deny" rules kicks in. After the "deny"
+# no redistribute local rules are going to match
+## redistribute local ip 192.160.4.0/24
+## redistribute local deny
+
+
+# Babel refuses to redistribute routes with a protocol number of "boot";
+# this is standard practice, and means that you cannot easily
+# redistribute the default route installed by dhcp. It is however
+# possible to redistribute such route by explicitly specifying "proto 3"
+# on the redistribute line.
+## redistribute ip 0.0.0.0/0 le 0 proto 3 metric 128
+
diff --git a/net/babeld/files/babeld.in b/net/babeld/files/babeld.in
new file mode 100644
index 000000000000..b8f42109ad6b
--- /dev/null
+++ b/net/babeld/files/babeld.in
@@ -0,0 +1,35 @@
+#!/bin/sh
+
+# $FreeBSD$
+#
+# PROVIDE: babeld dynamicrouting
+# REQUIRE: LOGIN
+# KEYWORD: shutdown
+#
+# Add the following lines to /etc/rc.conf.local or /etc/rc.conf
+# to enable this service:
+#
+# babeld_enable (bool): Set to NO by default.
+# Set it to YES to enable babeld.
+# babeld_config (path): Set to /usr/local/etc/babeld.conf
+# by default.
+#
+
+. /etc/rc.subr
+
+name="babeld"
+rcvar=babeld_enable
+
+command=/usr/local/bin/${name}
+
+load_rc_config $name
+
+extra_commands="reload"
+
+: ${babeld_enable="NO"}
+: ${babeld_config="/usr/local/etc/babeld.conf"}
+
+command_args="-D -I /var/run/${name}.pid $babeld_config"
+
+run_rc_command "$1"
+