aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authortz <tz@FreeBSD.org>2018-10-08 16:52:51 +0800
committertz <tz@FreeBSD.org>2018-10-08 16:52:51 +0800
commitdf310a32dc5482a3355a8fcd4ca55dd5289803bb (patch)
treeadfd6b20496941d7ab22cbbb81aacdf0db2ffbe3 /net
parent6925d9004d56a9f2d5109f1397be7247e1c9c5e0 (diff)
downloadfreebsd-ports-gnome-df310a32dc5482a3355a8fcd4ca55dd5289803bb.tar.gz
freebsd-ports-gnome-df310a32dc5482a3355a8fcd4ca55dd5289803bb.tar.zst
freebsd-ports-gnome-df310a32dc5482a3355a8fcd4ca55dd5289803bb.zip
Add PHP 7.3 RC2 to the ports-tree.
Notable changes: - Switch from PCRE to PCRE2 - Many modules now require PCRE2 for building - graphics/php73-gd: X11 option is no longer default Changes to Mk/Uses/php.mk approved by ale
Diffstat (limited to 'net')
-rw-r--r--net/php73-ldap/Makefile11
-rw-r--r--net/php73-soap/Makefile11
-rw-r--r--net/php73-sockets/Makefile11
-rw-r--r--net/php73-xmlrpc/Makefile11
-rw-r--r--net/php73-xmlrpc/files/patch-config.m423
5 files changed, 67 insertions, 0 deletions
diff --git a/net/php73-ldap/Makefile b/net/php73-ldap/Makefile
new file mode 100644
index 000000000000..dd821b57570a
--- /dev/null
+++ b/net/php73-ldap/Makefile
@@ -0,0 +1,11 @@
+# $FreeBSD$
+
+CATEGORIES= net
+
+MASTERDIR= ${.CURDIR}/../../lang/php73
+
+PKGNAMESUFFIX= -ldap
+
+TEST_TARGET= test
+
+.include "${MASTERDIR}/Makefile"
diff --git a/net/php73-soap/Makefile b/net/php73-soap/Makefile
new file mode 100644
index 000000000000..8037336de830
--- /dev/null
+++ b/net/php73-soap/Makefile
@@ -0,0 +1,11 @@
+# $FreeBSD$
+
+CATEGORIES= net
+
+MASTERDIR= ${.CURDIR}/../../lang/php73
+
+PKGNAMESUFFIX= -soap
+
+TEST_TARGET= test
+
+.include "${MASTERDIR}/Makefile"
diff --git a/net/php73-sockets/Makefile b/net/php73-sockets/Makefile
new file mode 100644
index 000000000000..7cf6f91a1acc
--- /dev/null
+++ b/net/php73-sockets/Makefile
@@ -0,0 +1,11 @@
+# $FreeBSD$
+
+CATEGORIES= net
+
+MASTERDIR= ${.CURDIR}/../../lang/php73
+
+PKGNAMESUFFIX= -sockets
+
+TEST_TARGET= test
+
+.include "${MASTERDIR}/Makefile"
diff --git a/net/php73-xmlrpc/Makefile b/net/php73-xmlrpc/Makefile
new file mode 100644
index 000000000000..25003aac3cdb
--- /dev/null
+++ b/net/php73-xmlrpc/Makefile
@@ -0,0 +1,11 @@
+# $FreeBSD$
+
+CATEGORIES= net
+
+MASTERDIR= ${.CURDIR}/../../lang/php73
+
+PKGNAMESUFFIX= -xmlrpc
+
+TEST_TARGET= test
+
+.include "${MASTERDIR}/Makefile"
diff --git a/net/php73-xmlrpc/files/patch-config.m4 b/net/php73-xmlrpc/files/patch-config.m4
new file mode 100644
index 000000000000..d2dc85f26a48
--- /dev/null
+++ b/net/php73-xmlrpc/files/patch-config.m4
@@ -0,0 +1,23 @@
+--- config.m4.orig 2014-04-29 08:04:30.000000000 +0000
++++ config.m4 2014-05-15 08:04:00.883004682 +0000
+@@ -61,11 +61,9 @@ if test "$PHP_XMLRPC" != "no"; then
+ fi
+ fi
+
+- dnl if iconv is shared or missing then we should build iconv ourselves
+- if test "$PHP_ICONV_SHARED" = "yes" || test "$PHP_ICONV" = "no"; then
+-
+ if test "$PHP_ICONV_DIR" != "no"; then
+ PHP_ICONV=$PHP_ICONV_DIR
++ PHP_ADD_INCLUDE($PHP_ICONV_DIR/include)
+ fi
+
+ if test -z "$PHP_ICONV" || test "$PHP_ICONV" = "no"; then
+@@ -75,7 +73,6 @@ if test "$PHP_XMLRPC" != "no"; then
+ PHP_SETUP_ICONV(XMLRPC_SHARED_LIBADD, [], [
+ AC_MSG_ERROR([iconv not found, in order to build xmlrpc you need the iconv library])
+ ])
+- fi
+ fi
+
+ if test "$PHP_XMLRPC" = "yes"; then