aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authordanilo <danilo@FreeBSD.org>2018-09-26 06:25:35 +0800
committerdanilo <danilo@FreeBSD.org>2018-09-26 06:25:35 +0800
commite6eaad23d2e8bdba25a0168f90003019919c3921 (patch)
tree79ae3d5833c7e3b820fc532cfe30ca57ca37da47 /net
parent2803fcbabd2b59b37bf5da41a8c958500ae9593f (diff)
downloadfreebsd-ports-gnome-e6eaad23d2e8bdba25a0168f90003019919c3921.tar.gz
freebsd-ports-gnome-e6eaad23d2e8bdba25a0168f90003019919c3921.tar.zst
freebsd-ports-gnome-e6eaad23d2e8bdba25a0168f90003019919c3921.zip
- Remove --enable-heterogeneous from CONFIGURE_ARGS, this option is broken and causing problems
see https://github.com/open-mpi/ompi/blob/master/README#L1387 while here - Bump PORTREVISION - Move USES to the proper section to make portlint happy PR: 231697 Submitted by: russo AT bogodyn.org
Diffstat (limited to 'net')
-rw-r--r--net/openmpi3/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/net/openmpi3/Makefile b/net/openmpi3/Makefile
index c387616e00c5..9288d7646238 100644
--- a/net/openmpi3/Makefile
+++ b/net/openmpi3/Makefile
@@ -2,6 +2,7 @@
PORTNAME= openmpi
PORTVERSION= 3.1.2
+PORTREVISION= 1
CATEGORIES= net parallel
MASTER_SITES= http://www.open-mpi.org/software/ompi/v${PORTVERSION:R}/downloads/
PKGNAMESUFFIX= 3
@@ -22,11 +23,12 @@ LIB_DEPENDS= libhwloc.so:devel/hwloc \
libevent.so:devel/libevent \
libmunge.so:security/munge
-HAS_CONFIGURE= yes
-INSTALL_TARGET= install-strip
# :keepla because port uses lt_dlopen
USES= fortran gmake libtool:keepla localbase perl5 \
pkgconfig shebangfix tar:bzip2
+
+HAS_CONFIGURE= yes
+INSTALL_TARGET= install-strip
USE_PERL5= build
MPIBASE?= mpi
@@ -43,7 +45,6 @@ CONFIGURE_ARGS+= --prefix=${PREFIX}/${MPIDIR} \
--enable-mpi-fortran=usempi \
--enable-mpi-cxx \
--enable-cxx-exceptions \
- --enable-heterogeneous \
--enable-mpi-thread-multiple \
--with-libevent=external \
--enable-mca-no-build=verbs,btl_openib,oob_ud \