aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authortdb <tdb@FreeBSD.org>2007-01-08 02:34:18 +0800
committertdb <tdb@FreeBSD.org>2007-01-08 02:34:18 +0800
commited371fd9868354451659459a3c60770e9f7cefa5 (patch)
tree5ab5459dc5fea686d8ea7439049911440db4c752 /net
parentfb289f915808c9fb795d54f56d446c8dcb861102 (diff)
downloadfreebsd-ports-gnome-ed371fd9868354451659459a3c60770e9f7cefa5.tar.gz
freebsd-ports-gnome-ed371fd9868354451659459a3c60770e9f7cefa5.tar.zst
freebsd-ports-gnome-ed371fd9868354451659459a3c60770e9f7cefa5.zip
Add patch to fix build when LOCALBASE != /usr/local. The configure
script checked explicitly in /usr/local for pwlib. This patch has also been sent upstream. Patch does not affect build when LOCALBASE == /usr/local, so no PORTREVISION bump required. Approved by: Jean-Baptiste Quenot <jbq@caraldi.com> (maintainer)
Diffstat (limited to 'net')
-rw-r--r--net/opal/files/patch-configure.ac24
-rw-r--r--net/opal3/files/patch-configure.ac24
2 files changed, 48 insertions, 0 deletions
diff --git a/net/opal/files/patch-configure.ac b/net/opal/files/patch-configure.ac
new file mode 100644
index 000000000000..0ff721a18000
--- /dev/null
+++ b/net/opal/files/patch-configure.ac
@@ -0,0 +1,24 @@
+--- ./configure.ac.orig Tue Feb 21 00:47:28 2006
++++ ./configure.ac Sun Jan 7 13:01:14 2007
+@@ -60,6 +60,11 @@
+ AC_CHECK_FILE(/usr/include/ptlib.h, HAS_PTLIB=1)
+ if test "${HAS_PTLIB:-unset}" != "unset" ; then
+ AC_PATH_PROG(PTLIB_CONFIG, ptlib-config, , /usr/share/pwlib/make/)
++ else
++ AC_CHECK_FILE(${prefix}/include/ptlib.h, HAS_PTLIB=1)
++ if test "${HAS_PTLIB:-unset}" != "unset" ; then
++ AC_PATH_PROG(PTLIB_CONFIG, ptlib-config, , ${prefix}/bin)
++ fi
+ fi
+ fi
+ fi
+@@ -84,6 +89,9 @@
+ fi
+ if test "x$PWLIBDIR" = "x/usr/local" -o "x$PWLIBDIR" = "x/usr/"; then
+ PWLIBDIR="/usr/local/share/pwlib/"
++fi
++if test "x$PWLIBDIR" = "x${prefix}"; then
++ PWLIBDIR="${prefix}/share/pwlib/"
+ fi
+
+ echo "PWLib prefix set to.... $PWLIBDIR"
diff --git a/net/opal3/files/patch-configure.ac b/net/opal3/files/patch-configure.ac
new file mode 100644
index 000000000000..0ff721a18000
--- /dev/null
+++ b/net/opal3/files/patch-configure.ac
@@ -0,0 +1,24 @@
+--- ./configure.ac.orig Tue Feb 21 00:47:28 2006
++++ ./configure.ac Sun Jan 7 13:01:14 2007
+@@ -60,6 +60,11 @@
+ AC_CHECK_FILE(/usr/include/ptlib.h, HAS_PTLIB=1)
+ if test "${HAS_PTLIB:-unset}" != "unset" ; then
+ AC_PATH_PROG(PTLIB_CONFIG, ptlib-config, , /usr/share/pwlib/make/)
++ else
++ AC_CHECK_FILE(${prefix}/include/ptlib.h, HAS_PTLIB=1)
++ if test "${HAS_PTLIB:-unset}" != "unset" ; then
++ AC_PATH_PROG(PTLIB_CONFIG, ptlib-config, , ${prefix}/bin)
++ fi
+ fi
+ fi
+ fi
+@@ -84,6 +89,9 @@
+ fi
+ if test "x$PWLIBDIR" = "x/usr/local" -o "x$PWLIBDIR" = "x/usr/"; then
+ PWLIBDIR="/usr/local/share/pwlib/"
++fi
++if test "x$PWLIBDIR" = "x${prefix}"; then
++ PWLIBDIR="${prefix}/share/pwlib/"
+ fi
+
+ echo "PWLib prefix set to.... $PWLIBDIR"