aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-04-06 21:38:16 +0800
committerkrion <krion@FreeBSD.org>2004-04-06 21:38:16 +0800
commitf11a6545ce6452be678eb90340ac308724a62fb9 (patch)
treeb2d52d55b63dab9c0e7827d6fb7fb8a500ce8e4a /net
parente71be172faf145f55902cc3a7c1bd07f33d48477 (diff)
downloadfreebsd-ports-gnome-f11a6545ce6452be678eb90340ac308724a62fb9.tar.gz
freebsd-ports-gnome-f11a6545ce6452be678eb90340ac308724a62fb9.tar.zst
freebsd-ports-gnome-f11a6545ce6452be678eb90340ac308724a62fb9.zip
- Respect CC & CFLAGS
PR: ports/65198 Submitted by: michael johnson <ahze@ahze.net>
Diffstat (limited to 'net')
-rw-r--r--net/ncp/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/net/ncp/Makefile b/net/ncp/Makefile
index 6ccf87cca0bf..905841b6ae84 100644
--- a/net/ncp/Makefile
+++ b/net/ncp/Makefile
@@ -17,6 +17,13 @@ MANCOMPRESSED= no
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_BZIP2= yes
+USE_REINPLACE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|gcc -O2|${CC} ${CFLAGS}|' \
+ ${WRKSRC}/conf-cc
+ @${REINPLACE_CMD} -e 's|gcc|${CC} ${LDFLAGS}|' \
+ ${WRKSRC}/conf-ld
do-install:
cd ${WRKSRC}; ${INSTALL_PROGRAM} ncp ${PREFIX}/bin