aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2016-07-19 02:01:29 +0800
committermadpilot <madpilot@FreeBSD.org>2016-07-19 02:01:29 +0800
commitf9750b912e977178b009b26f61e99652da5b369d (patch)
tree94535242b0813efc96e125d9e0feae956c6ad66c /net
parent83b5ffca41c25302bdda62e0d51d10d8dbffd517 (diff)
downloadfreebsd-ports-gnome-f9750b912e977178b009b26f61e99652da5b369d.tar.gz
freebsd-ports-gnome-f9750b912e977178b009b26f61e99652da5b369d.tar.zst
freebsd-ports-gnome-f9750b912e977178b009b26f61e99652da5b369d.zip
FreeBSD's regexec() libc function is more restrictive than the linux
one and will not accept an empty expression. Add patch (from PR) to fix this problem. PR: 211187 Submitted by: Dmitry Vagin <daemon.hammer at ya.ru>
Diffstat (limited to 'net')
-rw-r--r--net/asterisk13/Makefile2
-rw-r--r--net/asterisk13/files/patch-res_res__pjsip_pjsip__cli.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/net/asterisk13/Makefile b/net/asterisk13/Makefile
index b5fde8fd4d36..6a441b9349e3 100644
--- a/net/asterisk13/Makefile
+++ b/net/asterisk13/Makefile
@@ -2,7 +2,7 @@
PORTNAME= asterisk
PORTVERSION= 13.9.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= http://downloads.asterisk.org/pub/telephony/%SUBDIR%/:DEFAULT,g729
MASTER_SITE_SUBDIR= asterisk/ \
diff --git a/net/asterisk13/files/patch-res_res__pjsip_pjsip__cli.c b/net/asterisk13/files/patch-res_res__pjsip_pjsip__cli.c
new file mode 100644
index 000000000000..f1d6aa4819cc
--- /dev/null
+++ b/net/asterisk13/files/patch-res_res__pjsip_pjsip__cli.c
@@ -0,0 +1,11 @@
+--- res/res_pjsip/pjsip_cli.c.orig 2016-05-13 17:41:41 UTC
++++ res/res_pjsip/pjsip_cli.c
+@@ -172,7 +172,7 @@ char *ast_sip_cli_traverse_objects(struc
+ }
+ regex = a->argv[4];
+ } else {
+- regex = "";
++ regex = ".";
+ }
+
+ if (cmd == CLI_GENERATE