aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-07-10 20:41:18 +0800
committertijl <tijl@FreeBSD.org>2014-07-10 20:41:18 +0800
commitfa21c9e4d5340d48d14c057a9a835e0a718f1059 (patch)
tree2b84c777fd86d2145a85cb4c2552d7f7ef561d54 /net
parent2ecc324862c27da32b0dbfe13e6d1169f9440852 (diff)
downloadfreebsd-ports-gnome-fa21c9e4d5340d48d14c057a9a835e0a718f1059.tar.gz
freebsd-ports-gnome-fa21c9e4d5340d48d14c057a9a835e0a718f1059.tar.zst
freebsd-ports-gnome-fa21c9e4d5340d48d14c057a9a835e0a718f1059.zip
- Add USES=libtool and INSTALL_TARGET=install-strip
- Don't propagate -pthread to dependent ports - Use MAKE_CMD
Diffstat (limited to 'net')
-rw-r--r--net/libzmq2/Makefile13
-rw-r--r--net/libzmq2/pkg-plist10
2 files changed, 11 insertions, 12 deletions
diff --git a/net/libzmq2/Makefile b/net/libzmq2/Makefile
index ae64bdd20321..e8da9e516b78 100644
--- a/net/libzmq2/Makefile
+++ b/net/libzmq2/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libzmq2
PORTVERSION= 2.2.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net
MASTER_SITES= http://download.zeromq.org/
DISTNAME= zeromq-${DISTVERSION}
@@ -13,9 +13,10 @@ COMMENT= ZeroMQ core library (Version 2)
LICENSE= LGPL3
-USES= pathfix
-USE_LDCONFIG= yes
GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
+USES= libtool pathfix
+USE_LDCONFIG= yes
CONFLICTS= libzmq[^2]-[0-9]*
@@ -28,10 +29,8 @@ DEBUG_CONFIGURE_ON= --enable-debug
WITH_DEBUG= yes
.endif
-post-patch:
- ${REINPLACE_CMD} -e '9s|$$| -pthread|' ${WRKSRC}/src/libzmq.pc.in
-
regression-test: build
- cd ${WRKSRC} && ${MAKE} check
+ @(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_FLAGS} \
+ ${MAKEFILE} ${MAKE_ARGS} check)
.include <bsd.port.mk>
diff --git a/net/libzmq2/pkg-plist b/net/libzmq2/pkg-plist
index dfc9746e6755..fcfdbfa8c86b 100644
--- a/net/libzmq2/pkg-plist
+++ b/net/libzmq2/pkg-plist
@@ -1,11 +1,11 @@
-lib/libzmq.so.1
-lib/libzmq.la
+include/zmq.h
+include/zmq.hpp
+include/zmq_utils.h
lib/libzmq.a
lib/libzmq.so
+lib/libzmq.so.1
+lib/libzmq.so.1.0.1
libdata/pkgconfig/libzmq.pc
-include/zmq.hpp
-include/zmq_utils.h
-include/zmq.h
man/man3/zmq_bind.3.gz
man/man3/zmq_close.3.gz
man/man3/zmq_connect.3.gz