aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorflo <flo@FreeBSD.org>2013-05-05 06:48:03 +0800
committerflo <flo@FreeBSD.org>2013-05-05 06:48:03 +0800
commit02ba370ac4348e20c88c9698d4e91f3fe34868c8 (patch)
treeab399d9912d8f00891d9d8508edf96aa3ef0bc0b /net
parentab79042bad4c4010d43e6983f39a47e3575126a5 (diff)
downloadfreebsd-ports-gnome-02ba370ac4348e20c88c9698d4e91f3fe34868c8.tar.gz
freebsd-ports-gnome-02ba370ac4348e20c88c9698d4e91f3fe34868c8.tar.zst
freebsd-ports-gnome-02ba370ac4348e20c88c9698d4e91f3fe34868c8.zip
Fix installation of ports that rely on cp -n for installing files. r245960
changed cp to exit with a non-zero exit code if the file exists and is not overwritten thus causing ports to fail installing when e.g. trying to cp .default -> .conf files that already exist. We just ignore the error and continue, as we used to. Reported by: jaset Approved by: portmgr (bapt)
Diffstat (limited to 'net')
-rw-r--r--net/relayd/Makefile2
-rw-r--r--net/ushare/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/net/relayd/Makefile b/net/relayd/Makefile
index 1d899d5e4125..10eae269f469 100644
--- a/net/relayd/Makefile
+++ b/net/relayd/Makefile
@@ -58,6 +58,6 @@ post-install:
@${INSTALL_DATA} ${WRKSRC}/../etc/relayd.conf \
${PREFIX}/etc/relayd.conf.sample
@${CP} -n ${PREFIX}/etc/relayd.conf.sample \
- ${PREFIX}/etc/relayd.conf
+ ${PREFIX}/etc/relayd.conf || ${TRUE}
.include <bsd.port.post.mk>
diff --git a/net/ushare/Makefile b/net/ushare/Makefile
index 2145fbefa78c..7901a1fe3fa2 100644
--- a/net/ushare/Makefile
+++ b/net/ushare/Makefile
@@ -42,6 +42,6 @@ do-install:
post-install:
${CP} -np ${PREFIX}/etc/${PORTNAME}.conf.sample \
- ${PREFIX}/etc/${PORTNAME}.conf
+ ${PREFIX}/etc/${PORTNAME}.conf || ${TRUE}
.include <bsd.port.mk>