aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorcy <cy@FreeBSD.org>2016-12-16 04:22:14 +0800
committercy <cy@FreeBSD.org>2016-12-16 04:22:14 +0800
commit08012cd838d9e670e256746c49a9c036bc96013c (patch)
treee8bd4b4167e29486ae8e850803ebec5004f14a9e /net
parent9bc35e47612056db93b1fb69fcc45c4eabc35b49 (diff)
downloadfreebsd-ports-gnome-08012cd838d9e670e256746c49a9c036bc96013c.tar.gz
freebsd-ports-gnome-08012cd838d9e670e256746c49a9c036bc96013c.tar.zst
freebsd-ports-gnome-08012cd838d9e670e256746c49a9c036bc96013c.zip
Fix build with LibreSSL.
PR: 215323 Submitted by: naddy
Diffstat (limited to 'net')
-rw-r--r--net/ntp/Makefile4
-rw-r--r--net/ntp/files/patch-include_libssl__compat.h11
-rw-r--r--net/ntp/files/patch-libntp_libssl__compat.c11
3 files changed, 22 insertions, 4 deletions
diff --git a/net/ntp/Makefile b/net/ntp/Makefile
index ca827574cfa1..3aa5960b7578 100644
--- a/net/ntp/Makefile
+++ b/net/ntp/Makefile
@@ -70,10 +70,6 @@ ${D}_CONFIGURE_ON= --enable-${D}
BROKEN= Does not build under FreeBSD-9, aclocal not found
.endif
-.if ${SSL_DEFAULT:Mlibressl*}
-IGNORE= detected LibreSSL (md5 definition conflicts)
-.endif
-
# XXX Temporary hack. Remember to remove this next commit.
post-extract:
@${TOUCH} ${WRKSRC}/scripts/build/checkHtmlFileDates
diff --git a/net/ntp/files/patch-include_libssl__compat.h b/net/ntp/files/patch-include_libssl__compat.h
new file mode 100644
index 000000000000..7e03c01c4a67
--- /dev/null
+++ b/net/ntp/files/patch-include_libssl__compat.h
@@ -0,0 +1,11 @@
+--- include/libssl_compat.h.orig 2016-11-21 12:28:40 UTC
++++ include/libssl_compat.h
+@@ -25,7 +25,7 @@
+ #include "openssl/rsa.h"
+
+ /* ----------------------------------------------------------------- */
+-#if OPENSSL_VERSION_NUMBER < 0x10100000L
++#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
+ /* ----------------------------------------------------------------- */
+
+ # include <openssl/objects.h>
diff --git a/net/ntp/files/patch-libntp_libssl__compat.c b/net/ntp/files/patch-libntp_libssl__compat.c
new file mode 100644
index 000000000000..14117da9c86e
--- /dev/null
+++ b/net/ntp/files/patch-libntp_libssl__compat.c
@@ -0,0 +1,11 @@
+--- libntp/libssl_compat.c.orig 2016-11-21 12:28:40 UTC
++++ libntp/libssl_compat.c
+@@ -23,7 +23,7 @@
+ #include "ntp_types.h"
+
+ /* ----------------------------------------------------------------- */
+-#if OPENSSL_VERSION_NUMBER < 0x10100000L
++#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
+ /* ----------------------------------------------------------------- */
+
+ #include "libssl_compat.h"