aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-06-09 14:55:48 +0800
committermarcus <marcus@FreeBSD.org>2004-06-09 14:55:48 +0800
commit0d8ae16c8a63869d0d757c1a31e7d0c4e234f13e (patch)
treefef55e0b6f153339a1976155ac48bd457f2e2d7f /net
parentca80cd83bc0fc6863e065e4e1434b478a21caa64 (diff)
downloadfreebsd-ports-gnome-0d8ae16c8a63869d0d757c1a31e7d0c4e234f13e.tar.gz
freebsd-ports-gnome-0d8ae16c8a63869d0d757c1a31e7d0c4e234f13e.tar.zst
freebsd-ports-gnome-0d8ae16c8a63869d0d757c1a31e7d0c4e234f13e.zip
Do not escape HTML messages in ICQ if the message beings with <HTML>. This
works around a bug with messages sent by the sim client where they would be displayed as: <HTML><BODY BGCOLOR="#FFFFFF">hello</BODY></HTML> Submitted by: ale
Diffstat (limited to 'net')
-rw-r--r--net/gaim/Makefile1
-rw-r--r--net/gaim/files/patch-src_protocols_oscar_oscar.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/net/gaim/Makefile b/net/gaim/Makefile
index 9baad7faba59..484c89f2ee94 100644
--- a/net/gaim/Makefile
+++ b/net/gaim/Makefile
@@ -6,6 +6,7 @@
PORTNAME= gaim
PORTVERSION= 0.78
+PORTREVISION= 1
CATEGORIES?= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/net/gaim/files/patch-src_protocols_oscar_oscar.c b/net/gaim/files/patch-src_protocols_oscar_oscar.c
new file mode 100644
index 000000000000..050faa3b1966
--- /dev/null
+++ b/net/gaim/files/patch-src_protocols_oscar_oscar.c
@@ -0,0 +1,11 @@
+--- src/protocols/oscar/oscar.c.orig Tue Jun 1 18:12:11 2004
++++ src/protocols/oscar/oscar.c Tue Jun 1 18:12:58 2004
+@@ -3127,7 +3127,7 @@
+ * Note: There *may* be some clients which send messages as HTML formatted -
+ * they need to be special-cased somehow.
+ */
+- if (isdigit(gaim_account_get_username(account)[0]) && isdigit(userinfo->sn[0])) {
++ if (isdigit(gaim_account_get_username(account)[0]) && isdigit(userinfo->sn[0]) && g_strncasecmp(tmp, "<HTML>", 6)) {
+ /* being recevied by ICQ from ICQ - escape HTML so it is displayed as sent */
+ gchar *tmp2 = gaim_escape_html(tmp);
+ g_free(tmp);