aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-10-02 23:45:42 +0800
committerbapt <bapt@FreeBSD.org>2014-10-02 23:45:42 +0800
commit0fea042de7b24808208e631d116bb57cd4490404 (patch)
treed1992afb0ac4f57c43b3ac3822f493079d7ed64f /net
parent6b859cc41de6510e43e9c9416ae7837bcbf05b05 (diff)
downloadfreebsd-ports-gnome-0fea042de7b24808208e631d116bb57cd4490404.tar.gz
freebsd-ports-gnome-0fea042de7b24808208e631d116bb57cd4490404.tar.zst
freebsd-ports-gnome-0fea042de7b24808208e631d116bb57cd4490404.zip
Make sure the package respect SRC_BASE
Use the kmod framework Cleanup the plist Reported by: glebius
Diffstat (limited to 'net')
-rw-r--r--net/aoe/Makefile16
-rw-r--r--net/aoe/pkg-plist1
2 files changed, 6 insertions, 11 deletions
diff --git a/net/aoe/Makefile b/net/aoe/Makefile
index d7a64bee99a3..0f881b84a406 100644
--- a/net/aoe/Makefile
+++ b/net/aoe/Makefile
@@ -3,6 +3,7 @@
PORTNAME= aoe
PORTVERSION= 1.2.0
+PORTREVISION= 1
CATEGORIES= net kld
MASTER_SITES= http://www.son.org/download/
DISTNAME= ${PORTNAME}-freebsd-${PORTVERSION}
@@ -10,22 +11,17 @@ DISTNAME= ${PORTNAME}-freebsd-${PORTVERSION}
MAINTAINER= fjoe@FreeBSD.org
COMMENT= FreeBSD driver for ATA over Ethernet (AoE)
-NO_PACKAGE= Should be in sync with the kernel to work correctly
SSP_UNSAFE= kernel module does not support ssp
+USES= kmod
+
WRKSRC= ${WRKDIR}/dev/aoe
-USE_RC_SUBR= aoe
+KMODDIR= ${PREFIX}/lib/aoe
-pre-everything::
- @if [ ! -f /usr/src/sys/Makefile ]; then \
- ${ECHO_MSG} ">> The AoE port needs FreeBSD kernel source code to compile."; \
- ${ECHO_MSG} ">> Please install FreeBSD kernel source code in /usr/src/sys."; \
- ${FALSE}; \
- fi
+USE_RC_SUBR= aoe
do-install:
- ${MKDIR} ${STAGEDIR}${PREFIX}/lib/aoe
${INSTALL_KLD} ${WRKSRC}/aoe.ko ${STAGEDIR}${PREFIX}/lib/aoe
- ${INSTALL_MAN} ${WRKDIR}/aoe.4 ${STAGEDIR}${PREFIX}/man/man4
+ ${INSTALL_MAN} ${WRKDIR}/aoe.4 ${STAGEDIR}${PREFIX}/man/man4/
.include <bsd.port.mk>
diff --git a/net/aoe/pkg-plist b/net/aoe/pkg-plist
index 15d0f2a370a7..ba1e9b40aa4e 100644
--- a/net/aoe/pkg-plist
+++ b/net/aoe/pkg-plist
@@ -1,3 +1,2 @@
lib/aoe/aoe.ko
man/man4/aoe.4.gz
-@dirrm lib/aoe