aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2009-02-27 13:28:08 +0800
committermarcus <marcus@FreeBSD.org>2009-02-27 13:28:08 +0800
commit1059fd4ebf6cf8f1015eca98d41932b4e844072e (patch)
tree7f903a7e5d394a238f11770547a1009d9082b5aa /net
parentf2c9ce306373518c1143a7c37bfac7349a58f2cb (diff)
downloadfreebsd-ports-gnome-1059fd4ebf6cf8f1015eca98d41932b4e844072e.tar.gz
freebsd-ports-gnome-1059fd4ebf6cf8f1015eca98d41932b4e844072e.tar.zst
freebsd-ports-gnome-1059fd4ebf6cf8f1015eca98d41932b4e844072e.zip
Add libproxy-gnome, a plug-in which allows GNOME applications to make use
of libproxy.
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/libproxy-gnome/Makefile30
-rw-r--r--net/libproxy-gnome/pkg-descr7
-rw-r--r--net/libproxy-gnome/pkg-plist1
4 files changed, 39 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index d82441f5eb76..9afe78504f8e 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -302,6 +302,7 @@
SUBDIR += libpcap
SUBDIR += libpcapnav
SUBDIR += libproxy
+ SUBDIR += libproxy-gnome
SUBDIR += librsync
SUBDIR += libsocket++
SUBDIR += libsocketcpp
diff --git a/net/libproxy-gnome/Makefile b/net/libproxy-gnome/Makefile
new file mode 100644
index 000000000000..38ebe8c816d0
--- /dev/null
+++ b/net/libproxy-gnome/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: libproxy-gnome
+# Date created: 26 February 2009
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTREVISION= 0
+CATEGORIES= net devel
+PKGNAMESUFFIX= -gnome
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= GNOME plug-in for libproxy
+
+LIB_DEPENDS= proxy.0:${PORTSDIR}/net/libproxy
+
+MASTERDIR= ${.CURDIR}/../libproxy
+BUILD_WRKSRC= ${WRKSRC}/src/plugins
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+DESCR= ${.CURDIR}/pkg-descr
+PLIST= ${.CURDIR}/pkg-plist
+USE_XORG= xmu x11
+USE_GNOME= gconf2
+CONFIGURE_ARGS=--with-gnome --without-kde --without-webkit \
+ --without-mozjs --without-networkmanager --without-python \
+ --without-envvar --without-file
+
+LIBPROXY_SLAVE= yes
+
+.include "${MASTERDIR}/Makefile"
diff --git a/net/libproxy-gnome/pkg-descr b/net/libproxy-gnome/pkg-descr
new file mode 100644
index 000000000000..60ce67f8faae
--- /dev/null
+++ b/net/libproxy-gnome/pkg-descr
@@ -0,0 +1,7 @@
+Libproxy exists to answer the question: Given a network resource, how do I
+reach it? It handles all the details, enabling you to get back to
+programming.
+
+This plug-in allows the GNOME Desktop to make use of libproxy.
+
+WWW: http://code.google.com/p/libproxy/
diff --git a/net/libproxy-gnome/pkg-plist b/net/libproxy-gnome/pkg-plist
new file mode 100644
index 000000000000..0ee9c67e3789
--- /dev/null
+++ b/net/libproxy-gnome/pkg-plist
@@ -0,0 +1 @@
+lib/libproxy/%%VERSION%%/plugins/gnome.so