aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2013-08-05 23:05:29 +0800
committeraz <az@FreeBSD.org>2013-08-05 23:05:29 +0800
commit12549b30c2eef8132a2851d6f17e8c45a3491872 (patch)
tree6094da914716107bca7d35889c1b8aab5e6097c7 /net
parent7e71988ad884bca5467171d41d1f68fd7040697b (diff)
downloadfreebsd-ports-gnome-12549b30c2eef8132a2851d6f17e8c45a3491872.tar.gz
freebsd-ports-gnome-12549b30c2eef8132a2851d6f17e8c45a3491872.tar.zst
freebsd-ports-gnome-12549b30c2eef8132a2851d6f17e8c45a3491872.zip
- Convert to new perl framework
- Trim Makefile header Approved by: tobez@ (maintainer)
Diffstat (limited to 'net')
-rw-r--r--net/p5-Geo-IPfree/Makefile3
-rw-r--r--net/p5-Net-HTTPS-Any/Makefile3
-rw-r--r--net/p5-NetAddr-IP-Count/Makefile9
3 files changed, 7 insertions, 8 deletions
diff --git a/net/p5-Geo-IPfree/Makefile b/net/p5-Geo-IPfree/Makefile
index 5064e78d48a8..2b49f8abf558 100644
--- a/net/p5-Geo-IPfree/Makefile
+++ b/net/p5-Geo-IPfree/Makefile
@@ -12,7 +12,8 @@ COMMENT= Look up country from an IP Address
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Geo::IPfree.3
diff --git a/net/p5-Net-HTTPS-Any/Makefile b/net/p5-Net-HTTPS-Any/Makefile
index 23b12b5f81f0..4fdcd76e9614 100644
--- a/net/p5-Net-HTTPS-Any/Makefile
+++ b/net/p5-Net-HTTPS-Any/Makefile
@@ -15,7 +15,8 @@ BUILD_DEPENDS= p5-Tie-IxHash>=0:${PORTSDIR}/devel/p5-Tie-IxHash \
p5-Net-SSLeay>=1.30:${PORTSDIR}/security/p5-Net-SSLeay
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::HTTPS::Any.3
diff --git a/net/p5-NetAddr-IP-Count/Makefile b/net/p5-NetAddr-IP-Count/Makefile
index 27ede994e762..6de51a989fb0 100644
--- a/net/p5-NetAddr-IP-Count/Makefile
+++ b/net/p5-NetAddr-IP-Count/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: net-mgmt/p5-NetAddr-IP-Count
-# Date created: 29 March 2001
-# Whom: Anton Berezin <tobez@tobez.org>
-#
+# Created by: Anton Berezin <tobez@tobez.org>
# $FreeBSD$
-#
PORTNAME= NetAddr-IP-Count
PORTVERSION= 2.01
@@ -17,7 +13,8 @@ COMMENT= NetAddr::IP::Count - Count hosts in named subnets
BUILD_DEPENDS= p5-NetAddr-IP>0:${PORTSDIR}/net-mgmt/p5-NetAddr-IP
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= NetAddr::IP::Count.3