aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-09-05 18:26:41 +0800
committerbapt <bapt@FreeBSD.org>2013-09-05 18:26:41 +0800
commit131e0f4afb25e1b1cda0fa2ee5d894f875dab3a1 (patch)
tree1c21231160e0c492dfcf1f9375001555cfddd231 /net
parent88594e345c3dacded0874fdce8242d3c7e00bdd2 (diff)
downloadfreebsd-ports-gnome-131e0f4afb25e1b1cda0fa2ee5d894f875dab3a1.tar.gz
freebsd-ports-gnome-131e0f4afb25e1b1cda0fa2ee5d894f875dab3a1.tar.zst
freebsd-ports-gnome-131e0f4afb25e1b1cda0fa2ee5d894f875dab3a1.zip
Fix build on head with iconv in libc
Diffstat (limited to 'net')
-rw-r--r--net/netatalk/Makefile9
-rw-r--r--net/netatalk3/Makefile9
2 files changed, 13 insertions, 5 deletions
diff --git a/net/netatalk/Makefile b/net/netatalk/Makefile
index 7a266ef509d6..23ce7f2ec0e9 100644
--- a/net/netatalk/Makefile
+++ b/net/netatalk/Makefile
@@ -21,7 +21,6 @@ USE_RC_SUBR= netatalk
CONFIGURE_ARGS+= --with-tcp-wrappers \
--with-pkgconfdir=${PREFIX}/etc \
- --with-libiconv=${LOCALBASE} \
--with-libgcrypt-dir=${LOCALBASE} \
--with-uams-path=${PREFIX}/libexec/netatalk-uams \
--with-bdb=${LOCALBASE}
@@ -120,6 +119,12 @@ CONFIGURE_ARGS+= --enable-sendfile
CONFIGURE_ARGS+= --disable-sendfile
.endif
+.include <bsd.port.pre.mk>
+
+.if !empty(ICONV_LIB)
+CONFIGURE_ARGS= --with-libiconv=${LOCALBASE}
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|%%DB_NAME%%|${BDB_INCLUDE_DIR:T}| ; \
s|%%DB_LIB%%|-l${BDB_LIB_NAME}|g ; \
@@ -141,4 +146,4 @@ post-install:
.endfor
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net/netatalk3/Makefile b/net/netatalk3/Makefile
index ec987b6cdb7f..e9a955d69017 100644
--- a/net/netatalk3/Makefile
+++ b/net/netatalk3/Makefile
@@ -24,7 +24,6 @@ USE_RC_SUBR= netatalk
CONFIGURE_ARGS+= --enable-tcp-wrappers \
--with-pkgconfdir=${PREFIX}/etc \
- --with-libiconv=${LOCALBASE} \
--with-libgcrypt-dir=${LOCALBASE} \
--with-uams-path=${PREFIX}/libexec/netatalk-uams \
--with-bdb=${LOCALBASE} \
@@ -51,8 +50,6 @@ MAN8= afpd.8 cnid_dbd.8 cnid_metad.8 netatalk.8
CONFLICTS= bigloo-2.* cap-6.0.* tct-1.* netatalk-[12]* yudit-[0-9]*
-.include <bsd.port.pre.mk>
-
.if ${PORT_OPTIONS:MKRB5}
CONFIGURE_ARGS+= --enable-krbV-uam
PLIST_SUB+= NETATALKKRB5=""
@@ -119,6 +116,12 @@ PLIST_SUB+= ATFUNCS="@comment "
PLIST_SUB+= ATFUNCS=""
.endif
+.include <bsd.port.pre.mk>
+
+.if !empty(ICONV_LIB)
+CONFIGURE_ARGS= --with-libiconv=${LOCALBASE}
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|%%DB_NAME%%|${BDB_INCLUDE_DIR:T}| ; \
s|%%DB_LIB%%|-l${BDB_LIB_NAME}|g ; \