aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2001-03-31 11:43:44 +0800
committerwill <will@FreeBSD.org>2001-03-31 11:43:44 +0800
commit13d73ec8794b478e5c4e224a0879361c11c430ca (patch)
tree34386c7ccb89df70d063bd8e5ac1c7f12ef4d606 /net
parent4966e088645d18253bdb398ac894faaa8eff1dd7 (diff)
downloadfreebsd-ports-gnome-13d73ec8794b478e5c4e224a0879361c11c430ca.tar.gz
freebsd-ports-gnome-13d73ec8794b478e5c4e224a0879361c11c430ca.tar.zst
freebsd-ports-gnome-13d73ec8794b478e5c4e224a0879361c11c430ca.zip
Add aim-transport 0.9.0, AIM Transport for Jabber server.
PR: 25086 Submitted by: Yen-Ming Lee <leeym@cae.ce.ntu.edu.tw>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/aim-transport/Makefile36
-rw-r--r--net/aim-transport/distinfo1
-rw-r--r--net/aim-transport/pkg-comment1
-rw-r--r--net/aim-transport/pkg-descr16
-rw-r--r--net/aim-transport/pkg-plist2
6 files changed, 57 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index de999a5fa852..974c1651367b 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -9,6 +9,7 @@
SUBDIR += adns
SUBDIR += aggregate
SUBDIR += aim
+ SUBDIR += aim-transport
SUBDIR += airport
SUBDIR += amcl
SUBDIR += archie
diff --git a/net/aim-transport/Makefile b/net/aim-transport/Makefile
new file mode 100644
index 000000000000..46e474a86217
--- /dev/null
+++ b/net/aim-transport/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: aim-transport
+# Date created: 04 December 2000
+# Whom: Yen-Ming Lee <leeym@cae.ce.ntu.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= aim-transport
+PORTVERSION= 0.9.0
+CATEGORIES= net
+MASTER_SITES= http://download.jabber.org/dists/1.4/final/
+
+MAINTAINER= leeym@cae.ce.ntu.edu.tw
+
+BUILD_DEPENDS= ${NONEXISTENT}:${JABBER_PORT}:configure
+RUN_DEPENDS= jabberd:${JABBER_PORT}
+
+.include <bsd.port.pre.mk>
+
+JABBER_PORT= ${PORTSDIR}/net/jabber
+JABBER_WRKSRC!= cd ${JABBER_PORT} && ${MAKE} -V WRKSRC
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-jabberd=${JABBER_WRKSRC}/jabberd
+
+do-install:
+ @${MKDIR} ${PREFIX}/lib/jabber/${PORTNAME}
+ @${INSTALL_PROGRAM} ${WRKSRC}/src/aimtrans.so ${PREFIX}/lib/jabber/${PORTNAME}
+ @${ECHO} ""
+ @${ECHO} "============================================================================="
+ @${ECHO} "Please read ${WRKSRC}/README first"
+ @${ECHO} "and add \"./${PORTNAME}/aimtrans.so\" into ${PREFIX}/etc/jabber.xml"
+ @${ECHO} "then restart jabberd to enable ${PORTNAME}"
+ @${ECHO} "============================================================================="
+ @${ECHO} ""
+
+.include <bsd.port.post.mk>
diff --git a/net/aim-transport/distinfo b/net/aim-transport/distinfo
new file mode 100644
index 000000000000..c86d5dc30976
--- /dev/null
+++ b/net/aim-transport/distinfo
@@ -0,0 +1 @@
+MD5 (aim-transport-0.9.0.tar.gz) = 16af3cdaa008a30079f5a89ecc4dbc90
diff --git a/net/aim-transport/pkg-comment b/net/aim-transport/pkg-comment
new file mode 100644
index 000000000000..a5b0d431efb2
--- /dev/null
+++ b/net/aim-transport/pkg-comment
@@ -0,0 +1 @@
+AIM Transport for Jabber server
diff --git a/net/aim-transport/pkg-descr b/net/aim-transport/pkg-descr
new file mode 100644
index 000000000000..938404ee844b
--- /dev/null
+++ b/net/aim-transport/pkg-descr
@@ -0,0 +1,16 @@
+AIM-Transport 0.9
+-----------------
+
+This version of the AIM Transport is designed specifically to work with the
+Jabber server version 1.4. It will not work with previous versions due to the
+way that it loads itself into the main jabberd binary.
+
+To build the AIM Transport uncompress the tarball, if you uncompressed it into
+the Jabber 1.4 directory you can run the configure directly and it will find
+jabberd. Otherwise, you need to use the --with-jabberd=PATH option to
+configure. At this point you can run make and it should build just fine. Note
+this version of the AIM Transport no longer requires a seperate download of
+libfaim.
+
+--
+Yen-Ming Lee <leeym@cae.ce.ntu.edu.tw>
diff --git a/net/aim-transport/pkg-plist b/net/aim-transport/pkg-plist
new file mode 100644
index 000000000000..2c29bd1c2e58
--- /dev/null
+++ b/net/aim-transport/pkg-plist
@@ -0,0 +1,2 @@
+lib/jabber/aim-transport/aimtrans.so
+@dirrm lib/jabber/aim-transport