aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2008-02-08 01:18:48 +0800
committerrafan <rafan@FreeBSD.org>2008-02-08 01:18:48 +0800
commit146f4d0fe0aec1ba7dd044f63456983458dd17d7 (patch)
tree1735ad637d61f7295c799d22b0821f6ee2fbafdd /net
parentfc9b8977fe84b42377476ba38a70cd64428f093c (diff)
downloadfreebsd-ports-gnome-146f4d0fe0aec1ba7dd044f63456983458dd17d7.tar.gz
freebsd-ports-gnome-146f4d0fe0aec1ba7dd044f63456983458dd17d7.tar.zst
freebsd-ports-gnome-146f4d0fe0aec1ba7dd044f63456983458dd17d7.zip
- Update to 2.0 RC1 which works with Asterisk 1.4
PR: ports/117475 Submitted by: Mayo Jordanov <mayo at oyam.ca> (maintainer)
Diffstat (limited to 'net')
-rw-r--r--net/asterisk-app-notify/Makefile15
-rw-r--r--net/asterisk-app-notify/distinfo6
-rw-r--r--net/asterisk-app-notify/files/patch-Makefile40
-rw-r--r--net/asterisk-app-notify/files/patch-cflags.sh12
-rw-r--r--net/asterisk-app-notify/pkg-message6
-rw-r--r--net/asterisk-app-notify/pkg-plist7
6 files changed, 39 insertions, 47 deletions
diff --git a/net/asterisk-app-notify/Makefile b/net/asterisk-app-notify/Makefile
index 64049fa3fec6..88aacbe53c19 100644
--- a/net/asterisk-app-notify/Makefile
+++ b/net/asterisk-app-notify/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= app_notify
-PORTVERSION= 1.0
-PORTREVISION= 1
+DISTVERSION= 2.0rc1
CATEGORIES= net
MASTER_SITES= http://www.mezzo.net/asterisk/ \
http://static.oyam.ca/freebsd/ports/
@@ -16,20 +15,12 @@ EXTRACT_SUFX= .tgz
MAINTAINER= mayo@oyam.ca
COMMENT= Notify application module for the Asterisk PBX
-BUILD_DEPENDS= asterisk:${PORTSDIR}/net/asterisk12
-RUN_DEPENDS= asterisk:${PORTSDIR}/net/asterisk12
+BUILD_DEPENDS= asterisk:${PORTSDIR}/net/asterisk
+RUN_DEPENDS= asterisk:${PORTSDIR}/net/asterisk
USE_GMAKE= yes
-ASTETCDIR= ${PREFIX}/etc/asterisk
-
-pre-install:
- ${MKDIR} ${ASTETCDIR}
-
post-install:
- @if [ ! -f ${ASTETCDIR}/dialer_extensions.conf ]; then \
- ${CP} -p ${ASTETCDIR}/dialer_extensions.conf.sample ${ASTETCDIR}/dialer_extensions.conf ; \
- fi
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/net/asterisk-app-notify/distinfo b/net/asterisk-app-notify/distinfo
index 606955c01234..cd9e2a4983c0 100644
--- a/net/asterisk-app-notify/distinfo
+++ b/net/asterisk-app-notify/distinfo
@@ -1,3 +1,3 @@
-MD5 (app_notify-1.0.tgz) = a2f4bf2b6f306c0a60086e98265571a3
-SHA256 (app_notify-1.0.tgz) = 84d219c9ad2eed6c19a35e491f631428bd367cce4e736d973c762380378c29c0
-SIZE (app_notify-1.0.tgz) = 3839
+MD5 (app_notify-2.0rc1.tgz) = 0522cc76705bd11e943f309ae5c4a03f
+SHA256 (app_notify-2.0rc1.tgz) = b3eb3a7b1f567c9bb0d44406d3425de3062194411d0559f2c9c547926e3ad0cf
+SIZE (app_notify-2.0rc1.tgz) = 4053
diff --git a/net/asterisk-app-notify/files/patch-Makefile b/net/asterisk-app-notify/files/patch-Makefile
index 8dc2cee71eb8..31370c7b29f0 100644
--- a/net/asterisk-app-notify/files/patch-Makefile
+++ b/net/asterisk-app-notify/files/patch-Makefile
@@ -1,33 +1,27 @@
---- Makefile.orig Fri Mar 23 21:14:57 2007
-+++ Makefile Sat Mar 24 00:09:09 2007
-@@ -9,7 +9,7 @@
- NAME=app_notify
- CONF=dialer_extensions.conf
+--- Makefile.orig Thu Feb 1 04:08:39 2007
++++ Makefile Thu Oct 25 00:05:18 2007
+@@ -7,6 +7,7 @@
+ #
--CFLAGS=-g -Wall -D_REENTRANT -D_GNU_SOURCE -fPIC
-+CFLAGS+= -g -Wall -D_REENTRANT -D_GNU_SOURCE -fPIC -I$(LOCALBASE)/include
- LIBS=
- RES=$(NAME).so
+ NAME=app_notify
++CONF=extensions_dialer.conf
-@@ -19,7 +19,7 @@
- SOLINK=-shared -Xlinker -x
+ CC=gcc
+ CFLAGS=$(shell ./cflags.sh)
+@@ -21,7 +22,7 @@
+ CC=gcc -arch ppc -arch i386
+ else
+ SOLINK=-shared -Xlinker -x
+- MODULES_DIR=/usr/lib/asterisk/modules
++ MODULES_DIR=$(LOCALBASE)/lib/asterisk/modules
endif
--MODULES_DIR=/usr/lib/asterisk/modules
-+MODULES_DIR=$(PREFIX)/lib/asterisk/modules
-
- app_notify.so : app_notify.o
- $(CC) $(SOLINK) -o $@ $<
-@@ -30,10 +30,9 @@
+ RES=$(NAME).so
+@@ -35,6 +36,7 @@
rm -f $(NAME).o $(NAME).so notifyClient.o notifyClient sampleClient
install: all
-- if ! [ -f /etc/asterisk/$(CONF) ]; then \
-- install -m 644 $(CONF).sample /etc/asterisk/$(CONF) ; \
-- fi
-+ install -m 644 $(CONF).sample $(PREFIX)/etc/asterisk/$(CONF).sample ; \
++ install -m 644 $(CONF).sample $(LOCALBASE)/etc/asterisk/$(CONF).sample ; \
if [ -f $(NAME).so ]; then \
-+ mkdir -p $(MODULES_DIR) ; \
install -m 755 $(NAME).so $(MODULES_DIR) ; \
fi
-
diff --git a/net/asterisk-app-notify/files/patch-cflags.sh b/net/asterisk-app-notify/files/patch-cflags.sh
new file mode 100644
index 000000000000..15483921b9b4
--- /dev/null
+++ b/net/asterisk-app-notify/files/patch-cflags.sh
@@ -0,0 +1,12 @@
+--- cflags.sh.orig Wed Oct 24 23:37:00 2007
++++ cflags.sh Wed Oct 24 23:31:46 2007
+@@ -8,7 +8,8 @@
+ INCDIR=/Library/Asterisk/include
+ CFLAGS="${CFLAGS} -I/Library/Asterisk/include"
+ else
+- INCDIR=/usr/include
++ INCDIR=${LOCALBASE}/include
++ CFLAGS="${CFLAGS} -I${INCDIR}"
+ fi
+
+ CHANNEL_H=${INCDIR}/asterisk/channel.h
diff --git a/net/asterisk-app-notify/pkg-message b/net/asterisk-app-notify/pkg-message
index 647978adf41e..6b1a948a654b 100644
--- a/net/asterisk-app-notify/pkg-message
+++ b/net/asterisk-app-notify/pkg-message
@@ -3,12 +3,12 @@
a) If this is a new install, restart Asterisk or activate the module by
running:
- # asterisk -rx "load app_notify"
+ # asterisk -rx "module load app_notify"
b) If this is an upgrade, you can restart Asterisk or reload the module by
running:
- # asterisk -rx "unload app_notify"
- # asterisk -rx "load app_notify"
+ # asterisk -rx "module unload app_notify"
+ # asterisk -rx "module load app_notify"
*****************************************************************************
diff --git a/net/asterisk-app-notify/pkg-plist b/net/asterisk-app-notify/pkg-plist
index fbbfd84e38c1..58e21b95faf0 100644
--- a/net/asterisk-app-notify/pkg-plist
+++ b/net/asterisk-app-notify/pkg-plist
@@ -1,7 +1,2 @@
-@unexec if cmp -s %D/etc/asterisk/dialer_extensions.conf.sample %D/etc/asterisk/dialer_extensions.conf; then rm -f %D/etc/asterisk/dialer_extensions.conf; fi
-etc/asterisk/dialer_extensions.conf.sample
-@exec if [ ! -f %D/etc/asterisk/dialer_extensions.conf ] ; then cp -p %D/%F %B/dialer_extensions.conf; fi
+etc/asterisk/extensions_dialer.conf.sample
lib/asterisk/modules/app_notify.so
-@dirrmtry lib/asterisk/modules
-@dirrmtry lib/asterisk
-@dirrmtry etc/asterisk