aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2017-10-23 20:20:36 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2018-02-04 05:48:17 +0800
commit16f0880db53f83424bcb176f3b20ae3aac6a7ab9 (patch)
treed1fd0ccf9cb90ca49196e68669e34c3f0bf86d14 /net
parentf97659f58c27228b141a5040d9ac3213771df1ef (diff)
downloadfreebsd-ports-gnome-16f0880db53f83424bcb176f3b20ae3aac6a7ab9.tar.gz
freebsd-ports-gnome-16f0880db53f83424bcb176f3b20ae3aac6a7ab9.tar.zst
freebsd-ports-gnome-16f0880db53f83424bcb176f3b20ae3aac6a7ab9.zip
Pull deviceatlas library from a (recently created) separate port.
Submitted by: David Carlier <dcarlier@afilias.info>
Diffstat (limited to 'net')
-rw-r--r--net/haproxy-devel/Makefile16
-rw-r--r--net/haproxy-devel/distinfo4
-rw-r--r--net/haproxy/Makefile16
-rw-r--r--net/haproxy/distinfo4
4 files changed, 6 insertions, 34 deletions
diff --git a/net/haproxy-devel/Makefile b/net/haproxy-devel/Makefile
index 3452ce1aa763..569c822b6905 100644
--- a/net/haproxy-devel/Makefile
+++ b/net/haproxy-devel/Makefile
@@ -20,10 +20,6 @@ CONFLICTS_INSTALL= haproxy-[1234567890]\*
USES= cpe gmake
USE_RC_SUBR= haproxy
-DEVICEATLAS_VERSION= 2.1.2_2
-DEVICEATLAS_DISTFILE= deviceatlas-enterprise-c-${DEVICEATLAS_VERSION}
-DEVICEATLAS_REGISTRATION_URL= https://deviceatlas.com/deviceatlas-haproxy-module
-
MAKE_ARGS= TARGET=freebsd DEFINE=-DFREEBSD_PORTS USE_GETADDRINFO=1 \
USE_ZLIB=1 USE_CPU_AFFINITY=1 USE_ACCEPT4=1 \
CC="${CC}" DEBUG_CFLAGS="" CPU_CFLAGS="${CFLAGS}"
@@ -49,16 +45,8 @@ MAKE_ARGS+= USE_PCRE=1 USE_STATIC_PCRE=1 USE_PCRE_JIT=1
.endif
.if ${PORT_OPTIONS:MDEVICEATLAS}
-.if !exists(${DISTDIR}/${DEVICEATLAS_DISTFILE}.tgz)
-IGNORE?= you must manually fetch the DeviceAtlas Device Detection C API from ${DEVICEATLAS_REGISTRATION_URL} and place it in ${DISTDIR} and then run make again
-.else
-RESTRICTED= The redistribution of the DeviceAtlas Device Detection C API is not permitted
-DISTFILES+= ${DEVICEATLAS_DISTFILE}.tgz
-MAKE_ARGS+= USE_DEVICEATLAS=1 DEVICEATLAS_SRC=${WRKDIR}/deviceatlas-enterprise-c-${DEVICEATLAS_VERSION}/Src
-.endif
-.if ! ${PORT_OPTIONS:MDPCRE} && ! ${PORT_OPTIONS:MSPCRE}
-IGNORE?= enable PCRE support to use DeviceAtlas
-.endif
+LIB_DEPENDS+= libda.so:net/deviceatlas-enterprise-c
+MAKE_ARGS+= USE_DEVICEATLAS=1 DEVICEATLAS_LIB=${LOCALBASE}/lib DEVICEATLAS_INC=${LOCALBASE}/include
.endif
.if ${PORT_OPTIONS:MOPENSSL}
diff --git a/net/haproxy-devel/distinfo b/net/haproxy-devel/distinfo
index 3bb0d25df3e0..329efaf199fd 100644
--- a/net/haproxy-devel/distinfo
+++ b/net/haproxy-devel/distinfo
@@ -1,5 +1,3 @@
-TIMESTAMP = 1504203934
+TIMESTAMP = 1508748419
SHA256 (haproxy-1.8-dev2.tar.gz) = 45f42107e8730fc7bf324523d148d67aae6a65f0d4a4b981273d3dcefd6de2e1
SIZE (haproxy-1.8-dev2.tar.gz) = 1850881
-SHA256 (deviceatlas-enterprise-c-2.1.2_2.tgz) = feaa9198a5d6bed125b34742bd626ad0a0fcb862803916cd7d974413f8bdfdce
-SIZE (deviceatlas-enterprise-c-2.1.2_2.tgz) = 184368
diff --git a/net/haproxy/Makefile b/net/haproxy/Makefile
index 81ac0852b88d..3df24cc28e09 100644
--- a/net/haproxy/Makefile
+++ b/net/haproxy/Makefile
@@ -18,10 +18,6 @@ CONFLICTS_INSTALL= haproxy-devel-[0-9]*
USES= cpe gmake
USE_RC_SUBR= haproxy
-DEVICEATLAS_VERSION= 2.1.2_2
-DEVICEATLAS_DISTFILE= deviceatlas-enterprise-c-${DEVICEATLAS_VERSION}
-DEVICEATLAS_REGISTRATION_URL= https://deviceatlas.com/deviceatlas-haproxy-module
-
MAKE_ARGS= TARGET=freebsd DEFINE=-DFREEBSD_PORTS USE_GETADDRINFO=1 \
USE_ZLIB=1 USE_CPU_AFFINITY=1 USE_ACCEPT4=1 \
CC="${CC}" DEBUG_CFLAGS="" CPU_CFLAGS="${CFLAGS}"
@@ -47,16 +43,8 @@ MAKE_ARGS+= USE_PCRE=1 USE_STATIC_PCRE=1 USE_PCRE_JIT=1
.endif
.if ${PORT_OPTIONS:MDEVICEATLAS}
-.if !exists(${DISTDIR}/${DEVICEATLAS_DISTFILE}.tgz)
-IGNORE?= you must manually fetch the DeviceAtlas Device Detection C API from ${DEVICEATLAS_REGISTRATION_URL} and place it in ${DISTDIR} and then run make again
-.else
-RESTRICTED= The redistribution of the DeviceAtlas Device Detection C API is not permitted
-DISTFILES+= ${DEVICEATLAS_DISTFILE}.tgz
-MAKE_ARGS+= USE_DEVICEATLAS=1 DEVICEATLAS_SRC=${WRKDIR}/deviceatlas-enterprise-c-${DEVICEATLAS_VERSION}/Src
-.endif
-.if ! ${PORT_OPTIONS:MDPCRE} && ! ${PORT_OPTIONS:MSPCRE}
-IGNORE?= enable PCRE support to use DeviceAtlas
-.endif
+LIB_DEPENDS+= libda.so:net/deviceatlas-enterprise-c
+MAKE_ARGS+= USE_DEVICEATLAS=1 DEVICEATLAS_LIB=${LOCALBASE}/lib DEVICEATLAS_INC=${LOCALBASE}/include
.endif
.if ${PORT_OPTIONS:MOPENSSL}
diff --git a/net/haproxy/distinfo b/net/haproxy/distinfo
index c9254ff1a197..219d4e336729 100644
--- a/net/haproxy/distinfo
+++ b/net/haproxy/distinfo
@@ -1,5 +1,3 @@
-TIMESTAMP = 1504203902
+TIMESTAMP = 1508749073
SHA256 (haproxy-1.7.9.tar.gz) = 1072337e54fa188dc6e0cfe3ba4c2200b07082e321cbfe5a0882d85d54db068e
SIZE (haproxy-1.7.9.tar.gz) = 1748159
-SHA256 (deviceatlas-enterprise-c-2.1.2_2.tgz) = feaa9198a5d6bed125b34742bd626ad0a0fcb862803916cd7d974413f8bdfdce
-SIZE (deviceatlas-enterprise-c-2.1.2_2.tgz) = 184368