aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2001-01-08 01:49:52 +0800
committerwill <will@FreeBSD.org>2001-01-08 01:49:52 +0800
commit17fc78c61a40e51c25675da0e3d99e222c1abdd3 (patch)
treea8b19a050dd6847de35f8b185751c1b52138d171 /net
parent98a4931c0a8138d6f6fb6de52d4fd949a15ae520 (diff)
downloadfreebsd-ports-gnome-17fc78c61a40e51c25675da0e3d99e222c1abdd3.tar.gz
freebsd-ports-gnome-17fc78c61a40e51c25675da0e3d99e222c1abdd3.tar.zst
freebsd-ports-gnome-17fc78c61a40e51c25675da0e3d99e222c1abdd3.zip
Clean up inefficient perl invocations; use multiple REs in the same call.
Diffstat (limited to 'net')
-rw-r--r--net/p0f/Makefile4
-rw-r--r--net/rsync/Makefile5
2 files changed, 4 insertions, 5 deletions
diff --git a/net/p0f/Makefile b/net/p0f/Makefile
index f5731c383453..af0b6cdc0c8d 100644
--- a/net/p0f/Makefile
+++ b/net/p0f/Makefile
@@ -17,8 +17,8 @@ MAINTAINER= trevor@FreeBSD.org
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
post-patch:
- @${PERL} -pi -e "s=/etc=${PREFIX}/etc=g" ${WRKSRC}/p0f.c
- @${PERL} -pi -e "s=/etc=${PREFIX}/etc=g" ${WRKSRC}/README
+ @${PERL} -pi -e "s=/etc=${PREFIX}/etc=g ; \
+ s=/etc=${PREFIX}/etc=g" ${WRKSRC}/README
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/p0f ${PREFIX}/bin
diff --git a/net/rsync/Makefile b/net/rsync/Makefile
index 4e5048545cb2..fc451450c055 100644
--- a/net/rsync/Makefile
+++ b/net/rsync/Makefile
@@ -34,9 +34,8 @@ MAN1= rsync.1
MAN5= rsyncd.conf.5
pre-configure:
- @${PERL} -pi.orig -e 's:/etc/:${PREFIX}/etc/:g' ${WRKSRC}/rsync.h
- @${PERL} -pi.orig -e 's:/etc/:${PREFIX}/etc/:g' ${WRKSRC}/rsync.1
- @${PERL} -pi.orig -e 's:/etc/:${PREFIX}/etc/:g' ${WRKSRC}/rsyncd.conf.5
+ @${PERL} -pi.orig -e 's:/etc/:${PREFIX}/etc/:g'
+ ${WRKSRC}/rsync.h ${WRKSRC}/rsync.1 ${WRKSRC}/rsyncd.conf.5
.if defined(WITH_SSH)
@${PERL} -pi.orig-rsh -e 's/"rsh"/"ssh"/g' ${WRKSRC}/rsync.h
.endif