aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authordelphij <delphij@FreeBSD.org>2008-07-20 11:35:42 +0800
committerdelphij <delphij@FreeBSD.org>2008-07-20 11:35:42 +0800
commit21b83eda81d1d239741da626f500229206768aba (patch)
treea3424fdf012e5d01f216938fb59a1bd772dc81fe /net
parent0459477dec4afcfa408a595058bc76784e469bd4 (diff)
downloadfreebsd-ports-gnome-21b83eda81d1d239741da626f500229206768aba.tar.gz
freebsd-ports-gnome-21b83eda81d1d239741da626f500229206768aba.tar.zst
freebsd-ports-gnome-21b83eda81d1d239741da626f500229206768aba.zip
- Overhaul the way we handle with LDAP data directory, populate
the data directory upon start, not upon install. [1] - Update to OpenLDAP 2.4.11. - Modify bsd.port.mk to fit with the shared libary version bump [2] This has no impact to package building yet as 2.4.x is not the default version. Submitted by: Mikhail Goriachev <mikhailg webanoide org> [1] Approved by: portmgr (marcus) [2]
Diffstat (limited to 'net')
-rw-r--r--net/openldap24-server/Makefile4
-rw-r--r--net/openldap24-server/distinfo6
-rw-r--r--net/openldap24-server/files/patch-servers::slapd::Makefile.in26
-rw-r--r--net/openldap24-server/files/pkg-deinstall.in12
-rw-r--r--net/openldap24-server/files/slapd.sh.in4
-rw-r--r--net/openldap24-server/pkg-plist30
-rw-r--r--net/openldap24-server/pkg-plist.client6
7 files changed, 49 insertions, 39 deletions
diff --git a/net/openldap24-server/Makefile b/net/openldap24-server/Makefile
index 6c47ae8bcb61..fd4f59f769b1 100644
--- a/net/openldap24-server/Makefile
+++ b/net/openldap24-server/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= openldap
-DISTVERSION= 2.4.10
+DISTVERSION= 2.4.11
PORTREVISION= ${OPENLDAP_PORTREVISION}
CATEGORIES= net databases
MASTER_SITES= ftp://ftp.OpenLDAP.org/pub/OpenLDAP/%SUBDIR%/ \
@@ -39,7 +39,7 @@ BROKEN= incompatible OpenLDAP version: ${WANT_OPENLDAP_VER}
.endif
PORTREVISION_CLIENT= 0
-PORTREVISION_SERVER= 1
+PORTREVISION_SERVER= 0
.if !defined(CLIENT_ONLY)
OPTIONS= SASL "With (Cyrus) SASL2 support" off \
diff --git a/net/openldap24-server/distinfo b/net/openldap24-server/distinfo
index 7caad0301f1c..c729e385897b 100644
--- a/net/openldap24-server/distinfo
+++ b/net/openldap24-server/distinfo
@@ -1,3 +1,3 @@
-MD5 (openldap-2.4.10.tgz) = 519171f3e562bfced7afac7756cf7bf5
-SHA256 (openldap-2.4.10.tgz) = e460b1ef2a7a50ec8d7bd70c29d5cb3191f091fab50b96a7e10454ee8e4d0902
-SIZE (openldap-2.4.10.tgz) = 4453204
+MD5 (openldap-2.4.11.tgz) = 920fedbbb5bc61c2ca52c56edeef770a
+SHA256 (openldap-2.4.11.tgz) = 76e57147a2373015f306f2e72128330e51d5c0f1056b4713283234dfd16c1c9c
+SIZE (openldap-2.4.11.tgz) = 4941654
diff --git a/net/openldap24-server/files/patch-servers::slapd::Makefile.in b/net/openldap24-server/files/patch-servers::slapd::Makefile.in
index 50cec0cf4511..9987a5cd27db 100644
--- a/net/openldap24-server/files/patch-servers::slapd::Makefile.in
+++ b/net/openldap24-server/files/patch-servers::slapd::Makefile.in
@@ -1,6 +1,6 @@
---- servers/slapd/Makefile.in.orig Fri Sep 2 00:28:10 2005
-+++ servers/slapd/Makefile.in Sun Sep 4 17:34:37 2005
-@@ -372,7 +372,6 @@
+--- servers/slapd/Makefile.in.orig 2008-02-11 15:26:43.000000000 -0800
++++ servers/slapd/Makefile.in 2008-07-19 20:10:16.023473779 -0700
+@@ -374,7 +374,6 @@
install-slapd: FORCE
-$(MKDIR) $(DESTDIR)$(libexecdir)
@@ -8,7 +8,7 @@
$(LTINSTALL) $(INSTALLFLAGS) $(STRIP) -m 755 \
slapd$(EXEEXT) $(DESTDIR)$(libexecdir)
@for i in $(SUBDIRS); do \
-@@ -403,16 +402,18 @@
+@@ -405,16 +404,18 @@
touch all-cffiles
install-schema: FORCE
@@ -21,24 +21,24 @@
@SD=$(DESTDIR)$(schemadir) ; \
- files=`cd $(srcdir)/schema ; echo README *.ldif *.schema` ; \
+ files=`cd $(srcdir)/schema ; echo README *.ldif` ; \
-+ for i in $$files ; do \
-+ echo $(INSTALL) $(INSTALLFLAGS) -m 444 schema/$$i $$SD/$$i ; \
-+ $(INSTALL) $(INSTALLFLAGS) -m 444 $(srcdir)/schema/$$i $$SD/$$i ; \
-+ done ; \
-+ files=`cd $(srcdir)/schema ; echo *.schema` ; \
for i in $$files ; do \
echo $(INSTALL) $(INSTALLFLAGS) -m 444 schema/$$i $$SD/$$i ; \
$(INSTALL) $(INSTALLFLAGS) -m 444 $(srcdir)/schema/$$i $$SD/$$i ; \
++ done ; \
++ files=`cd $(srcdir)/schema ; echo *.schema` ; \
++ for i in $$files ; do \
++ echo $(INSTALL) $(INSTALLFLAGS) -m 444 schema/$$i $$SD/$$i ; \
++ $(INSTALL) $(INSTALLFLAGS) -m 444 $(srcdir)/schema/$$i $$SD/$$i ; \
+ $(INSTALL) $(INSTALLFLAGS) -m 444 $(srcdir)/schema/$$i $$SD/$$i.default ; \
done
install-conf: FORCE
-@@ -429,8 +430,6 @@
- install-db-config: FORCE
+@@ -432,8 +433,6 @@
@-$(MKDIR) $(DESTDIR)$(localstatedir) $(DESTDIR)$(sysconfdir)
@-$(INSTALL) -m 700 -d $(DESTDIR)$(localstatedir)/openldap-data
-- $(INSTALL) $(INSTALLFLAGS) -m 600 $(srcdir)/DB_CONFIG \
-- $(DESTDIR)$(localstatedir)/openldap-data/DB_CONFIG.example
$(INSTALL) $(INSTALLFLAGS) -m 600 $(srcdir)/DB_CONFIG \
+- $(DESTDIR)$(localstatedir)/openldap-data/DB_CONFIG.example
+- $(INSTALL) $(INSTALLFLAGS) -m 600 $(srcdir)/DB_CONFIG \
$(DESTDIR)$(sysconfdir)/DB_CONFIG.example
+ install-tools: FORCE
diff --git a/net/openldap24-server/files/pkg-deinstall.in b/net/openldap24-server/files/pkg-deinstall.in
index 2ead1eeb89a9..c3272b14c13a 100644
--- a/net/openldap24-server/files/pkg-deinstall.in
+++ b/net/openldap24-server/files/pkg-deinstall.in
@@ -5,6 +5,10 @@
ECHO_CMD=echo
+if [ -f "%%PREFIX%%/etc/openldap/slapd.conf" ]; then
+ DBDIR=`awk '$1 == "directory" {print $2}' "%%PREFIX%%/etc/openldap/slapd.conf"`
+fi
+
case $2 in
POST-DEINSTALL)
${ECHO_CMD}
@@ -13,9 +17,13 @@ POST-DEINSTALL)
${ECHO_CMD} "it any longer, you may want to issue the"
${ECHO_CMD} "following commands:"
${ECHO_CMD}
- if [ -d %%DATABASEDIR%% ]; then
+ if ([ "${DBDIR}" ] && [ -d "${DBDIR}" ]) || ([ ! "${DBDIR}" ] && [ -d %%DATABASEDIR%% ]); then
${ECHO_CMD} "- to delete the OpenLDAP database permanently (losing all data):"
- ${ECHO_CMD} " rm -Rf %%DATABASEDIR%%"
+ if [ "${DBDIR}" ] && [ -d "${DBDIR}" ]; then
+ ${ECHO_CMD} " rm -Rf ${DBDIR}"
+ else
+ ${ECHO_CMD} " rm -Rf %%DATABASEDIR%%"
+ fi
${ECHO_CMD}
fi
${ECHO_CMD} "- to remove the OpenLDAP user:"
diff --git a/net/openldap24-server/files/slapd.sh.in b/net/openldap24-server/files/slapd.sh.in
index 9c94268474b0..70b5106de23a 100644
--- a/net/openldap24-server/files/slapd.sh.in
+++ b/net/openldap24-server/files/slapd.sh.in
@@ -49,6 +49,10 @@ start_precmd()
""|[Nn][Oo][Nn][Ee]|[Dd][Ee][Ff][Aa][Uu][Ll][Tt])
;;
*)
+ if [ ! -d "${DBDIR}" ]; then
+ mkdir -p "${DBDIR}"
+ cp "%%PREFIX%%/etc/openldap/DB_CONFIG.example" "${DBDIR}/DB_CONFIG"
+ fi
chown "$slapd_owner" "%%LDAP_RUN_DIR%%"
chown -RL "$slapd_owner" "${DBDIR}"
chmod 700 "${DBDIR}"
diff --git a/net/openldap24-server/pkg-plist b/net/openldap24-server/pkg-plist
index b3264d559a7c..8683aab0ea52 100644
--- a/net/openldap24-server/pkg-plist
+++ b/net/openldap24-server/pkg-plist
@@ -14,58 +14,58 @@ etc/openldap/DB_CONFIG.example
%%SLAPI%%lib/libslapi.la
%%SLAPI%%lib/libslapi.so
%%SLAPI%%lib/libslapi-2.4.so
-%%SLAPI%%lib/libslapi-2.4.so.2
+%%SLAPI%%lib/libslapi-2.4.so.3
%%MODULES%%@exec mkdir -p %D/libexec/openldap
%%BACK_BDB%%libexec/openldap/back_bdb-2.4.so
-%%BACK_BDB%%libexec/openldap/back_bdb-2.4.so.2
+%%BACK_BDB%%libexec/openldap/back_bdb-2.4.so.3
%%BACK_BDB%%libexec/openldap/back_bdb.la
%%BACK_BDB%%libexec/openldap/back_bdb.so
%%BACK_HDB%%libexec/openldap/back_hdb-2.4.so
-%%BACK_HDB%%libexec/openldap/back_hdb-2.4.so.2
+%%BACK_HDB%%libexec/openldap/back_hdb-2.4.so.3
%%BACK_HDB%%libexec/openldap/back_hdb.la
%%BACK_HDB%%libexec/openldap/back_hdb.so
%%BACKEND%%libexec/openldap/back_ldap-2.4.so
-%%BACKEND%%libexec/openldap/back_ldap-2.4.so.2
+%%BACKEND%%libexec/openldap/back_ldap-2.4.so.3
%%BACKEND%%libexec/openldap/back_ldap.la
%%BACKEND%%libexec/openldap/back_ldap.so
%%BACKEND%%libexec/openldap/back_meta-2.4.so
-%%BACKEND%%libexec/openldap/back_meta-2.4.so.2
+%%BACKEND%%libexec/openldap/back_meta-2.4.so.3
%%BACKEND%%libexec/openldap/back_meta.la
%%BACKEND%%libexec/openldap/back_meta.so
%%BACKEND%%libexec/openldap/back_monitor-2.4.so
-%%BACKEND%%libexec/openldap/back_monitor-2.4.so.2
+%%BACKEND%%libexec/openldap/back_monitor-2.4.so.3
%%BACKEND%%libexec/openldap/back_monitor.la
%%BACKEND%%libexec/openldap/back_monitor.so
%%BACKEND%%libexec/openldap/back_null-2.4.so
-%%BACKEND%%libexec/openldap/back_null-2.4.so.2
+%%BACKEND%%libexec/openldap/back_null-2.4.so.3
%%BACKEND%%libexec/openldap/back_null.la
%%BACKEND%%libexec/openldap/back_null.so
%%BACK_DNSSRV%%libexec/openldap/back_dnssrv-2.4.so
-%%BACK_DNSSRV%%libexec/openldap/back_dnssrv-2.4.so.2
+%%BACK_DNSSRV%%libexec/openldap/back_dnssrv-2.4.so.3
%%BACK_DNSSRV%%libexec/openldap/back_dnssrv.la
%%BACK_DNSSRV%%libexec/openldap/back_dnssrv.so
%%BACK_PASSWD%%libexec/openldap/back_passwd-2.4.so
-%%BACK_PASSWD%%libexec/openldap/back_passwd-2.4.so.2
+%%BACK_PASSWD%%libexec/openldap/back_passwd-2.4.so.3
%%BACK_PASSWD%%libexec/openldap/back_passwd.la
%%BACK_PASSWD%%libexec/openldap/back_passwd.so
%%BACK_PERL%%libexec/openldap/back_perl-2.4.so
-%%BACK_PERL%%libexec/openldap/back_perl-2.4.so.2
+%%BACK_PERL%%libexec/openldap/back_perl-2.4.so.3
%%BACK_PERL%%libexec/openldap/back_perl.la
%%BACK_PERL%%libexec/openldap/back_perl.so
%%BACK_RELAY%%libexec/openldap/back_relay-2.4.so
-%%BACK_RELAY%%libexec/openldap/back_relay-2.4.so.2
+%%BACK_RELAY%%libexec/openldap/back_relay-2.4.so.3
%%BACK_RELAY%%libexec/openldap/back_relay.la
%%BACK_RELAY%%libexec/openldap/back_relay.so
%%BACK_SHELL%%libexec/openldap/back_shell-2.4.so
-%%BACK_SHELL%%libexec/openldap/back_shell-2.4.so.2
+%%BACK_SHELL%%libexec/openldap/back_shell-2.4.so.3
%%BACK_SHELL%%libexec/openldap/back_shell.la
%%BACK_SHELL%%libexec/openldap/back_shell.so
%%BACK_SOCK%%libexec/openldap/back_sock-2.4.so
-%%BACK_SOCK%%libexec/openldap/back_sock-2.4.so.2
+%%BACK_SOCK%%libexec/openldap/back_sock-2.4.so.3
%%BACK_SOCK%%libexec/openldap/back_sock.la
%%BACK_SOCK%%libexec/openldap/back_sock.so
%%BACK_SQL%%libexec/openldap/back_sql-2.4.so
-%%BACK_SQL%%libexec/openldap/back_sql-2.4.so.2
+%%BACK_SQL%%libexec/openldap/back_sql-2.4.so.3
%%BACK_SQL%%libexec/openldap/back_sql.la
%%BACK_SQL%%libexec/openldap/back_sql.so
libexec/slapd
@@ -81,6 +81,4 @@ sbin/slaptest
@cwd /
@exec mkdir -p %%LDAP_RUN_DIR%%
@dirrmtry %%LDAP_RUN_DIR%%
-@exec mkdir -p %%DATABASEDIR%%
-@dirrmtry %%DATABASEDIR%%
@cwd %%PREFIX%%
diff --git a/net/openldap24-server/pkg-plist.client b/net/openldap24-server/pkg-plist.client
index f764aa17cc46..38fa40e17b25 100644
--- a/net/openldap24-server/pkg-plist.client
+++ b/net/openldap24-server/pkg-plist.client
@@ -21,17 +21,17 @@ include/ldap_schema.h
include/ldap_utf8.h
include/slapi-plugin.h
lib/liblber-2.4.so
-lib/liblber-2.4.so.2
+lib/liblber-2.4.so.3
lib/liblber.a
lib/liblber.la
lib/liblber.so
lib/libldap-2.4.so
-lib/libldap-2.4.so.2
+lib/libldap-2.4.so.3
lib/libldap.a
lib/libldap.la
lib/libldap.so
lib/libldap_r-2.4.so
-lib/libldap_r-2.4.so.2
+lib/libldap_r-2.4.so.3
lib/libldap_r.a
lib/libldap_r.la
lib/libldap_r.so