aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2006-11-09 07:38:52 +0800
committerrafan <rafan@FreeBSD.org>2006-11-09 07:38:52 +0800
commit23a27701a23adb4220b2254175db6e910e8dd939 (patch)
tree551abcfb30f315a21ce740ad239862c31abbd962 /net
parent633ad028c69efe9250d7d5ae3f6bd4dbdfd27f9a (diff)
downloadfreebsd-ports-gnome-23a27701a23adb4220b2254175db6e910e8dd939.tar.gz
freebsd-ports-gnome-23a27701a23adb4220b2254175db6e910e8dd939.tar.zst
freebsd-ports-gnome-23a27701a23adb4220b2254175db6e910e8dd939.zip
- Support file names that contains blanks
PR: ports/105264 Submitted by: Rudolf Cejka, Brno University of Technology, Brno, Czech Republic Approved by: Matthias Andree (maintainer)
Diffstat (limited to 'net')
-rw-r--r--net/cvsupchk/Makefile6
-rw-r--r--net/cvsupchk/files/patch-spaces-in-filenames14
2 files changed, 18 insertions, 2 deletions
diff --git a/net/cvsupchk/Makefile b/net/cvsupchk/Makefile
index c9035870de13..43e9fa3c1a17 100644
--- a/net/cvsupchk/Makefile
+++ b/net/cvsupchk/Makefile
@@ -7,24 +7,26 @@
PORTNAME= cvsupchk
PORTVERSION= 19990209
+PORTREVISION= 1
CATEGORIES= net
DISTFILES=
MAINTAINER= matthias.andree@gmx.de
COMMENT= Check a CVSup directory hierarchy against the checkouts file
-BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/net/cvsup:extract
+EXTRACT_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/net/cvsup:extract
PLIST_FILES= bin/cvsupchk
PORTDOCS= *
USE_PYTHON= yes
+NO_BUILD= yes
.include <bsd.port.pre.mk>
src!= cd ${PORTSDIR}/net/cvsup && make -V WRKSRC
-do-build:
+do-extract:
${MKDIR} ${WRKSRC}
${SED} 's:^#!/usr/local/bin/python:#!${PYTHON_CMD}:' <${src}/contrib/cvsupchk/cvsupchk >${WRKSRC}/cvsupchk
diff --git a/net/cvsupchk/files/patch-spaces-in-filenames b/net/cvsupchk/files/patch-spaces-in-filenames
new file mode 100644
index 000000000000..3a09f90371f7
--- /dev/null
+++ b/net/cvsupchk/files/patch-spaces-in-filenames
@@ -0,0 +1,14 @@
+This patch by Rudolf Cejka aims to fix cvsupchk for names
+that contain spaces. -- Matthias Andree, 2006-11-07
+
+--- cvsupchk.orig Tue Oct 31 14:51:57 2006
++++ cvsupchk Tue Oct 31 14:57:47 2006
+@@ -396,6 +396,8 @@
+
+ c = string.split(l)
+
++ c[1] = string.replace(c[1], "\_", " ")
++
+ if c[0] not in [ 'C', 'c', 'D', 'F', 'U', 'V', 'v' ]:
+ diag_fatal('Unrecognized line: "%s"' % l[0:-1])
+