aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorwoodsb02 <woodsb02@FreeBSD.org>2016-06-27 06:25:51 +0800
committerwoodsb02 <woodsb02@FreeBSD.org>2016-06-27 06:25:51 +0800
commit241557429cbb018102944b86b6346baa7b74bf81 (patch)
tree6b0b4016b13aad57f01292d7896f29e66fbcd286 /net
parent635569e4d2a85abfb6583eb2b394637872a2b2d6 (diff)
downloadfreebsd-ports-gnome-241557429cbb018102944b86b6346baa7b74bf81.tar.gz
freebsd-ports-gnome-241557429cbb018102944b86b6346baa7b74bf81.tar.zst
freebsd-ports-gnome-241557429cbb018102944b86b6346baa7b74bf81.zip
net/libvncserver: Fix build with libva
- Add new option to select whether to compile with VAAPI support, so that if multimedia/libva is already installed on the system during the build process, it is not linked to unless desired. - Add patch to allow h.264 support to build using libva deprecated API PR: 210533 Submitted by: cpm Reported by: Walter Schwarzenfeld <w.schwarzenfeld@utanet.at> Approved by: adamw (mentor) Differential Revision: https://reviews.freebsd.org/D6974
Diffstat (limited to 'net')
-rw-r--r--net/libvncserver/Makefile5
-rw-r--r--net/libvncserver/files/patch-libvncclient_h264.c13
2 files changed, 17 insertions, 1 deletions
diff --git a/net/libvncserver/Makefile b/net/libvncserver/Makefile
index 35a55037ca6e..22363e4a41b3 100644
--- a/net/libvncserver/Makefile
+++ b/net/libvncserver/Makefile
@@ -24,7 +24,7 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
-OPTIONS_DEFINE= GCRYPT IPV6
+OPTIONS_DEFINE= GCRYPT IPV6 VAAPI
OPTIONS_SINGLE= SSL
OPTIONS_SINGLE_SSL= GNUTLS OPENSSL
OPTIONS_DEFAULT= OPENSSL
@@ -43,6 +43,9 @@ GCRYPT_CONFIGURE_WITH= gcrypt
IPV6_CONFIGURE_WITH= ipv6
+VAAPI_LIB_DEPENDS= libva.so:multimedia/libva
+VAAPI_CONFIGURE_WITH= libva
+
post-install:
${INSTALL_DATA} ${WRKSRC}/rfb/default8x16.h ${STAGEDIR}${PREFIX}/include/rfb
diff --git a/net/libvncserver/files/patch-libvncclient_h264.c b/net/libvncserver/files/patch-libvncclient_h264.c
new file mode 100644
index 000000000000..f81e0ece8350
--- /dev/null
+++ b/net/libvncserver/files/patch-libvncclient_h264.c
@@ -0,0 +1,13 @@
+--- libvncclient/h264.c.orig 2016-06-26 17:53:47 UTC
++++ libvncclient/h264.c
+@@ -20,6 +20,10 @@
+ #ifdef LIBVNCSERVER_CONFIG_LIBVA
+
+ #include <X11/Xlib.h>
++#include <va/va_version.h>
++#if VA_CHECK_VERSION(0,39,2)
++#include <va/va_compat.h>
++#endif
+ #include <va/va_x11.h>
+
+ enum _slice_types {