aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2011-04-11 02:18:09 +0800
committerswills <swills@FreeBSD.org>2011-04-11 02:18:09 +0800
commit281bb1cc1dbe6939d53f27733cf8d537050e20dc (patch)
treea39d720d5dc4e88e9d857aa56f5975a7da5ffc57 /net
parent5ab67ad7a6d341b9e28e7508912c27da5cd45c4c (diff)
downloadfreebsd-ports-gnome-281bb1cc1dbe6939d53f27733cf8d537050e20dc.tar.gz
freebsd-ports-gnome-281bb1cc1dbe6939d53f27733cf8d537050e20dc.tar.zst
freebsd-ports-gnome-281bb1cc1dbe6939d53f27733cf8d537050e20dc.zip
- Mark broken with Ruby 1.9
Diffstat (limited to 'net')
-rw-r--r--net/ruby-mpi/Makefile6
-rw-r--r--net/ruby-nis/Makefile6
-rw-r--r--net/ruby-pcap/Makefile6
-rw-r--r--net/ruby-romp/Makefile6
-rw-r--r--net/ruby-spread/Makefile6
5 files changed, 25 insertions, 5 deletions
diff --git a/net/ruby-mpi/Makefile b/net/ruby-mpi/Makefile
index 3789f6b468ac..bef57a49a758 100644
--- a/net/ruby-mpi/Makefile
+++ b/net/ruby-mpi/Makefile
@@ -45,4 +45,8 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/docs/rd/*.rd ${RUBY_MODDOCDIR}/rd/
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.if ${RUBY_VER} == 1.9
+BROKEN= does not build with ruby 1.9
+.endif
+.include <bsd.port.post.mk>
diff --git a/net/ruby-nis/Makefile b/net/ruby-nis/Makefile
index 716ccf911f7f..0c2a4171389f 100644
--- a/net/ruby-nis/Makefile
+++ b/net/ruby-nis/Makefile
@@ -35,4 +35,8 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/test/* ${RUBY_MODEXAMPLESDIR}/
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.if ${RUBY_VER} == 1.9
+BROKEN= does not build with ruby 1.9
+.endif
+.include <bsd.port.post.mk>
diff --git a/net/ruby-pcap/Makefile b/net/ruby-pcap/Makefile
index 383b87d31f1e..c10b9cc08477 100644
--- a/net/ruby-pcap/Makefile
+++ b/net/ruby-pcap/Makefile
@@ -35,4 +35,8 @@ post-install:
${RUBY_MODDOCDIR}/ja/
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.if ${RUBY_VER} == 1.9
+BROKEN= does not build with ruby 1.9
+.endif
+.include <bsd.port.post.mk>
diff --git a/net/ruby-romp/Makefile b/net/ruby-romp/Makefile
index 053e04078c3a..0701be5dfc45 100644
--- a/net/ruby-romp/Makefile
+++ b/net/ruby-romp/Makefile
@@ -50,4 +50,8 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.if ${RUBY_VER} == 1.9
+BROKEN= does not build with ruby 1.9
+.endif
+.include <bsd.port.post.mk>
diff --git a/net/ruby-spread/Makefile b/net/ruby-spread/Makefile
index 9a3db92b5535..3f021a480861 100644
--- a/net/ruby-spread/Makefile
+++ b/net/ruby-spread/Makefile
@@ -33,4 +33,8 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/README ${RUBY_MODDOCDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.if ${RUBY_VER} == 1.9
+BROKEN= does not build with ruby 1.9
+.endif
+.include <bsd.port.post.mk>