aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-07-29 22:12:44 +0800
committermiwi <miwi@FreeBSD.org>2009-07-29 22:12:44 +0800
commit285ae946000572158f585e185718823f9e1902de (patch)
treeee846772bad59b7601e4cf982cadfedae3204645 /net
parent060a619c66397e4d2732b0874aa01bd6caa26583 (diff)
downloadfreebsd-ports-gnome-285ae946000572158f585e185718823f9e1902de.tar.gz
freebsd-ports-gnome-285ae946000572158f585e185718823f9e1902de.tar.zst
freebsd-ports-gnome-285ae946000572158f585e185718823f9e1902de.zip
Getting network addresses from Python
It.s been irritating me for ages that it isn.t possible to straightforwardly get the network address(es) of the machine you.re running on from a Python program. WWW: http://alastairs-place.net/netifaces/ PR: ports/137236 Submitted by: Stanislav Svirid <count at 211.ru>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/py-netifaces/Makefile21
-rw-r--r--net/py-netifaces/distinfo3
-rw-r--r--net/py-netifaces/pkg-descr7
-rw-r--r--net/py-netifaces/pkg-plist1
5 files changed, 33 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 0cc58ebeb16b..a155b5a3c0d7 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -772,6 +772,7 @@
SUBDIR += py-medusa
SUBDIR += py-mp-random
SUBDIR += py-netaddr
+ SUBDIR += py-netifaces
SUBDIR += py-netstring
SUBDIR += py-oauth
SUBDIR += py-pcap
diff --git a/net/py-netifaces/Makefile b/net/py-netifaces/Makefile
new file mode 100644
index 000000000000..8482d09d4c19
--- /dev/null
+++ b/net/py-netifaces/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: py-netifaces
+# Date created: May 27 2009
+# Whom: Stanislav Svirid <count@211.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= netifaces
+PORTVERSION= 0.5
+CATEGORIES= net python
+MASTER_SITES= http://alastairs-place.net/2007/03/netifaces/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= count@211.ru
+COMMENT= Getting network addresses from Python
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= easy_install
+PYEASYINSTALL_ARCHDEP= yes
+
+.include <bsd.port.mk>
diff --git a/net/py-netifaces/distinfo b/net/py-netifaces/distinfo
new file mode 100644
index 000000000000..6472ec5690dc
--- /dev/null
+++ b/net/py-netifaces/distinfo
@@ -0,0 +1,3 @@
+MD5 (netifaces-0.5.tar.gz) = ea662a4b4c7db5d1631cc33bf68eb030
+SHA256 (netifaces-0.5.tar.gz) = a210263311512b9a13e758545161ddecdbf0426ccd1e1c3380cb354be259b35d
+SIZE (netifaces-0.5.tar.gz) = 13024
diff --git a/net/py-netifaces/pkg-descr b/net/py-netifaces/pkg-descr
new file mode 100644
index 000000000000..563daa3dc018
--- /dev/null
+++ b/net/py-netifaces/pkg-descr
@@ -0,0 +1,7 @@
+Getting network addresses from Python
+
+It.s been irritating me for ages that it isn.t possible to
+straightforwardly get the network address(es) of the machine
+you.re running on from a Python program.
+
+WWW: http://alastairs-place.net/netifaces/
diff --git a/net/py-netifaces/pkg-plist b/net/py-netifaces/pkg-plist
new file mode 100644
index 000000000000..ddf68a1c022f
--- /dev/null
+++ b/net/py-netifaces/pkg-plist
@@ -0,0 +1 @@
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%