aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorjpaetzel <jpaetzel@FreeBSD.org>2010-08-21 03:35:36 +0800
committerjpaetzel <jpaetzel@FreeBSD.org>2010-08-21 03:35:36 +0800
commit302f5427d0093a36cd4ae3082c0e848773066eda (patch)
tree3478a78b5c763c8d47616a963d8386d8896d9644 /net
parentb3ea00917bed49f85d8bb62f302514bd83c22ed2 (diff)
downloadfreebsd-ports-gnome-302f5427d0093a36cd4ae3082c0e848773066eda.tar.gz
freebsd-ports-gnome-302f5427d0093a36cd4ae3082c0e848773066eda.tar.zst
freebsd-ports-gnome-302f5427d0093a36cd4ae3082c0e848773066eda.zip
Update meta port to add subports
PR: ports/149767 Submitted by: Eric F Crist <ecrist@secure-computing.net>
Diffstat (limited to 'net')
-rw-r--r--net/freeswitch/Makefile47
1 files changed, 29 insertions, 18 deletions
diff --git a/net/freeswitch/Makefile b/net/freeswitch/Makefile
index 6c38d0e8e50c..55e64a9fa3d0 100644
--- a/net/freeswitch/Makefile
+++ b/net/freeswitch/Makefile
@@ -5,32 +5,43 @@
# $FreeBSD$
#
-PORTNAME= freeswitch
-PORTVERSION= 1.0.6
-CATEGORIES= net
-MASTER_SITES= # none
-DISTFILES= # none
-EXTRACT_ONLY= # none
+PORTNAME= freeswitch
+PORTVERSION= 1.0.6
+PORTREVISION= 1
+CATEGORIES= net
+MASTER_SITES= # none
+DISTFILES= # none
+EXTRACT_ONLY= # none
-MAINTAINER= ecrist@secure-computing.net
-COMMENT= FreeSwitch meta-port to pull in all the components
+MAINTAINER= ecrist@secure-computing.net
+COMMENT= FreeSwitch meta-port to pull in all the components
-NO_BUILD= YES
-SUB_FILES= pkg-message
+RUN_DEPENDS= ${LOCALBASE}/bin/freeswitch:${PORTSDIR}/net/freeswitch-core
-OPTIONS= CORE "FreeSwitch PBX Software" on \
- SOUNDS "Sound files for use with FreeSwitch PBX" on \
- MUSIC "Music on hold for use with FreeSwitch PBX" on
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+OPTIONS= SOUNDS "Sound files for use with FreeSwitch PBX" on \
+ MUSIC "Music on hold for use with FreeSwitch PBX" on \
+ PIZZA "Install Pizza Shop voice demo" off \
+ SCRIPTS "Install Freeswitch various scripts" off \
.include <bsd.port.options.mk>
-.if defined(WITH_CORE)
-RUN_DEPENDS+= freeswitch:${PORTSDIR}/net/freeswitch-core
-.endif
+
.if defined(WITH_SOUNDS)
-RUN_DEPENDS+= ${LOCALBASE}/share/freeswitch/sounds/.freeswitch-sounds:${PORTSDIR}/audio/freeswitch-sounds
+RUN_DEPENDS+= ${LOCALBASE}/share/freeswitch/sounds/.freeswitch-sounds:${PORTSDIR}/audio/freeswitch-sounds
.endif
+
.if defined(WITH_MUSIC)
-RUN_DEPENDS+= ${LOCALBASE}/share/freeswitch/sounds/music:${PORTSDIR}/audio/freeswitch-music
+RUN_DEPENDS+= ${LOCALBASE}/share/freeswitch/sounds/.freeswitch-music:${PORTSDIR}/audio/freeswitch-music
+.endif
+
+.if defined(WITH_PIZZA)
+RUN_DEPENDS+= ${LOCALBASE}/share/freeswitch/sounds/.pizza:${PORTSDIR}/misc/freeswitch-pizzademo
+.endif
+
+.if defined(WITH_SCRIPTS)
+RUN_DEPENDS+= ${LOCALBASE}/etc/freeswitch/scripts/.freeswitch-scripts:${PORTSDIR}/misc/freeswitch-scripts
.endif
do-install: build