aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2014-06-24 19:23:45 +0800
committerdemon <demon@FreeBSD.org>2014-06-24 19:23:45 +0800
commit34801f1d0f3656fa07573160e7d1229d4c68f1ab (patch)
tree735029233e0ba091f63a9d4b447b365e6b6585b0 /net
parentb98a72f41dee851996277e2f620df0b946fe5246 (diff)
downloadfreebsd-ports-gnome-34801f1d0f3656fa07573160e7d1229d4c68f1ab.tar.gz
freebsd-ports-gnome-34801f1d0f3656fa07573160e7d1229d4c68f1ab.tar.zst
freebsd-ports-gnome-34801f1d0f3656fa07573160e7d1229d4c68f1ab.zip
Update to version 1.5.1.
Diffstat (limited to 'net')
-rw-r--r--net/haproxy/Makefile20
-rw-r--r--net/haproxy/distinfo4
-rw-r--r--net/haproxy/files/patch-Makefile29
-rw-r--r--net/haproxy/pkg-plist58
4 files changed, 56 insertions, 55 deletions
diff --git a/net/haproxy/Makefile b/net/haproxy/Makefile
index 4fc1472b31a7..928d925e1364 100644
--- a/net/haproxy/Makefile
+++ b/net/haproxy/Makefile
@@ -2,9 +2,9 @@
# $FreeBSD$
PORTNAME= haproxy
-PORTVERSION= 1.4.25
+DISTVERSION= 1.5.1
CATEGORIES= net www
-MASTER_SITES= http://haproxy.1wt.eu/download/1.4/src/
+MASTER_SITES= http://haproxy.1wt.eu/download/1.5/src/
MAINTAINER= demon@FreeBSD.org
COMMENT= The Reliable, High Performance TCP/HTTP Load Balancer
@@ -18,16 +18,17 @@ USES= gmake
USE_RC_SUBR= haproxy
SUB_FILES= pkg-message
-OPTIONS_DEFINE= PCRE
+OPTIONS_DEFINE= PCRE OPENSSL
OPTIONS_SINGLE= PCRE
OPTIONS_SINGLE_PCRE= DPCRE SPCRE
-DPCRE_DESC= Link dynamically
-SPCRE_DESC= Link statically
-OPTIONS_DEFAULT=PCRE DPCRE
+DPCRE_DESC= Link dynamically
+SPCRE_DESC= Link statically
+OPTIONS_DEFAULT= PCRE DPCRE OPENSSL
.include <bsd.port.options.mk>
-MAKE_ARGS= TARGET=freebsd DEFINE=-DFREEBSD_PORTS CC="${CC}"
+MAKE_ARGS= TARGET=freebsd DEFINE=-DFREEBSD_PORTS USE_GETADDRINFO=1 \
+ USE_ZLIB=1 CC="${CC}" CFLAGS="${CFLAGS}"
.if ${PORT_OPTIONS:MDPCRE}
LIB_DEPENDS+= libpcre.so:${PORTSDIR}/devel/pcre
@@ -38,6 +39,11 @@ BUILD_DEPENDS+= ${LOCALBASE}/lib/libpcre.a:${PORTSDIR}/devel/pcre
MAKE_ARGS+= "USE_STATIC_PCRE=1"
.endif
+.if ${PORT_OPTIONS:MOPENSSL}
+USE_OPENSSL= yes
+MAKE_ARGS+= USE_OPENSSL=1
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/haproxy ${STAGEDIR}${PREFIX}/sbin/
${INSTALL_MAN} ${WRKSRC}/doc/haproxy.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
diff --git a/net/haproxy/distinfo b/net/haproxy/distinfo
index 1382b9a42b10..28c07bc446ce 100644
--- a/net/haproxy/distinfo
+++ b/net/haproxy/distinfo
@@ -1,2 +1,2 @@
-SHA256 (haproxy-1.4.25.tar.gz) = 84408ec1e37bf308c6b45ae3c7e66f2a9d2f762cb689ab6d322c67bba691db62
-SIZE (haproxy-1.4.25.tar.gz) = 838775
+SHA256 (haproxy-1.5.1.tar.gz) = 69b54be39247b4a7556b4a7d3bd90ffd4acf35799ffa7125bbadebab8e5df5b4
+SIZE (haproxy-1.5.1.tar.gz) = 1329710
diff --git a/net/haproxy/files/patch-Makefile b/net/haproxy/files/patch-Makefile
deleted file mode 100644
index 83445bb9d446..000000000000
--- a/net/haproxy/files/patch-Makefile
+++ /dev/null
@@ -1,29 +0,0 @@
---- Makefile.orig
-+++ Makefile
-@@ -62,7 +62,7 @@
-
- #### Installation options.
- DESTDIR =
--PREFIX = /usr/local
-+PREFIX? = /usr/local
- SBINDIR = $(PREFIX)/sbin
- MANDIR = $(PREFIX)/share/man
- DOCDIR = $(PREFIX)/doc/haproxy
-@@ -89,7 +89,7 @@
-
- #### Toolchain options.
- # GCC is normally used both for compiling and linking.
--CC = gcc
-+CC? = gcc
- LD = $(CC)
-
- #### Debug flags (typically "-g").
-@@ -158,7 +158,7 @@
- # These CFLAGS contain general optimization options, CPU-specific optimizations
- # and debug flags. They may be overridden by some distributions which prefer to
- # set all of them at once instead of playing with the CPU and DEBUG variables.
--CFLAGS = $(ARCH_FLAGS) $(CPU_CFLAGS) $(DEBUG_CFLAGS) $(SPEC_CFLAGS)
-+CFLAGS? = $(ARCH_FLAGS) $(CPU_CFLAGS) $(DEBUG_CFLAGS) $(SPEC_CFLAGS)
-
- #### Common LDFLAGS
- # These LDFLAGS are used as the first "ld" options, regardless of any library
diff --git a/net/haproxy/pkg-plist b/net/haproxy/pkg-plist
index 1dc3348e1273..ac4e0f4f1c04 100644
--- a/net/haproxy/pkg-plist
+++ b/net/haproxy/pkg-plist
@@ -2,35 +2,60 @@ man/man1/haproxy.1.gz
sbin/haproxy
%%PORTDOCS%%%%DOCSDIR%%/acl.fig
%%PORTDOCS%%%%DOCSDIR%%/architecture.txt
+%%PORTDOCS%%%%DOCSDIR%%/close-options.txt
+%%PORTDOCS%%%%DOCSDIR%%/coding-style.txt
%%PORTDOCS%%%%DOCSDIR%%/configuration.txt
+%%PORTDOCS%%%%DOCSDIR%%/cookie-options.txt
+%%PORTDOCS%%%%DOCSDIR%%/gpl.txt
+%%PORTDOCS%%%%DOCSDIR%%/haproxy-en.txt
+%%PORTDOCS%%%%DOCSDIR%%/haproxy-fr.txt
+%%PORTDOCS%%%%DOCSDIR%%/haproxy.1
+%%PORTDOCS%%%%DOCSDIR%%/lgpl.txt
+%%PORTDOCS%%%%DOCSDIR%%/proxy-protocol.txt
+%%PORTDOCS%%%%DOCSDIR%%/queuing.fig
%%PORTDOCS%%%%DOCSDIR%%/design-thoughts/backends-v0.txt
%%PORTDOCS%%%%DOCSDIR%%/design-thoughts/backends.txt
%%PORTDOCS%%%%DOCSDIR%%/design-thoughts/be-fe-changes.txt
+%%PORTDOCS%%%%DOCSDIR%%/design-thoughts/binding-possibilities.txt
+%%PORTDOCS%%%%DOCSDIR%%/design-thoughts/buffer-redesign.txt
%%PORTDOCS%%%%DOCSDIR%%/design-thoughts/buffers.fig
%%PORTDOCS%%%%DOCSDIR%%/design-thoughts/config-language.txt
+%%PORTDOCS%%%%DOCSDIR%%/design-thoughts/connection-reuse.txt
%%PORTDOCS%%%%DOCSDIR%%/design-thoughts/cttproxy-changes.txt
+%%PORTDOCS%%%%DOCSDIR%%/design-thoughts/entities-v2.txt
%%PORTDOCS%%%%DOCSDIR%%/design-thoughts/how-it-works.txt
%%PORTDOCS%%%%DOCSDIR%%/design-thoughts/http_load_time.url
+%%PORTDOCS%%%%DOCSDIR%%/design-thoughts/rate-shaping.txt
%%PORTDOCS%%%%DOCSDIR%%/design-thoughts/sess_par_sec.txt
-%%PORTDOCS%%%%DOCSDIR%%/gpl.txt
-%%PORTDOCS%%%%DOCSDIR%%/haproxy-en.txt
-%%PORTDOCS%%%%DOCSDIR%%/haproxy-fr.txt
-%%PORTDOCS%%%%DOCSDIR%%/haproxy.1
+%%PORTDOCS%%%%DOCSDIR%%/internals/acl.txt
+%%PORTDOCS%%%%DOCSDIR%%/internals/body-parsing.txt
+%%PORTDOCS%%%%DOCSDIR%%/internals/buffer-operations.txt
+%%PORTDOCS%%%%DOCSDIR%%/internals/buffer-ops.fig
%%PORTDOCS%%%%DOCSDIR%%/internals/connect-status.txt
%%PORTDOCS%%%%DOCSDIR%%/internals/connection-header.txt
%%PORTDOCS%%%%DOCSDIR%%/internals/connection-scale.txt
+%%PORTDOCS%%%%DOCSDIR%%/internals/entities.fig
+%%PORTDOCS%%%%DOCSDIR%%/internals/entities.pdf
+%%PORTDOCS%%%%DOCSDIR%%/internals/entities.svg
+%%PORTDOCS%%%%DOCSDIR%%/internals/entities.txt
+%%PORTDOCS%%%%DOCSDIR%%/internals/hashing.txt
%%PORTDOCS%%%%DOCSDIR%%/internals/header-parser-speed.txt
%%PORTDOCS%%%%DOCSDIR%%/internals/header-tree.txt
%%PORTDOCS%%%%DOCSDIR%%/internals/http-cookies.txt
%%PORTDOCS%%%%DOCSDIR%%/internals/http-docs.txt
%%PORTDOCS%%%%DOCSDIR%%/internals/http-parsing.txt
%%PORTDOCS%%%%DOCSDIR%%/internals/naming.txt
+%%PORTDOCS%%%%DOCSDIR%%/internals/pattern.dia
+%%PORTDOCS%%%%DOCSDIR%%/internals/pattern.pdf
+%%PORTDOCS%%%%DOCSDIR%%/internals/polling-states.fig
%%PORTDOCS%%%%DOCSDIR%%/internals/repartition-be-fe-fi.txt
+%%PORTDOCS%%%%DOCSDIR%%/internals/sequence.fig
%%PORTDOCS%%%%DOCSDIR%%/internals/stats-v2.txt
%%PORTDOCS%%%%DOCSDIR%%/internals/stream-sock-states.fig
%%PORTDOCS%%%%DOCSDIR%%/internals/todo.cttproxy
-%%PORTDOCS%%%%DOCSDIR%%/lgpl.txt
-%%PORTDOCS%%%%DOCSDIR%%/queuing.fig
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/internals
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/design-thoughts
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/acl-content-sw.cfg
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/auth.cfg
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/build.cfg
@@ -42,14 +67,6 @@ sbin/haproxy
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/debug2ansi
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/debug2html
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/debugfind
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/errorfiles/400.http
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/errorfiles/403.http
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/errorfiles/408.http
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/errorfiles/500.http
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/errorfiles/502.http
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/errorfiles/503.http
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/errorfiles/504.http
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/errorfiles/README
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples.cfg
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/haproxy-1.1.21-flx.1.pkg
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/haproxy.cfg
@@ -61,12 +78,19 @@ sbin/haproxy
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/linux-2.4.21-40.EL-custom.diff
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/option-http_proxy.cfg
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rc.highsock
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ssl.cfg
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/stats_haproxy.sh
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tarpit.cfg
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test-section-kw.cfg
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/transparent_proxy.cfg
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/url-switching.cfg
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/errorfiles/400.http
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/errorfiles/403.http
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/errorfiles/408.http
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/errorfiles/500.http
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/errorfiles/502.http
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/errorfiles/503.http
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/errorfiles/504.http
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/errorfiles/README
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/errorfiles
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/internals
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/design-thoughts
-%%PORTDOCS%%@dirrm %%DOCSDIR%%