aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2014-11-07 21:51:10 +0800
committermat <mat@FreeBSD.org>2014-11-07 21:51:10 +0800
commit34dc682be7b4986cfb11ab7c554efc5452d6ac4e (patch)
tree64a7b88cfefd6ac82e406551ff221ca21bbf2868 /net
parent339fda5e08d66ae603ab2aaa15a0b7370bbb77c4 (diff)
downloadfreebsd-ports-gnome-34dc682be7b4986cfb11ab7c554efc5452d6ac4e.tar.gz
freebsd-ports-gnome-34dc682be7b4986cfb11ab7c554efc5452d6ac4e.tar.zst
freebsd-ports-gnome-34dc682be7b4986cfb11ab7c554efc5452d6ac4e.zip
Replace some occurences of mach with PERL_ARCH (and a couple of other small noop fixes.)
With hat: perl@ Sponsored by: Absolight
Diffstat (limited to 'net')
-rw-r--r--net/libproxy-perl/Makefile6
-rw-r--r--net/libproxy-perl/pkg-plist10
-rw-r--r--net/spread/Makefile2
3 files changed, 9 insertions, 9 deletions
diff --git a/net/libproxy-perl/Makefile b/net/libproxy-perl/Makefile
index b355d9bb5d29..d5f4e9a74623 100644
--- a/net/libproxy-perl/Makefile
+++ b/net/libproxy-perl/Makefile
@@ -19,10 +19,10 @@ USES= perl5
LIBPROXY_SLAVE= perl
do-install:
- ${MKDIR} ${STAGEDIR}${SITE_PERL}/mach/auto/Net/Libproxy ${STAGEDIR}${SITE_PERL}/mach/Net
+ ${MKDIR} ${STAGEDIR}${SITE_PERL}/${PERL_ARCH}/auto/Net/Libproxy ${STAGEDIR}${SITE_PERL}/${PERL_ARCH}/Net
${INSTALL_LIB} ${WRKSRC}/perl/blib/arch/auto/Net/Libproxy.so \
- ${STAGEDIR}${SITE_PERL}/mach/auto/Net/Libproxy/
+ ${STAGEDIR}${SITE_PERL}/${PERL_ARCH}/auto/Net/Libproxy/
${INSTALL_DATA} ${WRKSRC}/perl/blib/lib/Libproxy.pm \
- ${STAGEDIR}${SITE_PERL}/mach/Net/
+ ${STAGEDIR}${SITE_PERL}/${PERL_ARCH}/Net/
.include "${MASTERDIR}/Makefile"
diff --git a/net/libproxy-perl/pkg-plist b/net/libproxy-perl/pkg-plist
index 51235dcfaf93..f6fe0295e541 100644
--- a/net/libproxy-perl/pkg-plist
+++ b/net/libproxy-perl/pkg-plist
@@ -1,5 +1,5 @@
-%%SITE_PERL%%/mach/Net/Libproxy.pm
-%%SITE_PERL%%/mach/auto/Net/Libproxy/Libproxy.so
-@dirrm %%SITE_PERL%%/mach/auto/Net/Libproxy
-@dirrmtry %%SITE_PERL%%/mach/auto/Net
-@dirrmtry %%SITE_PERL%%/mach/Net
+%%SITE_PERL%%/%%PERL_ARCH%%/Net/Libproxy.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Libproxy/Libproxy.so
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Libproxy
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Net
diff --git a/net/spread/Makefile b/net/spread/Makefile
index b094c7957d93..00275543a0ff 100644
--- a/net/spread/Makefile
+++ b/net/spread/Makefile
@@ -74,6 +74,6 @@ post-install:
${INSTALL} -m 750 -d ${STAGEDIR}${RUNDIR}
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libspread.so.1
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libtspread.so.1
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_PERL_REL}/mach/auto/Spread/Spread.so
+ ${STRIP_CMD} ${STAGEDIR}${SITE_PERL}/${PERL_ARCH}/auto/Spread/Spread.so
.include <bsd.port.post.mk>