aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-04-26 20:35:50 +0800
committerbapt <bapt@FreeBSD.org>2013-04-26 20:35:50 +0800
commit3b719f87a14768433dc0cd06f301eeaf9c02fa43 (patch)
tree94d53c5c905021f480b1c80529f6919181c4c73b /net
parent6ed47115f3cf9c141188528e8863513cfade4cd8 (diff)
downloadfreebsd-ports-gnome-3b719f87a14768433dc0cd06f301eeaf9c02fa43.tar.gz
freebsd-ports-gnome-3b719f87a14768433dc0cd06f301eeaf9c02fa43.tar.zst
freebsd-ports-gnome-3b719f87a14768433dc0cd06f301eeaf9c02fa43.zip
Remove USE_CDRTOOLS from bsd.port.mk
This macros has been useless since cdrtools-cjk port has gone. This macros also lead to badly handled dependencies assuming that the dependency on cdrtools was most BUILD and RUN dependency. While most of the time it is simply a RUN dependency and sometime a build one. While here: - Trim some headers - Convert some ports to optionsng - Convert some ports to USES= gettext
Diffstat (limited to 'net')
-rw-r--r--net/gpxe/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/net/gpxe/Makefile b/net/gpxe/Makefile
index b1d4e5a1b8aa..07e8de4ec67d 100644
--- a/net/gpxe/Makefile
+++ b/net/gpxe/Makefile
@@ -1,12 +1,9 @@
-# New ports collection Makefile for: gpxe
-# Date created: 27-02-2010
-# Whom: Guerkan Karaman <gk.freebsd@googlemail.com>
-#
+# Created by: Guerkan Karaman <gk.freebsd@googlemail.com>
# $FreeBSD$
-#
PORTNAME= gpxe
PORTVERSION= 1.0.1
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_KERNEL_ORG}
MASTER_SITE_SUBDIR=software/utils/boot/gpxe
@@ -16,11 +13,11 @@ COMMENT= Create an open-source PXE implementation and bootloader
LICENSE= GPLv2
-BUILD_DEPENDS= syslinux:${PORTSDIR}/sysutils/syslinux
+BUILD_DEPENDS= syslinux:${PORTSDIR}/sysutils/syslinux \
+ mkisofs:${PORTSDIR}/sysutils/cdrtools
USE_BZIP2= yes
USE_GMAKE= yes
-USE_CDRTOOLS= yes
USE_PERL5= yes
WRKSRC= ${WRKDIR}/${DISTNAME}/src
MAKE_JOBS_SAFE= yes
@@ -34,7 +31,7 @@ PLIST_FILES= %%DATADIR%%/gpxe.dsk \
SUB_FILES= pkg-message
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
ONLY_FOR_ARCHS= amd64 i386
ONLY_FOR_ARCHS_REASON= not yet ported to anything other than amd64/i386
@@ -55,4 +52,4 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>