aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authoranholt <anholt@FreeBSD.org>2004-07-24 03:10:32 +0800
committeranholt <anholt@FreeBSD.org>2004-07-24 03:10:32 +0800
commit3c76fd7fad82c9f137407348028fde08754f2866 (patch)
tree9818557f7ca7be09aba8db3b18a8262f50280603 /net
parenta861bc861bc7251a2f2399f845d673f742a19ee1 (diff)
downloadfreebsd-ports-gnome-3c76fd7fad82c9f137407348028fde08754f2866.tar.gz
freebsd-ports-gnome-3c76fd7fad82c9f137407348028fde08754f2866.tar.zst
freebsd-ports-gnome-3c76fd7fad82c9f137407348028fde08754f2866.zip
- Add the X_WINDOW_SYSTEM={xorg,xfree86-4,xfree86-3} variable to bsd.port.mk,
and make XFREE86_VERSION map to it. XFREE86_VERSION is now deprecated. - Make xorg the default X_WINDOW_SYSTEM on -current. - Add several new X_*_PORT variables which point to various pieces of X11 based on the setting of X_WINDOW_SYSTEM, and make ports use them. - Add information to CHANGES about how to handle the transition. PR: ports/68763 Approved by: portmgr (marcus) Approved by: re (scottl)
Diffstat (limited to 'net')
-rw-r--r--net/ayttm/Makefile2
-rw-r--r--net/tightvnc/Makefile5
-rw-r--r--net/tsclient/Makefile2
-rw-r--r--net/vnc/Makefile4
4 files changed, 5 insertions, 8 deletions
diff --git a/net/ayttm/Makefile b/net/ayttm/Makefile
index 5515c6d3798a..2fd843e52684 100644
--- a/net/ayttm/Makefile
+++ b/net/ayttm/Makefile
@@ -59,7 +59,7 @@ CONFIGURE_ARGS+= --disable-arts
PLIST_SUB+= LIBARTS="@comment "
.endif
-.if ${XFREE86_VERSION} >= 4 && !defined(WITHOUT_XFT)
+.if ${X_WINDOW_SYSTEM:L} != xfree86-3 && !defined(WITHOUT_XFT)
LIB_DEPENDS+= Xft.2:${PORTSDIR}/x11-fonts/libXft
CONFIGURE_ARGS+= --enable-xft
CPPFLAGS+= `freetype-config --cflags`
diff --git a/net/tightvnc/Makefile b/net/tightvnc/Makefile
index 585f879cfa87..88f619385f2d 100644
--- a/net/tightvnc/Makefile
+++ b/net/tightvnc/Makefile
@@ -17,6 +17,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Enhanced version of VNC
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg
+RUN_DEPENDS= ${X11BASE}/lib/X11/fonts/misc/10x20.pcf.gz:${X_FONTS_MISC_PORT}
WRKSRC= ${WRKDIR}/vnc_unixsrc
@@ -36,10 +37,6 @@ MAN1= Xvnc.1 vncviewer.1 vncpasswd.1 vncconnect.1 vncserver.1
BROKEN= "Does not compile on !i386"
.endif
-.if ${XFREE86_VERSION} >= 4
-RUN_DEPENDS+= ${X11BASE}/lib/X11/fonts/misc/10x20.pcf.gz:${PORTSDIR}/x11-fonts/XFree86-4-fontDefaultBitmaps
-.endif
-
.if exists(${X11BASE}/share/vnc/classes/index.vnc)
IGNORE= "vnc has already been installed, please uninstall it first."
.endif
diff --git a/net/tsclient/Makefile b/net/tsclient/Makefile
index 3d4e6f51cb9e..fd8f51b0a84b 100644
--- a/net/tsclient/Makefile
+++ b/net/tsclient/Makefile
@@ -21,7 +21,7 @@ RUN_DEPENDS+= tightvnc:${PORTSDIR}/net/tightvnc
.endif
.ifdef (WITH_XNEST)
-RUN_DEPENDS+= Xnest:${PORTSDIR}/x11-servers/XFree86-4-NestServer
+RUN_DEPENDS+= Xnest:${X_NESTSERVER_PORT}
.endif
USE_X_PREFIX= yes
diff --git a/net/vnc/Makefile b/net/vnc/Makefile
index 7989808cbc32..f5845ed1f25e 100644
--- a/net/vnc/Makefile
+++ b/net/vnc/Makefile
@@ -32,8 +32,8 @@ MAN1= vncviewer.1 \
MAN1+= Xvnc.1 \
vncserver.1
-RUN_DEPENDS+= xauth:${PORTSDIR}/x11/XFree86-4-clients \
-${X11BASE}/lib/X11/fonts/misc/6x13-ISO8859-1.pcf.gz:${PORTSDIR}/x11-fonts/XFree86-4-fontDefaultBitmaps
+RUN_DEPENDS= xauth:${X_CLIENTS_PORT} \
+ ${X11BASE}/lib/X11/fonts/misc/6x13-ISO8859-1.pcf.gz:${X_FONTS_MISC_PORT}
USE_PERL5_RUN= yes
.endif