aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>1998-09-19 05:53:24 +0800
committervanilla <vanilla@FreeBSD.org>1998-09-19 05:53:24 +0800
commit40430dfd015adc2c80000dfbca5e7e681654a949 (patch)
tree4976eaf7347c05fb97626c30c027df3965d9125e /net
parent9f9a666854d331f4e2e266f8d11e999d321b4802 (diff)
downloadfreebsd-ports-gnome-40430dfd015adc2c80000dfbca5e7e681654a949.tar.gz
freebsd-ports-gnome-40430dfd015adc2c80000dfbca5e7e681654a949.tar.zst
freebsd-ports-gnome-40430dfd015adc2c80000dfbca5e7e681654a949.zip
a network sniffer a la NetXray. With a little work and development this could
rival NetXray (which is approx $4,000). PR: ports/7581 Submitted by: Bill Fumerola <billf@chc-chimes.com>
Diffstat (limited to 'net')
-rw-r--r--net/ethereal/Makefile23
-rw-r--r--net/ethereal/distinfo1
-rw-r--r--net/ethereal/files/patch-aa20
-rw-r--r--net/ethereal/pkg-comment1
-rw-r--r--net/ethereal/pkg-descr7
-rw-r--r--net/ethereal/pkg-plist1
-rw-r--r--net/wireshark/Makefile23
-rw-r--r--net/wireshark/distinfo1
-rw-r--r--net/wireshark/files/patch-aa20
-rw-r--r--net/wireshark/pkg-comment1
-rw-r--r--net/wireshark/pkg-descr7
-rw-r--r--net/wireshark/pkg-plist1
12 files changed, 106 insertions, 0 deletions
diff --git a/net/ethereal/Makefile b/net/ethereal/Makefile
new file mode 100644
index 000000000000..9281e793a95f
--- /dev/null
+++ b/net/ethereal/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: ethereal
+# Version required: 0.3.16
+# Date created: 10 August 1998
+# Whom: Bill Fumerola <billf@chc-chimes.com>
+#
+# $Id: $
+#
+
+DISTNAME= ethereal-0.3.16
+CATEGORIES= net
+MASTER_SITES= http://ethereal.zing.org/distribution/ \
+ http://ethereal.boehm.org/distribution/
+
+MAINTAINER= billf@chc-chimes.com
+
+LIB_DEPENDS= gtk\\.1\\.5:${PORTSDIR}/x11-toolkits/gtk
+
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+
+MAN1= ethereal.1
+
+.include <bsd.port.mk>
diff --git a/net/ethereal/distinfo b/net/ethereal/distinfo
new file mode 100644
index 000000000000..1fbe960c1eb2
--- /dev/null
+++ b/net/ethereal/distinfo
@@ -0,0 +1 @@
+MD5 (ethereal-0.3.16.tar.gz) = 49700f2373486e3f3324938acfe7e3ba
diff --git a/net/ethereal/files/patch-aa b/net/ethereal/files/patch-aa
new file mode 100644
index 000000000000..04a5c750b1ec
--- /dev/null
+++ b/net/ethereal/files/patch-aa
@@ -0,0 +1,20 @@
+--- ethereal.h.orig Thu Sep 17 19:14:28 1998
++++ ethereal.h Thu Sep 17 19:15:15 1998
+@@ -27,6 +27,7 @@
+ #define __ETHEREAL_H__
+
+ #include "config.h"
++#include <machine/endian.h>
+
+ #define RC_FILE ".etherealrc"
+ #define MONO_MEDIUM_FONT "-*-lucidatypewriter-medium-r-normal-*-*-120-*-*-*-*-iso8859-1"
+--- packet.c.orig Thu Sep 17 19:15:34 1998
++++ packet.c Thu Sep 17 19:15:48 1998
+@@ -32,6 +32,7 @@
+ #include <stdio.h>
+ #include <stdarg.h>
+ #include <ctype.h>
++#include <sys/types.h>
+
+ #ifdef HAVE_NETINET_IN_H
+ # include <netinet/in.h>
diff --git a/net/ethereal/pkg-comment b/net/ethereal/pkg-comment
new file mode 100644
index 000000000000..5fec25e2b076
--- /dev/null
+++ b/net/ethereal/pkg-comment
@@ -0,0 +1 @@
+a network analyzer that lets you capture
diff --git a/net/ethereal/pkg-descr b/net/ethereal/pkg-descr
new file mode 100644
index 000000000000..8a3404dc3f71
--- /dev/null
+++ b/net/ethereal/pkg-descr
@@ -0,0 +1,7 @@
+a network analyzer that lets you capture and interactively browse the
+contents of Ethernet frames. Packet data can be read from a file, or
+live from a local network interface.
+
+http://ethereal.zing.org
+
+Bill Fumerola <billf@chc-chimes.com>
diff --git a/net/ethereal/pkg-plist b/net/ethereal/pkg-plist
new file mode 100644
index 000000000000..45a3b3226e79
--- /dev/null
+++ b/net/ethereal/pkg-plist
@@ -0,0 +1 @@
+bin/ethereal
diff --git a/net/wireshark/Makefile b/net/wireshark/Makefile
new file mode 100644
index 000000000000..9281e793a95f
--- /dev/null
+++ b/net/wireshark/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: ethereal
+# Version required: 0.3.16
+# Date created: 10 August 1998
+# Whom: Bill Fumerola <billf@chc-chimes.com>
+#
+# $Id: $
+#
+
+DISTNAME= ethereal-0.3.16
+CATEGORIES= net
+MASTER_SITES= http://ethereal.zing.org/distribution/ \
+ http://ethereal.boehm.org/distribution/
+
+MAINTAINER= billf@chc-chimes.com
+
+LIB_DEPENDS= gtk\\.1\\.5:${PORTSDIR}/x11-toolkits/gtk
+
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+
+MAN1= ethereal.1
+
+.include <bsd.port.mk>
diff --git a/net/wireshark/distinfo b/net/wireshark/distinfo
new file mode 100644
index 000000000000..1fbe960c1eb2
--- /dev/null
+++ b/net/wireshark/distinfo
@@ -0,0 +1 @@
+MD5 (ethereal-0.3.16.tar.gz) = 49700f2373486e3f3324938acfe7e3ba
diff --git a/net/wireshark/files/patch-aa b/net/wireshark/files/patch-aa
new file mode 100644
index 000000000000..04a5c750b1ec
--- /dev/null
+++ b/net/wireshark/files/patch-aa
@@ -0,0 +1,20 @@
+--- ethereal.h.orig Thu Sep 17 19:14:28 1998
++++ ethereal.h Thu Sep 17 19:15:15 1998
+@@ -27,6 +27,7 @@
+ #define __ETHEREAL_H__
+
+ #include "config.h"
++#include <machine/endian.h>
+
+ #define RC_FILE ".etherealrc"
+ #define MONO_MEDIUM_FONT "-*-lucidatypewriter-medium-r-normal-*-*-120-*-*-*-*-iso8859-1"
+--- packet.c.orig Thu Sep 17 19:15:34 1998
++++ packet.c Thu Sep 17 19:15:48 1998
+@@ -32,6 +32,7 @@
+ #include <stdio.h>
+ #include <stdarg.h>
+ #include <ctype.h>
++#include <sys/types.h>
+
+ #ifdef HAVE_NETINET_IN_H
+ # include <netinet/in.h>
diff --git a/net/wireshark/pkg-comment b/net/wireshark/pkg-comment
new file mode 100644
index 000000000000..5fec25e2b076
--- /dev/null
+++ b/net/wireshark/pkg-comment
@@ -0,0 +1 @@
+a network analyzer that lets you capture
diff --git a/net/wireshark/pkg-descr b/net/wireshark/pkg-descr
new file mode 100644
index 000000000000..8a3404dc3f71
--- /dev/null
+++ b/net/wireshark/pkg-descr
@@ -0,0 +1,7 @@
+a network analyzer that lets you capture and interactively browse the
+contents of Ethernet frames. Packet data can be read from a file, or
+live from a local network interface.
+
+http://ethereal.zing.org
+
+Bill Fumerola <billf@chc-chimes.com>
diff --git a/net/wireshark/pkg-plist b/net/wireshark/pkg-plist
new file mode 100644
index 000000000000..45a3b3226e79
--- /dev/null
+++ b/net/wireshark/pkg-plist
@@ -0,0 +1 @@
+bin/ethereal