aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authornectar <nectar@FreeBSD.org>2004-01-08 22:28:35 +0800
committernectar <nectar@FreeBSD.org>2004-01-08 22:28:35 +0800
commit4187b568562b66544e34cce3cb58e42061cdd795 (patch)
tree545f3cf11b77831cbec52699d8b1632486ab91e8 /net
parent51838698b9daa924a91b8018891aa87c0ce414df (diff)
downloadfreebsd-ports-gnome-4187b568562b66544e34cce3cb58e42061cdd795.tar.gz
freebsd-ports-gnome-4187b568562b66544e34cce3cb58e42061cdd795.tar.zst
freebsd-ports-gnome-4187b568562b66544e34cce3cb58e42061cdd795.zip
Make nss_ldap pull its LDAP configuration from
${PREFIX}/etc/nss_ldap.conf rather than /etc/ldap.conf and the LDAP secret from ${PREFIX}/etc/nss_ldap.secret rather than /etc/ldap.secret. Requested by: Many.
Diffstat (limited to 'net')
-rw-r--r--net/nss_ldap/Makefile14
-rw-r--r--net/nss_ldap/pkg-message15
-rw-r--r--net/nss_ldap/pkg-plist1
3 files changed, 28 insertions, 2 deletions
diff --git a/net/nss_ldap/Makefile b/net/nss_ldap/Makefile
index 97ebb2a0683f..77cfe4315e01 100644
--- a/net/nss_ldap/Makefile
+++ b/net/nss_ldap/Makefile
@@ -7,7 +7,7 @@
PORTNAME= nss_ldap
PORTVERSION= 1.${NSS_LDAP_VERSION}
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net
MASTER_SITES= http://www.padl.com/download/
DISTNAME= ${PORTNAME}-${NSS_LDAP_VERSION}
@@ -21,15 +21,25 @@ NSS_LDAP_VERSION=204
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
+PKGMESSAGE= ${WRKDIR}/pkg-message
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -Wl,-rpath,${LOCALBASE}/lib"
+CONFIGURE_ARGS= --with-ldap-conf-file=${PREFIX}/etc/nss_ldap.conf \
+ --with-ldap-secret-file=${PREFIX}/etc/nss_ldap.secret
+
post-extract:
${CP} ${FILESDIR}/bsdnss.c ${WRKSRC}
+post-build:
+ ${SED} -e "s,%%PREFIX%%,${PREFIX},g" ${PKGDIR}/pkg-message > ${PKGMESSAGE}
+
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/nss_ldap.so ${LOCALBASE}/lib/nss_ldap.so.1
+ ${INSTALL_PROGRAM} ${WRKSRC}/nss_ldap.so ${PREFIX}/lib/nss_ldap.so.1
+ ${INSTALL_DATA} ${WRKSRC}/ldap.conf ${PREFIX}/etc/nss_ldap.conf.sample
+ ${CAT} ${PKGMESSAGE}
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500112
diff --git a/net/nss_ldap/pkg-message b/net/nss_ldap/pkg-message
new file mode 100644
index 000000000000..d3948e1d1302
--- /dev/null
+++ b/net/nss_ldap/pkg-message
@@ -0,0 +1,15 @@
+=====================================================================
+The nss_ldap module expects to find its configuration files at the
+following paths:
+
+LDAP configuration: %%PREFIX%%/etc/nss_ldap.conf
+LDAP secret (optional): %%PREFIX%%/etc/nss_ldap.secret
+
+
+WARNING: For users of previous versions of this port:
+WARNING:
+WARNING: Previous versions of this port expected configuration files
+WARNING: to be located at /etc/ldap.conf and /etc/ldap.secret. You
+WARNING: may need to move these configuration files to their new
+WARNING: location specified above.
+=====================================================================
diff --git a/net/nss_ldap/pkg-plist b/net/nss_ldap/pkg-plist
index 4f6c839f23f0..4e07a436c7d5 100644
--- a/net/nss_ldap/pkg-plist
+++ b/net/nss_ldap/pkg-plist
@@ -1 +1,2 @@
+etc/nss_ldap.conf.sample
lib/nss_ldap.so.1