aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2010-02-05 11:33:45 +0800
committerpgollucci <pgollucci@FreeBSD.org>2010-02-05 11:33:45 +0800
commit418ac81adde53540876036e3a41207c6a87e0470 (patch)
treedae5bdc0797b62f5a4cde10398bb2cd67f1d6f3d /net
parentf957e9843a441bec9750695531360b440c89de6c (diff)
downloadfreebsd-ports-gnome-418ac81adde53540876036e3a41207c6a87e0470.tar.gz
freebsd-ports-gnome-418ac81adde53540876036e3a41207c6a87e0470.tar.zst
freebsd-ports-gnome-418ac81adde53540876036e3a41207c6a87e0470.zip
- Update to 0.4
- Update MAINTAINER e-mail address PR: ports/142428 Submitted by: Alex Deiter <alex.deiter@gmail.com> (maintainer)
Diffstat (limited to 'net')
-rw-r--r--net/ris/Makefile16
-rw-r--r--net/ris/distinfo6
-rw-r--r--net/ris/files/patch-binlsrv.py6
-rw-r--r--net/ris/files/patch-infparser.py14
-rw-r--r--net/ris/pkg-plist1
5 files changed, 20 insertions, 23 deletions
diff --git a/net/ris/Makefile b/net/ris/Makefile
index 5dc4b634637c..7d20ff1b3a05 100644
--- a/net/ris/Makefile
+++ b/net/ris/Makefile
@@ -6,13 +6,12 @@
#
PORTNAME= ris
-PORTVERSION= 0.3
+PORTVERSION= 0.4
CATEGORIES= net
-MASTER_SITES= http://oss.netfarm.it/guides/ \
- http://m.komi.mtsnet.ru/FreeBSD/distfiles/
+MASTER_SITES= http://oss.netfarm.it/guides/
DISTNAME= ris-linux-${PORTVERSION}
-MAINTAINER= tiamat@komi.mts.ru
+MAINTAINER= alex.deiter@gmail.com
COMMENT= OpenSource alternative to Microsoft Windows RIS
RUN_DEPENDS= ${LOCALBASE}/libexec/in.tftpd:${PORTSDIR}/ftp/tftp-hpa
@@ -49,14 +48,13 @@ post-patch:
.endfor
do-install:
- @${MKDIR} ${DATADIR}
+ @${MKDIR} ${DATADIR}/
@${MKDIR} ${DATADIR}/inf
@${MKDIR} ${DATADIR}/sys
- @${INSTALL_DATA} ${WRKSRC}/winnt.sif ${DATADIR}
- @${INSTALL_DATA} ${WRKSRC}/winnt-ris.sif ${DATADIR}
- @${INSTALL_DATA} ${FILESDIR}/tftp.map ${DATADIR}
+ @${INSTALL_DATA} ${WRKSRC}/winnt.sif ${DATADIR}/
+ @${INSTALL_DATA} ${FILESDIR}/tftp.map ${DATADIR}/
.for SCRIPT in ${SCRIPTS}
- @${INSTALL_SCRIPT} ${WRKSRC}/${SCRIPT} ${DATADIR}
+ @${INSTALL_SCRIPT} ${WRKSRC}/${SCRIPT} ${DATADIR}/
.endfor
post-install:
diff --git a/net/ris/distinfo b/net/ris/distinfo
index dbb4bf6d0ec5..e7175ab2a8a2 100644
--- a/net/ris/distinfo
+++ b/net/ris/distinfo
@@ -1,3 +1,3 @@
-MD5 (ris-linux-0.3.tar.gz) = 1e089d285ea5651dd50325ac704dff70
-SHA256 (ris-linux-0.3.tar.gz) = fca88b9c64fc93d1ff1abacfbe4ff96548d28739512326ffd6b70ea0289e3072
-SIZE (ris-linux-0.3.tar.gz) = 19303
+MD5 (ris-linux-0.4.tar.gz) = 7315e1d02436668299f3d6aaf4efc87e
+SHA256 (ris-linux-0.4.tar.gz) = 196c7441f498154d1ae41ef4f1e5107296b7de39f345c763ccce2e913432ae19
+SIZE (ris-linux-0.4.tar.gz) = 21634
diff --git a/net/ris/files/patch-binlsrv.py b/net/ris/files/patch-binlsrv.py
index 484b58104686..55c1441b783b 100644
--- a/net/ris/files/patch-binlsrv.py
+++ b/net/ris/files/patch-binlsrv.py
@@ -1,5 +1,5 @@
---- binlsrv.py.orig Tue Aug 7 16:06:15 2007
-+++ binlsrv.py Tue Aug 7 16:35:02 2007
+--- binlsrv.py.orig 2007-09-28 19:29:12.000000000 +0400
++++ binlsrv.py 2010-01-07 18:50:47.218704824 +0300
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#! @PYTHON_CMD@
@@ -15,7 +15,7 @@
-a, --address= : ip address to bind to [all interfaces]
-p, --port= : port to bind to [4011]
--pid= : pid file to use instead of the default
-@@ -839,11 +839,11 @@
+@@ -1015,11 +1015,11 @@
## Defaults
global pidfile, s
daemon = False
diff --git a/net/ris/files/patch-infparser.py b/net/ris/files/patch-infparser.py
index 12283379ae2e..926bf33d58df 100644
--- a/net/ris/files/patch-infparser.py
+++ b/net/ris/files/patch-infparser.py
@@ -1,19 +1,19 @@
---- infparser.py.orig Tue Aug 7 16:10:14 2007
-+++ infparser.py Tue Aug 7 17:09:32 2007
+--- infparser.py.orig 2010-01-07 20:00:17.171071673 +0300
++++ infparser.py 2010-01-07 20:02:24.200743110 +0300
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#! @PYTHON_CMD@
# -*- Mode: Python; tab-width: 4 -*-
#
# Inf Driver parser
-@@ -293,28 +293,6 @@
- if inffile.split('/').pop() not in exclude:
- devlist.update(scan_inf(inffile))
+@@ -312,28 +312,6 @@
+ print format_exc()
+ print '---- CUT HERE ----'
- print 'Compiled %d drivers' % len(devlist)
-
-- fd = open('devlist.cache', 'w')
-+ fd = open('@DEVLIST_CACHE@', 'w')
+- fd = open('devlist.cache', 'wb')
++ fd = open('@DEVLIST_CACHE@', 'wb')
dump(devlist, fd)
fd.close()
- print 'generated devlist.cache'
diff --git a/net/ris/pkg-plist b/net/ris/pkg-plist
index 8fbad6542526..38e670814a15 100644
--- a/net/ris/pkg-plist
+++ b/net/ris/pkg-plist
@@ -1,7 +1,6 @@
@stopdaemon binlsrv
%%DATADIR%%/tftp.map
%%DATADIR%%/winnt.sif
-%%DATADIR%%/winnt-ris.sif
%%DATADIR%%/binlsrv.py
%%DATADIR%%/decode.py
%%DATADIR%%/fixloader.py