aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorhrs <hrs@FreeBSD.org>2015-09-12 07:50:55 +0800
committerhrs <hrs@FreeBSD.org>2015-09-12 07:50:55 +0800
commit41eb9d1a05dc4619fd93baa79c25f727c7ba3cff (patch)
tree3bf60ec0d54b63e81e76afc3c51bf753c22e8220 /net
parenta9c30a3f29b893bddc181aeebd957ece7a84242f (diff)
downloadfreebsd-ports-gnome-41eb9d1a05dc4619fd93baa79c25f727c7ba3cff.tar.gz
freebsd-ports-gnome-41eb9d1a05dc4619fd93baa79c25f727c7ba3cff.tar.zst
freebsd-ports-gnome-41eb9d1a05dc4619fd93baa79c25f727c7ba3cff.zip
- Temporarily disable -Werror to fix build on 11.x. Boost < 1.59.0 has
a lot of unused local typedefs while the newer versions use __attribulte__((unused)) to suppress the warning. - Add patches to remove BOOST_PFTO_WRAPPER(). This macro is obsolete in the newer versions of Boost.
Diffstat (limited to 'net')
-rw-r--r--net/kea/Makefile3
-rw-r--r--net/kea/files/patch-src-lib-util-encode-base16_from_binary.h14
-rw-r--r--net/kea/files/patch-src-lib-util-encode-base32hex_from_binary.h14
-rw-r--r--net/kea/files/patch-src-lib-util-encode-binary_from_base16.h14
-rw-r--r--net/kea/files/patch-src-lib-util-encode-binary_from_base32hex.h14
5 files changed, 58 insertions, 1 deletions
diff --git a/net/kea/Makefile b/net/kea/Makefile
index d0f58a46eb36..9b7a32b3e292 100644
--- a/net/kea/Makefile
+++ b/net/kea/Makefile
@@ -23,7 +23,8 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-silent-rules \
--with-openssl=${OPENSSLBASE} \
--with-log4cplus=${LOCALBASE} \
- --with-boost-include=${LOCALBASE}/include
+ --with-boost-include=${LOCALBASE}/include \
+ --without-werror
INSTALL_TARGET= install-strip
PORTDOCS= AUTHORS COPYING ChangeLog README \
kea-guide.css kea-guide.html kea-guide.txt \
diff --git a/net/kea/files/patch-src-lib-util-encode-base16_from_binary.h b/net/kea/files/patch-src-lib-util-encode-base16_from_binary.h
new file mode 100644
index 000000000000..ef2d89066f52
--- /dev/null
+++ b/net/kea/files/patch-src-lib-util-encode-base16_from_binary.h
@@ -0,0 +1,14 @@
+--- src/lib/util/encode/base16_from_binary.h.orig 2015-09-12 06:07:02.929641000 +0900
++++ src/lib/util/encode/base16_from_binary.h 2015-09-12 06:07:28.903859000 +0900
+@@ -85,9 +85,9 @@
+ public:
+ // make composable by using templated constructor
+ template<class T>
+- base16_from_binary(BOOST_PFTO_WRAPPER(T) start) :
++ base16_from_binary(T start) :
+ super_t(
+- Base(BOOST_MAKE_PFTO_WRAPPER(static_cast<T>(start))),
++ Base(static_cast<T>(start)),
+ detail::from_4_bit<CharType>()
+ )
+ {}
diff --git a/net/kea/files/patch-src-lib-util-encode-base32hex_from_binary.h b/net/kea/files/patch-src-lib-util-encode-base32hex_from_binary.h
new file mode 100644
index 000000000000..2c76f3dc0a10
--- /dev/null
+++ b/net/kea/files/patch-src-lib-util-encode-base32hex_from_binary.h
@@ -0,0 +1,14 @@
+--- src/lib/util/encode/base32hex_from_binary.h.orig 2015-09-12 06:08:07.415328000 +0900
++++ src/lib/util/encode/base32hex_from_binary.h 2015-09-12 06:08:28.438126000 +0900
+@@ -87,9 +87,9 @@
+ public:
+ // make composable by using templated constructor
+ template<class T>
+- base32hex_from_binary(BOOST_PFTO_WRAPPER(T) start) :
++ base32hex_from_binary(T start) :
+ super_t(
+- Base(BOOST_MAKE_PFTO_WRAPPER(static_cast<T>(start))),
++ Base(static_cast<T>(start)),
+ detail::from_5_bit<CharType>()
+ )
+ {}
diff --git a/net/kea/files/patch-src-lib-util-encode-binary_from_base16.h b/net/kea/files/patch-src-lib-util-encode-binary_from_base16.h
new file mode 100644
index 000000000000..dd250867f611
--- /dev/null
+++ b/net/kea/files/patch-src-lib-util-encode-binary_from_base16.h
@@ -0,0 +1,14 @@
+--- src/lib/util/encode/binary_from_base16.h.orig 2015-09-12 06:08:57.358126000 +0900
++++ src/lib/util/encode/binary_from_base16.h 2015-09-12 06:09:12.997499000 +0900
+@@ -93,9 +93,9 @@
+ public:
+ // make composable by using templated constructor
+ template<class T>
+- binary_from_base16(BOOST_PFTO_WRAPPER(T) start) :
++ binary_from_base16(T start) :
+ super_t(
+- Base(BOOST_MAKE_PFTO_WRAPPER(static_cast<T>(start))),
++ Base(static_cast<T>(start)),
+ detail::to_4_bit<CharType>()
+ )
+ {}
diff --git a/net/kea/files/patch-src-lib-util-encode-binary_from_base32hex.h b/net/kea/files/patch-src-lib-util-encode-binary_from_base32hex.h
new file mode 100644
index 000000000000..b42ab53c09ad
--- /dev/null
+++ b/net/kea/files/patch-src-lib-util-encode-binary_from_base32hex.h
@@ -0,0 +1,14 @@
+--- src/lib/util/encode/binary_from_base32hex.h.orig 2015-09-12 06:05:44.329389000 +0900
++++ src/lib/util/encode/binary_from_base32hex.h 2015-09-12 06:06:24.217165000 +0900
+@@ -96,9 +96,9 @@
+ public:
+ // make composable by using templated constructor
+ template<class T>
+- binary_from_base32hex(BOOST_PFTO_WRAPPER(T) start) :
++ binary_from_base32hex(T start) :
+ super_t(
+- Base(BOOST_MAKE_PFTO_WRAPPER(static_cast<T>(start))),
++ Base(static_cast<T>(start)),
+ detail::to_5_bit<CharType>()
+ )
+ {}