aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorhrs <hrs@FreeBSD.org>2013-05-04 04:28:15 +0800
committerhrs <hrs@FreeBSD.org>2013-05-04 04:28:15 +0800
commit45dbcb23a67f9c74e36858cee9edcd1fa5618f1a (patch)
tree1f56cce0b387ef48c60470ad9bbb154027aadf9b /net
parentbc87e7dcd91b46c3174ca2dce05f1517674092d6 (diff)
downloadfreebsd-ports-gnome-45dbcb23a67f9c74e36858cee9edcd1fa5618f1a.tar.gz
freebsd-ports-gnome-45dbcb23a67f9c74e36858cee9edcd1fa5618f1a.tar.zst
freebsd-ports-gnome-45dbcb23a67f9c74e36858cee9edcd1fa5618f1a.zip
- Update to 3.3.2.
- Add LICENSE. - Mark MAKE_JOBS_SAFE.
Diffstat (limited to 'net')
-rw-r--r--net/v6eval/Makefile17
-rw-r--r--net/v6eval/distinfo4
-rw-r--r--net/v6eval/files/patch-Bpfilter.h11
-rw-r--r--net/v6eval/files/patch-McIKE.h11
-rw-r--r--net/v6eval/files/patch-MvFunction.cc10
-rw-r--r--net/v6eval/files/patch-RAFControl.h11
-rw-r--r--net/v6eval/files/patch-hmac.c11
-rw-r--r--net/v6eval/files/patch-lib_Cm_BtObject.cc10
-rw-r--r--net/v6eval/files/patch-lib_Cm_CmMain.cc46
-rw-r--r--net/v6eval/files/patch-lib_pkt_Makefile12
-rw-r--r--net/v6eval/files/patch-sigcomp.c11
-rw-r--r--net/v6eval/files/patch-x509dec.c18
-rw-r--r--net/v6eval/pkg-plist16
13 files changed, 77 insertions, 111 deletions
diff --git a/net/v6eval/Makefile b/net/v6eval/Makefile
index 50cc58b6831c..f1378a076130 100644
--- a/net/v6eval/Makefile
+++ b/net/v6eval/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= v6eval
-PORTVERSION= 3.0.1
-PORTREVISION= 3
+PORTVERSION= 3.3.2
PORTEPOCH= 1
CATEGORIES= net ipv6
MASTER_SITES= http://www.tahi.org/release/v6eval/
@@ -11,17 +10,21 @@ MASTER_SITES= http://www.tahi.org/release/v6eval/
MAINTAINER= hrs@FreeBSD.org
COMMENT= IPv6 Conformance Test Platform
+LICENSE= BSD
+LICENSE_FILE= ${WRKSRC}/COPYRIGHT
+
RUN_DEPENDS= ${SITE_PERL}/Expect.pm:${PORTSDIR}/lang/p5-Expect
USE_PERL5= yes
USE_OPENSSL= yes
+MAKE_JOBS_SAFE= yes
+SUB_FILES= pkg-message
+
NO_MANCOMPRESS= yes
MAN1PREFIX= ${PREFIX}/v6eval
-MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3PREFIX= ${LOCALBASE}/lib/perl5/${PERL_VERSION}
MAN1= pktctl.1.gz pktsend.1.gz
MAN3= V6evalRemote.3 V6evalTool.3
-MAKE_JOBS_UNSAFE= yes
-SUB_FILES= pkg-message
.include <bsd.port.pre.mk>
@@ -29,10 +32,6 @@ SUB_FILES= pkg-message
RUN_DEPENDS+= p5-Digest-MD5>=2.16:${PORTSDIR}/security/p5-Digest-MD5
.endif
-#.if ${OSVERSION} > 900007
-#BROKEN= fails to build with new utmpx
-#.endif
-
post-install:
@${CAT} ${PKGMESSAGE}
diff --git a/net/v6eval/distinfo b/net/v6eval/distinfo
index 157ccad8878c..3be6cc2acc79 100644
--- a/net/v6eval/distinfo
+++ b/net/v6eval/distinfo
@@ -1,2 +1,2 @@
-SHA256 (v6eval-3.0.1.tar.gz) = 839594793ef9c41929449d6b92a5375775e5c6196bf3394b1043d3d9e6170332
-SIZE (v6eval-3.0.1.tar.gz) = 407851
+SHA256 (v6eval-3.3.2.tar.gz) = bb9ba46631917c2b95d490c4248238145d6df743dfadbb3862daa68e7fb712f4
+SIZE (v6eval-3.3.2.tar.gz) = 426871
diff --git a/net/v6eval/files/patch-Bpfilter.h b/net/v6eval/files/patch-Bpfilter.h
deleted file mode 100644
index 4f56ee46dbf5..000000000000
--- a/net/v6eval/files/patch-Bpfilter.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/pkt/Bpfilter.h 2001-10-05 20:41:19.000000000 +0900
-+++ lib/pkt/Bpfilter.h 2008-01-01 04:50:29.000000000 +0900
-@@ -62,7 +62,7 @@ public:
- int statistics(uint32_t&,uint32_t&) const;
- int receive(caddr_t) const;
- int send(caddr_t,uint32_t) const;
-- uint32_t Bpfilter::getDLT() const;
-+ uint32_t getDLT() const;
- };
- inline int Bpfilter::fileDesc() const {return fd_;}
- inline uint32_t Bpfilter::bufferSize() const {return bufsize_;}
diff --git a/net/v6eval/files/patch-McIKE.h b/net/v6eval/files/patch-McIKE.h
deleted file mode 100644
index 7cbe4a97943f..000000000000
--- a/net/v6eval/files/patch-McIKE.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/Pz/McIKE.h 2005-05-09 18:35:23.000000000 +0900
-+++ lib/Pz/McIKE.h 2008-01-01 04:36:34.000000000 +0900
-@@ -397,7 +397,7 @@ class WmISAKMP_Padding: public WmObject
-
- class PaISAKMP: public PaESP {
- public:
-- PaISAKMP::PaISAKMP(const MObject *m, CSTR st, int l):
-+ PaISAKMP(const MObject *m, CSTR st, int l):
- PaESP(m, st, l) {};
- virtual ~PaISAKMP() {}
-
diff --git a/net/v6eval/files/patch-MvFunction.cc b/net/v6eval/files/patch-MvFunction.cc
deleted file mode 100644
index f9924132c1b0..000000000000
--- a/net/v6eval/files/patch-MvFunction.cc
+++ /dev/null
@@ -1,10 +0,0 @@
---- lib/Pz/MvFunction.cc 2005-05-09 18:35:24.000000000 +0900
-+++ lib/Pz/MvFunction.cc 2008-01-01 04:41:51.000000000 +0900
-@@ -71,6 +71,7 @@ extern "C" {
- #include <netinet/in.h>
- #include <arpa/inet.h>
- #include <openssl/hmac.h>
-+#include <openssl/md5.h>
- #include <openssl/sha.h>
- }
-
diff --git a/net/v6eval/files/patch-RAFControl.h b/net/v6eval/files/patch-RAFControl.h
deleted file mode 100644
index 30cf23b14f4b..000000000000
--- a/net/v6eval/files/patch-RAFControl.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/pkt/RAFControl.h 2001-10-05 20:41:20.000000000 +0900
-+++ lib/pkt/RAFControl.h 2008-01-01 04:49:37.000000000 +0900
-@@ -69,7 +69,7 @@ virtual const PaObject* pop_SA(eAlgorith
- CSTR reverseEvaluate(const McObject&,PvOctets&,bool&);
- bool evaluateWith(RObject*,WObject*) const;
- WObject* evaluateAlgorithm(RObject*) const;
-- WObject* RAFControl::evaluate(RObject*);
-+ WObject* evaluate(RObject*);
- virtual void reset();
- void applyFrame(const WObject* w) const;
- const WAlgorithm* appliedAlgorithm() const;
diff --git a/net/v6eval/files/patch-hmac.c b/net/v6eval/files/patch-hmac.c
deleted file mode 100644
index 54438e569464..000000000000
--- a/net/v6eval/files/patch-hmac.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/Pz/crypto/hmac/hmac.c 2002-05-27 18:56:19.000000000 +0900
-+++ lib/Pz/crypto/hmac/hmac.c 2008-01-01 04:48:38.000000000 +0900
-@@ -60,7 +60,7 @@
- #include <stdio.h>
- #include <stdlib.h>
- #include <string.h>
--#include <openssl/hmac.h>
-+#include "hmac.h"
-
- void HMAC_Init(HMAC_CTX *ctx, const void *key, int len,
- const EVP_MD *md)
diff --git a/net/v6eval/files/patch-lib_Cm_BtObject.cc b/net/v6eval/files/patch-lib_Cm_BtObject.cc
deleted file mode 100644
index cc9c162c7b3d..000000000000
--- a/net/v6eval/files/patch-lib_Cm_BtObject.cc
+++ /dev/null
@@ -1,10 +0,0 @@
---- lib/Cm/BtObject.cc.orig 2001-10-11 20:56:13.000000000 -0800
-+++ lib/Cm/BtObject.cc 2008-02-03 13:27:51.000000000 -0900
-@@ -47,6 +47,6 @@
- BtObject::BtObject(const BtObject&) {}
- BtObject::~BtObject() {}
- uint32_t BtObject::hash() const {return 0;}
--int BtObject::compare(const BtObject*p) const {return (int)this-(int)p;}
-+int BtObject::compare(const BtObject*p) const {return (long)this-(long)p;}
- bool BtObject::isEqual(const BtObject* v) const {
- return compare(v)==0;}
diff --git a/net/v6eval/files/patch-lib_Cm_CmMain.cc b/net/v6eval/files/patch-lib_Cm_CmMain.cc
index 4519d9e59cf2..d9f46e37fe09 100644
--- a/net/v6eval/files/patch-lib_Cm_CmMain.cc
+++ b/net/v6eval/files/patch-lib_Cm_CmMain.cc
@@ -1,9 +1,10 @@
---- lib/Cm/CmMain.cc.orig 2003-10-23 13:37:30.000000000 +0900
-+++ lib/Cm/CmMain.cc 2013-03-06 04:38:49.000000000 +0900
-@@ -47,7 +47,11 @@
+--- lib/Cm/CmMain.cc.orig 2009-08-27 09:10:04.000000000 +0900
++++ lib/Cm/CmMain.cc 2013-05-04 04:59:43.000000000 +0900
+@@ -48,13 +48,17 @@
#include <string.h>
#include <stdlib.h>
#include <unistd.h>
++#include <sys/param.h>
+#if __FreeBSD_version <= 900006
#include <utmp.h>
+#else
@@ -12,12 +13,49 @@
#include <time.h>
#include <pwd.h>
#include <sys/time.h>
-@@ -129,7 +133,7 @@
+ #include <sys/types.h>
+ #include <sys/resource.h>
+-#include <sys/param.h>
+ extern int causeStopSignals[];
+ static int stopSingals[]={SIGINT,SIGQUIT,SIGTERM,0};
+ extern void applicationMain(CmMain*);
+@@ -129,21 +133,37 @@
+
//----------------------------------------------------------------------
// 障害解析情報作成
++#if __FreeBSD_version <= 900006
static struct utmp *myUtmpEnt(FILE *in,struct utmp *u) {
- int s=ttyslot();
+ int s = 0;
if(s<0||fseek(in,sizeof(struct utmp)*s,0)<0||
fread(u,sizeof(struct utmp),1,in)==0) {return 0;}
return u;}
+ void CmMain::makeCatch2Eye(STR p) {
+ static char catch2[]=" on %*.*s:%-*.*s from %*.*s";
+ struct utmp ux[1], *u; FILE *in;
+- if((in=fopen("/etc/utmp","r"))==NULL) {return;}
++ if((in=fopen(_PATH_UTMP,"r"))==NULL) {return;}
+ u=myUtmpEnt(in,ux); fclose(in);
+ if(!u) {return;}
+ #define A(a)sizeof(a),sizeof(a),a
+ sprintf(p,catch2,A(u->ut_line),A(u->ut_name),A(u->ut_host));
+ #undef A
+ return;}
++#else
++void CmMain::makeCatch2Eye(STR p) {
++static char catch2[]=" on %*.*s:%-*.*s from %*.*s";
++ struct utmpx ux, *u;
++ memset(&ux, 0, sizeof(ux));
++ ux.ut_type = USER_PROCESS;
++ snprintf(ux.ut_user, sizeof(ux.ut_user), "%d", getuid());
++ u = getutxuser(ux.ut_user);
++ if (u == NULL)
++ return;
++#define A(a)sizeof(a),sizeof(a),a
++ sprintf(p, catch2, A(u->ut_line), A(u->ut_user), A(u->ut_host));
++#undef A
++ return;}
++#endif
+ void CmMain::makeCatchEye(const STR pgmName) {
+ static char catch1[]="@(#) %02d/%02d/%02d %02d:%02d:%02d %s STARTED by %s@%s";
+ time_t now=time(0); struct tm *m=localtime(&now);
diff --git a/net/v6eval/files/patch-lib_pkt_Makefile b/net/v6eval/files/patch-lib_pkt_Makefile
new file mode 100644
index 000000000000..624937bf99be
--- /dev/null
+++ b/net/v6eval/files/patch-lib_pkt_Makefile
@@ -0,0 +1,12 @@
+--- lib/pkt/Makefile.orig 2013-05-04 05:06:29.000000000 +0900
++++ lib/pkt/Makefile 2013-05-04 05:06:32.000000000 +0900
+@@ -5,6 +5,9 @@
+ BpfAgent.cc Bpfilter.cc Ringbuf.cc RunEnv.cc PktCtlClient.cc \
+ PktSndClient.cc PktRcvClient.cc PktBuf.cc PktQueue.cc bufStat.cc
+
++LxLexer.o: PzParse.h
++PzParse.h: PzParse.cc
++
+ CXXFLAGS+= -I. -I$(Cm) -I$(Pz) -DHAVE_BPF_HDRCMPLT -I/usr/include
+ # CXXFLAGS+= -DVCLEAR_DBG
+
diff --git a/net/v6eval/files/patch-sigcomp.c b/net/v6eval/files/patch-sigcomp.c
deleted file mode 100644
index b14a8ea4a0be..000000000000
--- a/net/v6eval/files/patch-sigcomp.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- bin/sigcomp/sigcomp.c 2005-05-27 20:40:19.000000000 +0900
-+++ bin/sigcomp/sigcomp.c 2008-01-01 06:03:23.000000000 +0900
-@@ -53,7 +53,7 @@
-
- #include <openssl/err.h>
- #include <openssl/evp.h>
--
-+#include <openssl/rsa.h>
-
-
- #ifdef DEBUG
diff --git a/net/v6eval/files/patch-x509dec.c b/net/v6eval/files/patch-x509dec.c
deleted file mode 100644
index fd6a9afa91cf..000000000000
--- a/net/v6eval/files/patch-x509dec.c
+++ /dev/null
@@ -1,18 +0,0 @@
---- bin/x509dec/x509dec.c 2005-05-30 19:17:31.000000000 +0900
-+++ bin/x509dec/x509dec.c 2008-01-01 06:02:24.000000000 +0900
-@@ -244,13 +244,13 @@ x509dec_on_evp(const X509 *const x509)
-
- TAILQ_INIT(&head);
-
-- if(!((unsigned char *)pubkey =
-+ if(!(pubkey =
- X509dec_get_pubkey(x509, &pubkeylen))) {
-
- return(x509dec_on_evp_return(false, pubkey, subject_name));
- }
-
-- if(!((unsigned char *)subject_name =
-+ if(!(subject_name =
- X509dec_get_subject_name(x509, (int *)&subject_namelen))) {
-
- return(x509dec_on_evp_return(false, pubkey, subject_name));
diff --git a/net/v6eval/pkg-plist b/net/v6eval/pkg-plist
index 894fe1a1173d..fa3f9e67b58e 100644
--- a/net/v6eval/pkg-plist
+++ b/net/v6eval/pkg-plist
@@ -5,6 +5,7 @@ v6eval/bin/checker
v6eval/bin/dhcomp
v6eval/bin/dhgen
v6eval/bin/file2hex
+v6eval/bin/indexgen
v6eval/bin/ivcomp
v6eval/bin/manual/cleardefr.rmt
v6eval/bin/manual/clearmtu.rmt
@@ -12,6 +13,7 @@ v6eval/bin/manual/clearnc.rmt
v6eval/bin/manual/clearprefix.rmt
v6eval/bin/manual/clearroute.rmt
v6eval/bin/manual/dhcp6c.rmt
+v6eval/bin/manual/dhcp6r.rmt
v6eval/bin/manual/dhcp6s.rmt
v6eval/bin/manual/igmpv3.rmt
v6eval/bin/manual/igmpv3config.rmt
@@ -36,6 +38,13 @@ v6eval/bin/manual/mip6EnableCN.rmt
v6eval/bin/manual/mip6EnableHA.rmt
v6eval/bin/manual/mip6EnableMN.rmt
v6eval/bin/manual/mldv2.rmt
+v6eval/bin/manual/mldv2DisableHUT.rmt
+v6eval/bin/manual/mldv2DisableRUT.rmt
+v6eval/bin/manual/mldv2EnableHUT.rmt
+v6eval/bin/manual/mldv2EnableRUT.rmt
+v6eval/bin/manual/mldv2ListenerAPI.rmt
+v6eval/bin/manual/mldv2SetHUT.rmt
+v6eval/bin/manual/mldv2SetRUT.rmt
v6eval/bin/manual/mldv2config.rmt
v6eval/bin/manual/mtuconfig.rmt
v6eval/bin/manual/multicastConfig.rmt
@@ -62,12 +71,14 @@ v6eval/bin/pktrecv
v6eval/bin/pktsend
v6eval/bin/prfcomp
v6eval/bin/sigcomp
+v6eval/bin/x509dec
v6eval/bin/unknown/cleardefr.rmt
v6eval/bin/unknown/clearmtu.rmt
v6eval/bin/unknown/clearnc.rmt
v6eval/bin/unknown/clearprefix.rmt
v6eval/bin/unknown/clearroute.rmt
v6eval/bin/unknown/dhcp6c.rmt
+v6eval/bin/unknown/dhcp6r.rmt
v6eval/bin/unknown/dhcp6s.rmt
v6eval/bin/unknown/igmpv3.rmt
v6eval/bin/unknown/igmpv3config.rmt
@@ -111,7 +122,6 @@ v6eval/bin/unknown/sysctl.rmt
v6eval/bin/unknown/tcp6.rmt
v6eval/bin/unknown/tunnel.rmt
v6eval/bin/unknown/useTempAddr.rmt
-v6eval/bin/x509dec
v6eval/doc/00README
v6eval/doc/00README.v6eval
v6eval/doc/CHANGELOG
@@ -128,12 +138,12 @@ v6eval/include/stdpacket.def
@dirrm v6eval/bin/manual
@dirrm v6eval/bin/unknown
@dirrm v6eval/bin
-@dirrm v6eval/doc
+@dirrmtry v6eval/doc
@dirrm v6eval/include
@dirrm v6eval/man/man1
@dirrm v6eval/man
@dirrmtry v6eval/etc
-@dirrm v6eval
+@dirrmtry v6eval
%%SITE_PERL%%/V6evalCommon.pm
%%SITE_PERL%%/V6evalRemote.pm
%%SITE_PERL%%/V6evalTool.pm