aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorobraun <obraun@FreeBSD.org>2003-01-29 00:50:01 +0800
committerobraun <obraun@FreeBSD.org>2003-01-29 00:50:01 +0800
commit47d2e9ff10ff7d7af9a6a7d4c109404b1878ef76 (patch)
treeac280cf5f41f96c064aa1add1d66a79f715b1055 /net
parentfb7b64e0a2e2d0cda138ee8cfb9658554002c142 (diff)
downloadfreebsd-ports-gnome-47d2e9ff10ff7d7af9a6a7d4c109404b1878ef76.tar.gz
freebsd-ports-gnome-47d2e9ff10ff7d7af9a6a7d4c109404b1878ef76.tar.zst
freebsd-ports-gnome-47d2e9ff10ff7d7af9a6a7d4c109404b1878ef76.zip
Upgrade to 2.5.6.
SSH-patches are no longer needed, using ./configure --with-rsh=ssh instead. Tested on sparc64 by: Hiroki Sato <hrs@eos.ocn.ne.jp>
Diffstat (limited to 'net')
-rw-r--r--net/rsync/Makefile29
-rw-r--r--net/rsync/distinfo2
-rw-r--r--net/rsync/files/ssh-patch-README8
-rw-r--r--net/rsync/files/ssh-patch-main.c5
-rw-r--r--net/rsync/files/ssh-patch-options.c5
-rw-r--r--net/rsync/files/ssh-patch-rsync.121
-rw-r--r--net/rsync/files/ssh-patch-rsync.h8
7 files changed, 16 insertions, 62 deletions
diff --git a/net/rsync/Makefile b/net/rsync/Makefile
index f624aded744f..6da5fc19cc64 100644
--- a/net/rsync/Makefile
+++ b/net/rsync/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= rsync
-PORTVERSION= 2.5.5
-PORTREVISION= 1
+PORTVERSION= 2.5.6
CATEGORIES= net ipv6
MASTER_SITES= ftp://samba.anu.edu.au/pub/rsync/ \
ftp://sunsite.auc.dk/pub/unix/rsync/ \
@@ -23,11 +22,13 @@ LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt
USE_REINPLACE= yes
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-debug
+
.if defined(WITH_POPT_PORT)
CONFIGURE_ENV= CFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
.else
-CONFIGURE_ARGS= --with-included-popt
+CONFIGURE_ARGS+= --with-included-popt
.endif
.include <bsd.port.pre.mk>
@@ -39,14 +40,15 @@ USE_SSH?= no
.endif
.if ${USE_SSH:U} == YES
-EXTRA_PATCHES= ${FILESDIR}/ssh-patch-*
+CONFIGURE_ARGS+= --with-rsh=ssh
.endif
.if ${OSVERSION} >= 400014
-CONFIGURE_ARGS+= --disable-debug --enable-ipv6
+CONFIGURE_ARGS+= --enable-ipv6
.else
-CONFIGURE_ARGS+= --disable-debug --disable-ipv6
+CONFIGURE_ARGS+= --disable-ipv6
.endif
+
MAN1= rsync.1
MAN5= rsyncd.conf.5
@@ -62,18 +64,17 @@ pre-configure:
${WRKSRC}/rsync.h ${WRKSRC}/rsync.1 ${WRKSRC}/rsyncd.conf.5
@${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|g' \
${WRKSRC}/rsync.h ${WRKSRC}/zlib/zutil.h
-.if defined(WITH_SSH)
- @${REINPLACE_CMD} -e 's/"rsh"/"ssh"/g' ${WRKSRC}/rsync.h
-.endif
post-install:
- @strip ${PREFIX}/bin/rsync
+ @{STRIP_CMD} ${PREFIX}/bin/rsync
.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/doc/rsync
- ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/rsync
- ${INSTALL_DATA} ${WRKSRC}/COPYING ${PREFIX}/share/doc/rsync
- ${INSTALL_DATA} ${WRKSRC}/tech_report.tex ${PREFIX}/share/doc/rsync
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/COPYING ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/tech_report.tex ${DOCSDIR}
.endif
+.if ${USE_SSH:U} == YES
@${CAT} ${PKGMESSAGE}
+.endif
.include <bsd.port.post.mk>
diff --git a/net/rsync/distinfo b/net/rsync/distinfo
index b3fe3bf48f0d..767d7131850c 100644
--- a/net/rsync/distinfo
+++ b/net/rsync/distinfo
@@ -1 +1 @@
-MD5 (rsync-2.5.5.tar.gz) = b34b5a5eed243fe18b667e2c1d34b3b6
+MD5 (rsync-2.5.6.tar.gz) = ec39fcea433df4d6a3a4e0896c655535
diff --git a/net/rsync/files/ssh-patch-README b/net/rsync/files/ssh-patch-README
deleted file mode 100644
index 5daf36387947..000000000000
--- a/net/rsync/files/ssh-patch-README
+++ /dev/null
@@ -1,8 +0,0 @@
---- README.orig Tue Sep 5 19:46:43 2000
-+++ README Thu Mar 8 03:31:32 2001
-@@ -60 +60 @@
-- -e, --rsh=COMMAND specify rsh replacement
-+ -e, --rsh=COMMAND specify rsh replacement (default ssh)
-@@ -96 +96 @@
--rsh or ssh system. Using ssh is recommended for its security
-+rsh or ssh system. Using rsh is discouraged for lack of security
diff --git a/net/rsync/files/ssh-patch-main.c b/net/rsync/files/ssh-patch-main.c
deleted file mode 100644
index 295429f2476e..000000000000
--- a/net/rsync/files/ssh-patch-main.c
+++ /dev/null
@@ -1,5 +0,0 @@
---- main.c.orig Tue Sep 5 19:46:43 2000
-+++ main.c Sat Apr 7 23:32:25 2001
-@@ -134 +134 @@
-- cmd = RSYNC_RSH;
-+ cmd = RSYNC_SSH;
diff --git a/net/rsync/files/ssh-patch-options.c b/net/rsync/files/ssh-patch-options.c
deleted file mode 100644
index 8fe17d89eb6f..000000000000
--- a/net/rsync/files/ssh-patch-options.c
+++ /dev/null
@@ -1,5 +0,0 @@
---- options.c.orig Thu Mar 8 03:31:32 2001
-+++ options.c Thu Mar 8 03:31:32 2001
-@@ -141 +141 @@
-- rprintf(F," -e, --rsh=COMMAND specify rsh replacement\n");
-+ rprintf(F," -e, --rsh=COMMAND specify rsh replacement (default %s)\n", RSYNC_SSH);
diff --git a/net/rsync/files/ssh-patch-rsync.1 b/net/rsync/files/ssh-patch-rsync.1
deleted file mode 100644
index a8ab98002689..000000000000
--- a/net/rsync/files/ssh-patch-rsync.1
+++ /dev/null
@@ -1,21 +0,0 @@
---- rsync.1.orig Tue Sep 5 19:46:43 2000
-+++ rsync.1 Thu Mar 8 03:34:47 2001
-@@ -89,2 +89,2 @@
--Once installed you can use rsync to any machine that you can use rsh
--to\&. rsync uses rsh for its communications, unless both the source and
-+Once installed you can use rsync to any machine that you can use ssh
-+to\&. rsync uses ssh for its communications, unless both the source and
-@@ -93 +93 @@
--You can also specify an alternative to rsh, by either using the -e
-+You can also specify an alternative to ssh, by either using the -e
-@@ -273 +273 @@
-- -e, --rsh=COMMAND specify rsh replacement
-+ -e, --rsh=COMMAND specify rsh replacement (default ssh)
-@@ -566,2 +566,2 @@
--remote copies of rsync\&. By default, rsync will use rsh, but you may
--like to instead use ssh because of its high security\&.
-+remote copies of rsync\&. By default, rsync will use ssh, but you may
-+need to use the much less secure rsh for compatibility reasons\&.
-@@ -890 +890 @@
-- rsh remotehost /bin/true > out\&.dat
-+ ssh remotehost /bin/true > out\&.dat
diff --git a/net/rsync/files/ssh-patch-rsync.h b/net/rsync/files/ssh-patch-rsync.h
deleted file mode 100644
index 444182bf9967..000000000000
--- a/net/rsync/files/ssh-patch-rsync.h
+++ /dev/null
@@ -1,8 +0,0 @@
---- rsync.h.orig Sat Aug 19 06:10:39 2000
-+++ rsync.h Sat Apr 7 23:31:00 2001
-@@ -75,4 +75,5 @@
- #define RSYNC_RSH "rsh"
- #endif
-+#define RSYNC_SSH "ssh"
-
- #include <sys/types.h>
184d487f93'>Introduce 2 new USES: sqlite and firebirdbapt2016-01-111-0/+6 * Change the meaning of NO_WRKSUBDIR to force a WRKDIR != WRKSRC.mat2015-11-051-0/+17 * - Add shebangfix documentation bitsamdmi32015-10-221-0/+15 * Readd PORTSDIR for now we will only start removing them after 2016Q1 is branchedbapt2015-10-151-14/+0 * Drop the necessity to add ${PORTSDIR} to dependency linebapt2015-10-151-0/+14 * Rewording missed from previous commitamdmi32015-09-291-2/+2 * Implemented complete support for test target.amdmi32015-09-291-0/+20 * Extend @sample to accept argumentsbapt2015-09-261-1/+10 * Document @{pre,post}[un]exec in CHANGESbapt2015-09-261-0/+12 * Make it so that the default Perl is always called perl5.mat2015-09-141-0/+6 * Add generic opt_VARS/opt_VARS_OFF.mat2015-08-281-0/+11 * Document r394572 in CHANGES.rakuco2015-08-181-0/+6 * Introduce <opt>_IMPLIES and <opt>_PREVENTS to register dependencies, ormat2015-08-181-0/+14 * Remove UNIQUENAME and LATEST_LINK.mat2015-08-171-0/+8 * Convert code in bsd.port.mk for USE_GHOSTSCRIPT* to USES=ghostscript.kwm2015-07-171-0/+7 * Introduce target option helpers.mat2015-07-011-0/+32 * Document the removal of USE_RCORDERbapt2015-06-231-0/+6 * Introduce USE_GITHUB=nodefault to allow fetching additional distfilesmat2015-05-291-0/+7 * USE_GITHUB can now fetch multiple distfiles. It uses a grouping featuremat2015-05-291-0/+29 * Switch PYTHON_REL from a 3 digits number to a 4 digits number to handleantoine2015-05-271-0/+8 * Remove GH_COMMIT support.mat2015-05-211-0/+5 * Mark USE_AUTOTOOLS deprecated and remove support for libtoolize.tijl2015-04-201-0/+9 * Convert bsd.gnustep.mk to USES=gnustepbapt2015-04-091-0/+11 * Document the new USES=waf into CHANGESbapt2015-04-081-0/+20 * USE_BZIP2 and USE_XZ are not used anymore in the ports tree mark them asbapt2015-04-071-0/+6 * - track subversion http module activation change in the correct fileohauer2015-04-071-7/+0 * Document recent changesbapt2015-04-011-0/+16 * - document new subversion httpd module fileohauer2015-04-011-0/+7 * Document removal of PTHREAD_LIBS/PTHREAD_CFLAGSbdrewery2015-03-271-0/+6 * Undocument BSDMAKE from r381977 as I have thought of a better way and willbdrewery2015-03-231-7/+0 * Introduce a BSDMAKE?= /usr/bin/make and use it as the default MAKE_CMD.bdrewery2015-03-231-0/+7 * Remove GITHUB_RELEASE MASTER_SITE from r375010 as it is now redundant with GI...bdrewery2015-03-201-0/+8 * Note that GH_TAGNAME can be any length of the git hash.bdrewery2015-03-201-0/+3 * Update USE_GITHUB so it does not require GH_COMMIT.bdrewery2015-03-201-0/+14 * The FreeBSD Xfce team proudly presents Xfce 4.12.olivierd2015-03-061-0/+6 * Introduce new USE_QT4 component linguisttools for lrelease/lupdate toolsmakc2015-02-251-0/+9 * Make Perl link all .so it builds with libperl.so.mat2014-12-171-0/+9 * Split devel/gettext in devel/gettext-runtime and devel/gettext-tools. Thetijl2014-11-301-0/+13 * Change the way Perl modules are installed, update the default Perl to 5.18.mat2014-11-261-0/+29 * Finally retire USE_PGSQLcrees2014-11-231-0/+10 * Introduce the SITE_ARCH variable containing SITE_PERL/PERL_ARCH.mat2014-11-181-0/+6 * - Enable SSP by default.bdrewery2014-11-031-0/+8 * Add an example with @exec too.mat2014-10-081-0/+3 * Note @cwd being deprecated.mat2014-10-071-0/+15 * Add BUNDLE_LIBS knob to prevent pkg(8) from automatically add provided shlibsbapt2014-10-021-0/+7 * Remove support for old autoconf and automake versions from USE_AUTOTOOLS:tijl2014-10-011-0/+6 * If either of OSVERSION or UNAME_r is improperly set when building in abdrewery2014-10-011-0/+30 * Add hint as to where @stopdaemon has gone.mandree2014-09-251-21/+20 * Proofread the 20140922 CHANGES entry.rakuco2014-09-241-4/+4 * Document recent changes in plist handlingbapt2014-09-221-0/+19 * - Remove last uses of USE_AUTOTOOLS=libtool from bsd.gnome.mktijl2014-09-171-0/+10 * Document r368281.tijl2014-09-171-0/+11 * Remove support for pkg_installbapt2014-09-011-0/+9 * Remove support for NO_STAGEbapt2014-09-011-0/+5 * Document r366154antoine2014-08-261-0/+5 * - Rename PYTHON_FEATURES to USE_PYTHON to comply to USE_PERL5 and to avoid amva2014-08-151-3/+3 * - Fix typosunpoet2014-08-101-2/+2 * Convert the Python framework bits to USES=python.mva2014-08-091-0/+23 * Now that all LIB_DEPENDS has been switched to modern version, remove supportbapt2014-07-161-0/+5 * Support for installations based on the easy_install setup.py target hasmva2014-07-091-0/+8 * Add a bit about USE_PERL5=fixpacklist here.mat2014-06-291-0/+7 * Remove the IGNOREFILES feature: it was an unsafe feature allowing to use filesbapt2014-06-231-0/+7 * Introduce a new PYTHON_CONCURRENT_INSTALL knob to support the parallelmva2014-06-081-0/+27 * - Remove USE_GMAKE support, please use USES=gmake insteadmiwi2014-05-291-0/+5 * Drop compatibility code for USE_DOS2UNIXbapt2014-05-261-0/+5 * Convert all :U to :tu and :L to :tlbapt2014-05-051-0/+9 * Document r352514bapt2014-05-011-0/+9 * When linking a library libA with a library libB using libtool, if libB.latijl2014-04-231-0/+12 * - Rename check-orphans to check-plist. Keep the old for backwards-compat.bdrewery2014-04-191-0/+16 * - Make default target "make stage" if staging supported.bdrewery2014-04-171-0/+6 * - Add a @sample plist keywordbdrewery2014-04-121-0/+17 * Two new USES added to finish handling distfiles formats a consistent way:bapt2014-03-121-0/+14 * Add a note for USES=zip and USES=makeself which were recently added by baptrene2014-03-081-0/+10 * KDE/FreeBSD team is happy to present Qt 5 in ports!makc2014-03-041-0/+7 * - Whitespace cleanupmiwi2014-01-291-11/+11 * Add two new options helpers:mat2014-01-281-0/+11 * New USES=uniquefiles to make files or directories uniquemva2014-01-121-0/+38 * - Remove lang/python as implicit build and run dependency frommva2013-12-191-0/+22 * New USES=fortran to replace USE_FORTRAN.tijl2013-12-131-0/+14 * New USES=twisted, to replace the old USE_TWISTED knob.mva2013-12-081-0/+17 * Remove ltverhack's hard depend on USE_AUTOTOOLS=libtool.kwm2013-11-201-0/+15 * Indent 20131031 entry like the rest of the file.kwm2013-11-201-10/+10 * Add a description of USES=kmodrene2013-10-311-0/+14 * - Remove manual creation and removal of share/applications, as it's now in th...amdmi32013-10-221-0/+6 * - Fix typosunpoet2013-10-201-1/+1 * New USES=compilerbapt2013-10-091-0/+18 * - Add new USES= qmake (with staging support)makc2013-10-091-0/+8 * - PATCHFILES now support an optional :-pX flag that notes which patch stripbdrewery2013-10-051-0/+9 * Introduce the new "scons" USES. The goal is to replace the old bsd.scons.mkbapt2013-10-031-0/+6 * Add an entry about "create packages as a user"bapt2013-09-241-3/+16 * - add new USES target: zope, and convert the tree to itrm2013-09-231-0/+8 * Add support for staging area in the ports treebapt2013-09-231-0/+29 * - Rename public name of SSP support to WITH_SSP_PORTS as /usr/srcbdrewery2013-09-221-2/+2 * SSP support has been added to ports with WITH_SSP for i386 and amd64bdrewery2013-09-201-0/+22 * - Document the addition of tcl/tk to the USES and DEFAULT_VERSIONS framework.gahr2013-09-191-0/+14 * Remove the old perl framework, that also means all the perl code is not loade...bapt2013-09-181-0/+11 * - proper formatingaz2013-09-071-1/+4 * - Make ports use the libc provided iconv implementation on 10-CURRENTmadpilot2013-09-051-0/+18 * Back to the presentbapt2013-09-041-1/+1 * Document the removal of USE_GNOME=pkgconfigbapt2013-09-021-0/+6 * - Add USE_PACKAGE_DEPENDS_ONLY which will try installing dependenciesbdrewery2013-08-311-0/+7 * Back to the presentbapt2013-07-311-1/+1 * Typobapt2013-07-311-1/+1 * Document the new USE=perl5bapt2013-07-311-0/+33 * KDE3 and QT3 expired on 2013-07-01, remove these ports.rene2013-07-271-0/+10 * New USES imake to handle the dependency on imake.bapt2013-06-281-0/+12 * Fix AUTHORS line in the last entrybapt2013-06-261-1/+2 * Add a new USES: fmakebapt2013-06-201-1/+8 * Fix two typos: add two trailing curly braces.bsam2013-06-201-2/+2 * Document the fact that _DEPENDS now also has per options helpersbapt2013-06-141-0/+3 * Add a forgotten helper:bapt2013-06-141-0/+6 * New macros to help dealing with ports that have options:bapt2013-06-141-0/+31 * Add a USES display to replace USE_DISPLAY.bapt2013-06-141-0/+13 * Fix ports using GH_TAGNAME=master to depend on a known hashbdrewery2013-06-081-0/+8 * Add WRKSRC_SUBDIR to simplify overriding WRKSRC:bdrewery2013-06-071-0/+12 * Wordingbapt2013-06-061-2/+2 * Remove support for parsing the old OPTIONS macro, the compatibility code to l...bapt2013-06-061-0/+6 * Document new USES: desktop-file-utils and shared-mime-info.kwm2013-05-091-0/+26 * USE_GETTEXT has totally been replaced by USES=gettext thanks, jgh and akbapt2013-05-071-0/+2 * Add new USES: shebangfixbapt2013-05-071-0/+10 * Add new USES: ncurses and readlinebapt2013-05-061-0/+16 * Introduces USES= iconv to replace USE_ICONV.mva2013-04-271-1/+8 * Remove USE_CDRTOOLS from bsd.port.mkbapt2013-04-261-0/+1 * Remove USE_FREETYPE from bsd.port.mkbapt2013-04-261-0/+5 * Introduces USES= gettext to replace USE_GETTEXTjgh2013-04-231-0/+13 * Fix datebapt2013-04-231-1/+1 * - Add WITH_CCACHE_BUILD support during 'configure' phasebdrewery2013-04-231-0/+9 * Introduce USES= pkgconfig to replace USE_PKGCONFIGbapt2013-04-231-0/+12 * - Add New USES macro to handle support for Zenoss ports and Zenpacks:jgh2013-03-201-0/+7 * Convert USE_CMAKE to USES macro:makc2013-03-201-0/+15 * Make the ports tree use dialog4ports for make config.bapt2013-03-191-0/+10 * Document USES=qmailbdrewery2013-03-161-0/+11 * Document the introduction of Keywords/info.yaml in CHANGESbapt2013-03-151-0/+7 * Add a note about the new USES macro and the new USES= pathfix fusebapt2013-03-071-0/+9 * - Fix Whitespacesmiwi2013-02-081-1/+1 * - Document that PTHREAD_CFLAGS and PTHREAD_LIBS are unsupportedgahr2013-02-071-0/+7 * - introduce a USE_FUSE macroflo2012-12-141-0/+7 * Extend the options framework providing 2 new macros:bapt2012-12-101-0/+7 * Minor whitespace and formatting fixes.danfe2012-11-171-3/+3 * We are in 2012, it is time to activate IPV6 options by default everywherebapt2012-10-101-0/+5 * Switching current to use pkgng by defaultbapt2012-10-101-0/+10 * - Add ccache support for building ports. [1]beat2012-08-301-0/+16 * - Add support for fetching from GitHub in bsd.sites.mkgahr2012-08-201-0/+22 * new devel/pkgconf added to replace devel/pkg-config. new version of pkg-configbapt2012-07-261-0/+15 * - use UPDATING instead CHANGESohauer2012-07-231-5/+0 * - use reserverd UID/GIDohauer2012-07-211-0/+5 * - Keep questions on a public mailing listbeat2012-07-161-1/+1 * - Add a note about the switch to Subversionbeat2012-07-161-0/+15 * - Fix copy-paste errorak2012-06-251-2/+2 * Give a passing mention of OPTIONSngcrees2012-06-241-0/+11 * - Add CHANGES entry on recent LDFLAGS updateamdmi32011-09-271-0/+19 * Describe how CPPFLAGS is now passed to both the configure and makegerald2011-06-071-0/+15 * Autotools update. Read ports/UPDATING 20100915 for details.ade2010-09-161-0/+8 * USE_GCC=4.3 is deprecated (and no port uses it anymore). USE_GCC=4.3+gerald2010-06-071-0/+7 * - Add entry in CHANGES about bsd.licenses*.mk.alepulver2010-05-261-0/+9 * - add 1 missing WITH_APACHEXX option to CHANGES thats now deadpgollucci2010-05-261-1/+1 * Bump copyright year to 2010erwin2010-01-031-1/+1 * be more specific about WITH_APACHE2 and friendspgollucci2009-12-261-1/+1 * Remove myself as maintainer and hand over to portmgrerwin2009-09-151-6/+3 * Mention the new USERS/GROUPS variable.flz2009-09-07