aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorflo <flo@FreeBSD.org>2012-07-19 06:57:42 +0800
committerflo <flo@FreeBSD.org>2012-07-19 06:57:42 +0800
commit48cb50b1294c1d7009aa680d58db1078fc7bfeb5 (patch)
tree52de03dff77faf62dd61eb3aac0024d2655a0398 /net
parentcd84ecf28f8b5221c526640ed4169b25c455dd6b (diff)
downloadfreebsd-ports-gnome-48cb50b1294c1d7009aa680d58db1078fc7bfeb5.tar.gz
freebsd-ports-gnome-48cb50b1294c1d7009aa680d58db1078fc7bfeb5.tar.zst
freebsd-ports-gnome-48cb50b1294c1d7009aa680d58db1078fc7bfeb5.zip
- fix a logic bug in the DAHDI and H323 options, the logic was the wrong way
around. Selecting the option turned it off and vice versa. [1] - bump PORTREVISION - remove remnants of old options framework Reported by: Attila Bogar <attila.bogar@gmail.com> [1] David Froehlich <dfroe@gmx.de> [1]
Diffstat (limited to 'net')
-rw-r--r--net/asterisk/Makefile16
1 files changed, 7 insertions, 9 deletions
diff --git a/net/asterisk/Makefile b/net/asterisk/Makefile
index 98c4d0a97c1b..44e9e398a95e 100644
--- a/net/asterisk/Makefile
+++ b/net/asterisk/Makefile
@@ -7,6 +7,7 @@
PORTNAME= asterisk
PORTVERSION= 1.8.14.1
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://downloads.asterisk.org/pub/telephony/asterisk/ \
http://downloads.asterisk.org/pub/telephony/asterisk/old-releases/
@@ -81,9 +82,6 @@ VARDIR=${PREFIX}/var
OPTIONS_DEFINE+= DAHDI
OPTIONS_DEFAULT+= DAHDI
DAHDI_DESC?= DAHDI support
-
-# Include this since we have altered OPTIONS.
-.include <bsd.port.options.mk>
.endif
SUB_LIST+= ASTERISK_USER=${ASTERISK_USER}
@@ -92,25 +90,25 @@ PLIST_SUB+= ASTERISK_GROUP=${ASTERISK_GROUP}
PLIST_SUB+= VARDIR=${VARDIR}
.if ${PORT_OPTIONS:MH323}
-PLIST_SUB+= WITH_H323="@comment "
-CONFIGURE_ARGS+= --without-h323
-.else
PLIST_SUB+= WITH_H323=""
CONFIGURE_ARGS+= --with-h323=${LOCALBASE}
LIB_DEPENDS+= pt_r.1:${PORTSDIR}/devel/pwlib \
h323_r.1:${PORTSDIR}/net/openh323
+.else
+PLIST_SUB+= WITH_H323="@comment "
+CONFIGURE_ARGS+= --without-h323
.endif
.if ${PORT_OPTIONS:MDAHDI}
-PLIST_SUB+= WITH_DAHDI="@comment "
-CONFIGURE_ARGS+= --without-dahdi --without-openr2
-.else
PLIST_SUB+= WITH_DAHDI=""
CONFIGURE_ARGS+= --with-dahdi --with-openr2
BUILD_DEPENDS+= libpri>=1.4.10:${PORTSDIR}/misc/libpri \
${LOCALBASE}/include/dahdi/user.h:${PORTSDIR}/misc/dahdi
LIB_DEPENDS+= pri.1:${PORTSDIR}/misc/libpri\
openr2.4:${PORTSDIR}/misc/openr2
+.else
+PLIST_SUB+= WITH_DAHDI="@comment "
+CONFIGURE_ARGS+= --without-dahdi --without-openr2
.endif
#