aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-10-17 14:57:53 +0800
committermiwi <miwi@FreeBSD.org>2009-10-17 14:57:53 +0800
commit5302d070fef77428668af6bcecf8a433bf447ec3 (patch)
treed741b16ffad71f1ed66885c7403401965202e635 /net
parentfdbe811574df9e16692b5814a48d202e5bf73b6f (diff)
downloadfreebsd-ports-gnome-5302d070fef77428668af6bcecf8a433bf447ec3.tar.gz
freebsd-ports-gnome-5302d070fef77428668af6bcecf8a433bf447ec3.tar.zst
freebsd-ports-gnome-5302d070fef77428668af6bcecf8a433bf447ec3.zip
This program produces numerous reports from OpenLDAP 2.1, 2.2, 2.3 and 2.4
slapd logfiles to allow OpenLDAP administrator to analyze server's performance. WWW: http://prefetch.net/code/index.html PR: ports/139474 Submitted by: Alexey V. Degtyarev <alexey at renatasystems.org>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/ldap-stats/Makefile26
-rw-r--r--net/ldap-stats/distinfo3
-rw-r--r--net/ldap-stats/pkg-descr4
4 files changed, 34 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 5faeed2d6ddc..a0cd24346677 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -284,6 +284,7 @@
SUBDIR += lambdamoo
SUBDIR += lanbrowsing
SUBDIR += latd
+ SUBDIR += ldap-stats
SUBDIR += ldap2dns
SUBDIR += ldapbrowser
SUBDIR += ldapdiff
diff --git a/net/ldap-stats/Makefile b/net/ldap-stats/Makefile
new file mode 100644
index 000000000000..ae286b49b776
--- /dev/null
+++ b/net/ldap-stats/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: ldap-stats
+# Date created: Fri 09 Oct 2009
+# Whom: Alexey V. Degtyarev <alexey@renatasystems.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ldap-stats
+PORTVERSION= 5.2
+CATEGORIES= net
+MASTER_SITES= ftp://ftp.renatasystems.org/pub/FreeBSD/ports/distfiles/
+
+MAINTAINER= alexey@renatasystems.org
+COMMENT= Program to generate OpenLDAP statistics reports
+
+RUN_DEPENDS= p5-Getopt-Long>=0:${PORTSDIR}/devel/p5-Getopt-Long
+
+NO_BUILD= yes
+USE_PERL5= yes
+
+PLIST_FILES= bin/ldap-stats
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/ldap-stats.pl ${PREFIX}/bin/ldap-stats
+
+.include <bsd.port.mk>
diff --git a/net/ldap-stats/distinfo b/net/ldap-stats/distinfo
new file mode 100644
index 000000000000..32409dfa5e47
--- /dev/null
+++ b/net/ldap-stats/distinfo
@@ -0,0 +1,3 @@
+MD5 (ldap-stats-5.2.tar.gz) = 1b102765f00b04d47f91d0904cf42443
+SHA256 (ldap-stats-5.2.tar.gz) = 7a9495f7e89beb96a6a62cb4dd7d07ff655e88badffee2bbadad80773f9c0033
+SIZE (ldap-stats-5.2.tar.gz) = 10655
diff --git a/net/ldap-stats/pkg-descr b/net/ldap-stats/pkg-descr
new file mode 100644
index 000000000000..584307608a7d
--- /dev/null
+++ b/net/ldap-stats/pkg-descr
@@ -0,0 +1,4 @@
+This program produces numerous reports from OpenLDAP 2.1, 2.2, 2.3 and 2.4
+slapd logfiles to allow OpenLDAP administrator to analyze server's performance.
+
+WWW: http://prefetch.net/code/index.html