aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorjhale <jhale@FreeBSD.org>2012-11-30 13:14:18 +0800
committerjhale <jhale@FreeBSD.org>2012-11-30 13:14:18 +0800
commit541f0b27b596f8c3e79eb19682b7fecf7f587000 (patch)
tree315fe898e4cf00e24a8e632d003445f322df42d6 /net
parentbc184f8e4e890e7f6360f6eaa75775832696e060 (diff)
downloadfreebsd-ports-gnome-541f0b27b596f8c3e79eb19682b7fecf7f587000.tar.gz
freebsd-ports-gnome-541f0b27b596f8c3e79eb19682b7fecf7f587000.tar.zst
freebsd-ports-gnome-541f0b27b596f8c3e79eb19682b7fecf7f587000.zip
- Update to 0.2.4 [1]
- Trim Makefile header [2] - Remove indefinite article from COMMENT [2] - Add .desktop file [2] - Make NLS optional [2] PR: ports/173181 Submitted by: Beni Keller <navigium@grindcore.ch> (maintainer) [1] Approved by: maintainer (via private mail) [2] Feature safe: yes
Diffstat (limited to 'net')
-rw-r--r--net/heybuddy/Makefile57
-rw-r--r--net/heybuddy/distinfo4
-rw-r--r--net/heybuddy/pkg-plist48
3 files changed, 74 insertions, 35 deletions
diff --git a/net/heybuddy/Makefile b/net/heybuddy/Makefile
index 223bc178e0ff..45ae96d03ca9 100644
--- a/net/heybuddy/Makefile
+++ b/net/heybuddy/Makefile
@@ -1,43 +1,60 @@
-# New ports collection makefile for: heybuddy
-# Date created: 14 April 2011
-# Whom: Beni Keller <navigium@grindcore.ch>
-#
+# Created by: Beni Keller <navigium@grindcore.ch>
# $FreeBSD$
-#
PORTNAME= heybuddy
-PORTVERSION= 0.2.2
-PORTREVISION= 2
+PORTVERSION= 0.2.4
CATEGORIES= net
-MASTER_SITES= http://launchpad.net/${PORTNAME}/0.2/${PORTVERSION}/+download/ \
+MASTER_SITES= http://launchpad.net/${PORTNAME}/${PORTVERSION:R}/${PORTVERSION}/+download/ \
http://freebsd.grindcore.ch/distfiles/
EXTRACT_SUFX= .tgz
MAINTAINER= navigium@grindcore.ch
-COMMENT= A supposedly light, feature free identi.ca client
+COMMENT= Supposedly light, feature free identi.ca client
LICENSE= GPLv3
FETCH_ARGS= -Fpr
USE_PYTHON= yes
+USE_GNOME= desktopfileutils pygtk2
+
+DESKTOP_ENTRIES= "Heybuddy" \
+ "Light identi.ca client" \
+ "${PORTNAME}" \
+ "${PORTNAME}" \
+ "" \
+ false
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
-USE_GNOME= pygtk2
+PLIST_SUB+= NLS=""
+.else
+PLIST_SUB+= NLS="@comment "
+.endif
post-patch:
- @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/heybuddy.py
- @${REINPLACE_CMD} -e 's|%%DATADIR%%|${DATADIR}|g' ${WRKSRC}/heybuddy.py
+ @${REINPLACE_CMD} \
+ -e 's|%%PREFIX%%|${PREFIX}|g' \
+ -e 's|%%DATADIR%%|${DATADIR}|g' \
+ ${WRKSRC}/${PORTNAME}.py
+ @${MV} ${WRKSRC}/${PORTNAME}.py ${WRKDIR}
do-build:
${PYTHON_CMD} -mcompileall ${WRKSRC}
+ ${PYTHON_CMD} -O -mcompileall ${WRKSRC}
do-install:
- @${RM} ${WRKSRC}/ChangeLog ${WRKSRC}/gpl-3.0.txt
- @${MV} ${WRKSRC}/*.bak ${WRKDIR}
- @${MV} ${WRKSRC}/*.orig ${WRKDIR}
- @${MV} ${WRKSRC}/locales ${WRKDIR}
- @${MV} ${WRKSRC}/${PORTNAME}.py ${WRKDIR}
- (cd ${WRKSRC} && ${COPYTREE_SHARE} . ${DATADIR})
- (cd ${WRKDIR}/locales && ${COPYTREE_SHARE} . ${PREFIX}/share/locale)
- ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}.py ${PREFIX}/bin/${PORTNAME}
+ @${MKDIR} ${DATADIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} README.txt *.py *.py[co] ${DATADIR}
+ cd ${WRKDIR} && ${INSTALL_SCRIPT} ${PORTNAME}.py ${PREFIX}/bin/${PORTNAME}
+ cd ${WRKSRC}/assets && ${INSTALL_DATA} icon64.png ${PREFIX}/share/pixmaps/${PORTNAME}.png
+ @cd ${WRKSRC} && ${COPYTREE_SHARE} assets ${DATADIR}
+.if ${PORT_OPTIONS:MNLS}
+ @cd ${WRKSRC}/locales && ${COPYTREE_SHARE} . ${PREFIX}/share/locale
+.endif
+
+post-install:
+ -@update-desktop-database
.include <bsd.port.mk>
diff --git a/net/heybuddy/distinfo b/net/heybuddy/distinfo
index d4d41090f37e..d401f20211d5 100644
--- a/net/heybuddy/distinfo
+++ b/net/heybuddy/distinfo
@@ -1,2 +1,2 @@
-SHA256 (heybuddy-0.2.2.tgz) = 4bcc26cecb374bacce0dce401d29e2d8d6e9ac5c3c931e1288347d6cde4e4ce1
-SIZE (heybuddy-0.2.2.tgz) = 77455
+SHA256 (heybuddy-0.2.4.tgz) = 233c4f3bc158240d57f6fc69c2810ca74de103d8c9d076a0f3e8eebd6b4330e2
+SIZE (heybuddy-0.2.4.tgz) = 84264
diff --git a/net/heybuddy/pkg-plist b/net/heybuddy/pkg-plist
index 051efe4e3100..c42997f59535 100644
--- a/net/heybuddy/pkg-plist
+++ b/net/heybuddy/pkg-plist
@@ -1,46 +1,65 @@
-@comment $FreeBSD$
bin/heybuddy
%%DATADIR%%/About.py
%%DATADIR%%/About.pyc
+%%DATADIR%%/About.pyo
%%DATADIR%%/CertificateValidatingHTTPSHandler.py
%%DATADIR%%/CertificateValidatingHTTPSHandler.pyc
+%%DATADIR%%/CertificateValidatingHTTPSHandler.pyo
%%DATADIR%%/Communicator.py
%%DATADIR%%/Communicator.pyc
+%%DATADIR%%/Communicator.pyo
%%DATADIR%%/Configuration.py
%%DATADIR%%/Configuration.pyc
+%%DATADIR%%/Configuration.pyo
%%DATADIR%%/ContextPage.py
%%DATADIR%%/ContextPage.pyc
+%%DATADIR%%/ContextPage.pyo
%%DATADIR%%/Dent.py
%%DATADIR%%/Dent.pyc
+%%DATADIR%%/Dent.pyo
%%DATADIR%%/DentButton.py
%%DATADIR%%/DentButton.pyc
+%%DATADIR%%/DentButton.pyo
%%DATADIR%%/DentScroller.py
%%DATADIR%%/DentScroller.pyc
+%%DATADIR%%/DentScroller.pyo
%%DATADIR%%/FilterFrame.py
%%DATADIR%%/FilterFrame.pyc
+%%DATADIR%%/FilterFrame.pyo
%%DATADIR%%/GroupPage.py
%%DATADIR%%/GroupPage.pyc
+%%DATADIR%%/GroupPage.pyo
%%DATADIR%%/ImageCache.py
%%DATADIR%%/ImageCache.pyc
+%%DATADIR%%/ImageCache.pyo
%%DATADIR%%/MainWindow.py
%%DATADIR%%/MainWindow.pyc
+%%DATADIR%%/MainWindow.pyo
%%DATADIR%%/Notify.py
%%DATADIR%%/Notify.pyc
+%%DATADIR%%/Notify.pyo
%%DATADIR%%/PlatformSpecific.py
%%DATADIR%%/PlatformSpecific.pyc
+%%DATADIR%%/PlatformSpecific.pyo
%%DATADIR%%/README.txt
%%DATADIR%%/ScrollPage.py
%%DATADIR%%/ScrollPage.pyc
+%%DATADIR%%/ScrollPage.pyo
%%DATADIR%%/SettingsPage.py
%%DATADIR%%/SettingsPage.pyc
+%%DATADIR%%/SettingsPage.pyo
%%DATADIR%%/StatusIcon.py
%%DATADIR%%/StatusIcon.pyc
+%%DATADIR%%/StatusIcon.pyo
+%%DATADIR%%/TagPage.py
+%%DATADIR%%/TagPage.pyc
+%%DATADIR%%/TagPage.pyo
%%DATADIR%%/UserPage.py
%%DATADIR%%/UserPage.pyc
+%%DATADIR%%/UserPage.pyo
%%DATADIR%%/XMLProcessor.py
%%DATADIR%%/XMLProcessor.pyc
-%%DATADIR%%/_dev/get_text
-%%DATADIR%%/_dev/heybuddy.pot
+%%DATADIR%%/XMLProcessor.pyo
%%DATADIR%%/assets/direct_icon.png
%%DATADIR%%/assets/icon.png
%%DATADIR%%/assets/icon.svg
@@ -48,15 +67,18 @@ bin/heybuddy
%%DATADIR%%/assets/icon14.png
%%DATADIR%%/assets/icon64.png
%%DATADIR%%/assets/throbber.gif
-%%DATADIR%%/heybuddy.pyc
-share/locale/da/LC_MESSAGES/heybuddy.mo
-share/locale/de/LC_MESSAGES/heybuddy.mo
-share/locale/el/LC_MESSAGES/heybuddy.mo
-share/locale/eo/LC_MESSAGES/heybuddy.mo
-share/locale/es/LC_MESSAGES/heybuddy.mo
-share/locale/gl/LC_MESSAGES/heybuddy.mo
-share/locale/pt/LC_MESSAGES/heybuddy.mo
-share/locale/pt_BR/LC_MESSAGES/heybuddy.mo
+%%NLS%%share/locale/da/LC_MESSAGES/heybuddy.mo
+%%NLS%%share/locale/de/LC_MESSAGES/heybuddy.mo
+%%NLS%%share/locale/el/LC_MESSAGES/heybuddy.mo
+%%NLS%%share/locale/en_GB/LC_MESSAGES/heybuddy.mo
+%%NLS%%share/locale/eo/LC_MESSAGES/heybuddy.mo
+%%NLS%%share/locale/es/LC_MESSAGES/heybuddy.mo
+%%NLS%%share/locale/gl/LC_MESSAGES/heybuddy.mo
+%%NLS%%share/locale/he/LC_MESSAGES/heybuddy.mo
+%%NLS%%share/locale/pt/LC_MESSAGES/heybuddy.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/heybuddy.mo
+share/pixmaps/heybuddy.png
@dirrm %%DATADIR%%/assets
-@dirrm %%DATADIR%%/_dev
@dirrm %%DATADIR%%
+@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null 2>&1 || /usr/bin/true
+@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null 2>&1 || /usr/bin/true