aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-01-10 19:31:06 +0800
committerijliao <ijliao@FreeBSD.org>2002-01-10 19:31:06 +0800
commit5aa6f7fd46c22f7c7f108bb6e40522de517fa813 (patch)
tree7598209a8059a67e9fdc1dd95d07a05f2c5d84f1 /net
parent601a1664392f8cc170aa0ee4cbf47c1d6aa764e9 (diff)
downloadfreebsd-ports-gnome-5aa6f7fd46c22f7c7f108bb6e40522de517fa813.tar.gz
freebsd-ports-gnome-5aa6f7fd46c22f7c7f108bb6e40522de517fa813.tar.zst
freebsd-ports-gnome-5aa6f7fd46c22f7c7f108bb6e40522de517fa813.zip
add wol 0.5.1
Wake On LAN client
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/wol/Makefile28
-rw-r--r--net/wol/distinfo1
-rw-r--r--net/wol/pkg-comment1
-rw-r--r--net/wol/pkg-descr14
-rw-r--r--net/wol/pkg-plist5
6 files changed, 50 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 4b3067448406..82b55b16f96f 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -487,6 +487,7 @@
SUBDIR += wmnetmon
SUBDIR += wmq3
SUBDIR += wmwave
+ SUBDIR += wol
SUBDIR += xarchie
SUBDIR += xbone
SUBDIR += xferstats
diff --git a/net/wol/Makefile b/net/wol/Makefile
new file mode 100644
index 000000000000..184e86757da2
--- /dev/null
+++ b/net/wol/Makefile
@@ -0,0 +1,28 @@
+# ex:ts=8
+# Ports collection makefile for: wol
+# Date created: Jan 10, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= wol
+PORTVERSION= 0.5.1
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ahh
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= intl:${PORTSDIR}/devel/gettext \
+ giconv:${PORTSDIR}/converters/libiconv \
+ gnugetopt:${PORTSDIR}/devel/libgnugetopt
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -lgiconv -lgnugetopt"
+
+post-patch:
+ @${PERL} -pi -e "s/iconv.h/giconv.h/g" ${WRKSRC}/configure
+
+.include <bsd.port.mk>
diff --git a/net/wol/distinfo b/net/wol/distinfo
new file mode 100644
index 000000000000..504b42264b33
--- /dev/null
+++ b/net/wol/distinfo
@@ -0,0 +1 @@
+MD5 (wol-0.5.1.tar.gz) = 776e3b40f11163bcdcc78c7783e6aaf9
diff --git a/net/wol/pkg-comment b/net/wol/pkg-comment
new file mode 100644
index 000000000000..ad2dc96c2cdf
--- /dev/null
+++ b/net/wol/pkg-comment
@@ -0,0 +1 @@
+Wake On LAN client
diff --git a/net/wol/pkg-descr b/net/wol/pkg-descr
new file mode 100644
index 000000000000..9d82c30099fd
--- /dev/null
+++ b/net/wol/pkg-descr
@@ -0,0 +1,14 @@
+wol implements Wake On LAN functionality in a small program. It wakes up
+hardware that is Magic Packet compliant.
+
+Features:
+ Wakes up various NIC's (tested)
+ 3COM 3C905c
+ Intel EtherExpress Pro 100
+ Linksys Etherfast LNE100TX
+ Realtek LFE8139
+ LevelOne FNC-0107TX
+ Wake up from file (same as /etc/ethers and an enhanced format)
+ Sleeping between two wake ups (measured in milliseconds)
+
+WWW: http://ahh.sourceforge.net/wol/
diff --git a/net/wol/pkg-plist b/net/wol/pkg-plist
new file mode 100644
index 000000000000..aa5b5b6adf76
--- /dev/null
+++ b/net/wol/pkg-plist
@@ -0,0 +1,5 @@
+bin/wol
+@unexec install-info --delete %D/info/wol.info %D/info/dir
+info/wol.info
+@exec install-info %D/info/wol.info %D/info/dir
+share/locale/de/LC_MESSAGES/wol.mo