aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authortz <tz@FreeBSD.org>2017-11-16 18:48:48 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2018-02-04 05:57:22 +0800
commit5b27cbc62c5d8f59985081907ae7a2d906418f1c (patch)
treefb9f954553ab0d387d2ed80421e3a595dbe1e0cc /net
parente7c9b3f082da3e8d0d0fefb08950ae1d9606aebb (diff)
downloadfreebsd-ports-gnome-5b27cbc62c5d8f59985081907ae7a2d906418f1c.tar.gz
freebsd-ports-gnome-5b27cbc62c5d8f59985081907ae7a2d906418f1c.tar.zst
freebsd-ports-gnome-5b27cbc62c5d8f59985081907ae7a2d906418f1c.zip
Add PHP 7.2 RC6
Notable changes: - mcrypt module was removed - sodium module was added - sybase_ct artifacts removed Also many PECL ports will not work with this version since some files got renamed. Reviewed by: mat, ale, Rainer Duffner <rainer@ultra-secure.de> Differential Revision: https://reviews.freebsd.org/D12980
Diffstat (limited to 'net')
-rw-r--r--net/Makefile4
-rw-r--r--net/php72-ldap/Makefile9
-rw-r--r--net/php72-ldap/php71-ldap/Makefile9
-rw-r--r--net/php72-soap/Makefile9
-rw-r--r--net/php72-soap/php71-soap/Makefile9
-rw-r--r--net/php72-sockets/Makefile9
-rw-r--r--net/php72-sockets/php71-sockets/Makefile9
-rw-r--r--net/php72-xmlrpc/Makefile9
-rw-r--r--net/php72-xmlrpc/files/patch-config.m423
-rw-r--r--net/php72-xmlrpc/php71-xmlrpc/Makefile9
-rw-r--r--net/php72-xmlrpc/php71-xmlrpc/files/patch-config.m423
11 files changed, 122 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 7094f99af3bf..8af166c21e08 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -943,6 +943,10 @@
SUBDIR += php71-soap
SUBDIR += php71-sockets
SUBDIR += php71-xmlrpc
+ SUBDIR += php72-ldap
+ SUBDIR += php72-soap
+ SUBDIR += php72-sockets
+ SUBDIR += php72-xmlrpc
SUBDIR += phpldapadmin
SUBDIR += pim6-tools
SUBDIR += pim6dd
diff --git a/net/php72-ldap/Makefile b/net/php72-ldap/Makefile
new file mode 100644
index 000000000000..930af552e593
--- /dev/null
+++ b/net/php72-ldap/Makefile
@@ -0,0 +1,9 @@
+# $FreeBSD$
+
+CATEGORIES= net
+
+MASTERDIR= ${.CURDIR}/../../lang/php72
+
+PKGNAMESUFFIX= -ldap
+
+.include "${MASTERDIR}/Makefile"
diff --git a/net/php72-ldap/php71-ldap/Makefile b/net/php72-ldap/php71-ldap/Makefile
new file mode 100644
index 000000000000..1edcb04d0de5
--- /dev/null
+++ b/net/php72-ldap/php71-ldap/Makefile
@@ -0,0 +1,9 @@
+# $FreeBSD$
+
+CATEGORIES= net
+
+MASTERDIR= ${.CURDIR}/../../lang/php71
+
+PKGNAMESUFFIX= -ldap
+
+.include "${MASTERDIR}/Makefile"
diff --git a/net/php72-soap/Makefile b/net/php72-soap/Makefile
new file mode 100644
index 000000000000..2fb49fe37328
--- /dev/null
+++ b/net/php72-soap/Makefile
@@ -0,0 +1,9 @@
+# $FreeBSD$
+
+CATEGORIES= net
+
+MASTERDIR= ${.CURDIR}/../../lang/php72
+
+PKGNAMESUFFIX= -soap
+
+.include "${MASTERDIR}/Makefile"
diff --git a/net/php72-soap/php71-soap/Makefile b/net/php72-soap/php71-soap/Makefile
new file mode 100644
index 000000000000..8f0142f7d728
--- /dev/null
+++ b/net/php72-soap/php71-soap/Makefile
@@ -0,0 +1,9 @@
+# $FreeBSD$
+
+CATEGORIES= net
+
+MASTERDIR= ${.CURDIR}/../../lang/php71
+
+PKGNAMESUFFIX= -soap
+
+.include "${MASTERDIR}/Makefile"
diff --git a/net/php72-sockets/Makefile b/net/php72-sockets/Makefile
new file mode 100644
index 000000000000..7ae4fafe9e71
--- /dev/null
+++ b/net/php72-sockets/Makefile
@@ -0,0 +1,9 @@
+# $FreeBSD$
+
+CATEGORIES= net
+
+MASTERDIR= ${.CURDIR}/../../lang/php72
+
+PKGNAMESUFFIX= -sockets
+
+.include "${MASTERDIR}/Makefile"
diff --git a/net/php72-sockets/php71-sockets/Makefile b/net/php72-sockets/php71-sockets/Makefile
new file mode 100644
index 000000000000..9284f2d9c7ae
--- /dev/null
+++ b/net/php72-sockets/php71-sockets/Makefile
@@ -0,0 +1,9 @@
+# $FreeBSD$
+
+CATEGORIES= net
+
+MASTERDIR= ${.CURDIR}/../../lang/php71
+
+PKGNAMESUFFIX= -sockets
+
+.include "${MASTERDIR}/Makefile"
diff --git a/net/php72-xmlrpc/Makefile b/net/php72-xmlrpc/Makefile
new file mode 100644
index 000000000000..21440fea888b
--- /dev/null
+++ b/net/php72-xmlrpc/Makefile
@@ -0,0 +1,9 @@
+# $FreeBSD$
+
+CATEGORIES= net
+
+MASTERDIR= ${.CURDIR}/../../lang/php72
+
+PKGNAMESUFFIX= -xmlrpc
+
+.include "${MASTERDIR}/Makefile"
diff --git a/net/php72-xmlrpc/files/patch-config.m4 b/net/php72-xmlrpc/files/patch-config.m4
new file mode 100644
index 000000000000..d2dc85f26a48
--- /dev/null
+++ b/net/php72-xmlrpc/files/patch-config.m4
@@ -0,0 +1,23 @@
+--- config.m4.orig 2014-04-29 08:04:30.000000000 +0000
++++ config.m4 2014-05-15 08:04:00.883004682 +0000
+@@ -61,11 +61,9 @@ if test "$PHP_XMLRPC" != "no"; then
+ fi
+ fi
+
+- dnl if iconv is shared or missing then we should build iconv ourselves
+- if test "$PHP_ICONV_SHARED" = "yes" || test "$PHP_ICONV" = "no"; then
+-
+ if test "$PHP_ICONV_DIR" != "no"; then
+ PHP_ICONV=$PHP_ICONV_DIR
++ PHP_ADD_INCLUDE($PHP_ICONV_DIR/include)
+ fi
+
+ if test -z "$PHP_ICONV" || test "$PHP_ICONV" = "no"; then
+@@ -75,7 +73,6 @@ if test "$PHP_XMLRPC" != "no"; then
+ PHP_SETUP_ICONV(XMLRPC_SHARED_LIBADD, [], [
+ AC_MSG_ERROR([iconv not found, in order to build xmlrpc you need the iconv library])
+ ])
+- fi
+ fi
+
+ if test "$PHP_XMLRPC" = "yes"; then
diff --git a/net/php72-xmlrpc/php71-xmlrpc/Makefile b/net/php72-xmlrpc/php71-xmlrpc/Makefile
new file mode 100644
index 000000000000..961bb83a703c
--- /dev/null
+++ b/net/php72-xmlrpc/php71-xmlrpc/Makefile
@@ -0,0 +1,9 @@
+# $FreeBSD$
+
+CATEGORIES= net
+
+MASTERDIR= ${.CURDIR}/../../lang/php71
+
+PKGNAMESUFFIX= -xmlrpc
+
+.include "${MASTERDIR}/Makefile"
diff --git a/net/php72-xmlrpc/php71-xmlrpc/files/patch-config.m4 b/net/php72-xmlrpc/php71-xmlrpc/files/patch-config.m4
new file mode 100644
index 000000000000..d2dc85f26a48
--- /dev/null
+++ b/net/php72-xmlrpc/php71-xmlrpc/files/patch-config.m4
@@ -0,0 +1,23 @@
+--- config.m4.orig 2014-04-29 08:04:30.000000000 +0000
++++ config.m4 2014-05-15 08:04:00.883004682 +0000
+@@ -61,11 +61,9 @@ if test "$PHP_XMLRPC" != "no"; then
+ fi
+ fi
+
+- dnl if iconv is shared or missing then we should build iconv ourselves
+- if test "$PHP_ICONV_SHARED" = "yes" || test "$PHP_ICONV" = "no"; then
+-
+ if test "$PHP_ICONV_DIR" != "no"; then
+ PHP_ICONV=$PHP_ICONV_DIR
++ PHP_ADD_INCLUDE($PHP_ICONV_DIR/include)
+ fi
+
+ if test -z "$PHP_ICONV" || test "$PHP_ICONV" = "no"; then
+@@ -75,7 +73,6 @@ if test "$PHP_XMLRPC" != "no"; then
+ PHP_SETUP_ICONV(XMLRPC_SHARED_LIBADD, [], [
+ AC_MSG_ERROR([iconv not found, in order to build xmlrpc you need the iconv library])
+ ])
+- fi
+ fi
+
+ if test "$PHP_XMLRPC" = "yes"; then