aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authordes <des@FreeBSD.org>2014-11-14 05:46:11 +0800
committerdes <des@FreeBSD.org>2014-11-14 05:46:11 +0800
commit5cebfc42d4d68744d3f99fecffd934b69ab4b44c (patch)
treed710d21e1c25aab9a25dbd52c8f49456ef7f86f9 /net
parent700e1930e0091a849836b655bf63859bc8ad6995 (diff)
downloadfreebsd-ports-gnome-5cebfc42d4d68744d3f99fecffd934b69ab4b44c.tar.gz
freebsd-ports-gnome-5cebfc42d4d68744d3f99fecffd934b69ab4b44c.tar.zst
freebsd-ports-gnome-5cebfc42d4d68744d3f99fecffd934b69ab4b44c.zip
Add patches for a couple of issues I found while researching #190055:
- Use GID_MAX instead of LONG_MAX, they are not the same on 64-bit. - Correctly restore the egid after reading the krb5 credential cache. MFH: 2014Q4
Diffstat (limited to 'net')
-rw-r--r--net/nss_ldap/Makefile2
-rw-r--r--net/nss_ldap/files/patch-ldap-grp.c11
-rw-r--r--net/nss_ldap/files/patch-ldap-init-krb5-cache.c13
3 files changed, 23 insertions, 3 deletions
diff --git a/net/nss_ldap/Makefile b/net/nss_ldap/Makefile
index 670288d72954..a4e14258dd37 100644
--- a/net/nss_ldap/Makefile
+++ b/net/nss_ldap/Makefile
@@ -3,7 +3,7 @@
PORTNAME= nss_ldap
PORTVERSION= 1.${NSS_LDAP_VERSION}
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= net
MASTER_SITES= http://www.padl.com/download/ \
LOCAL/martymac
diff --git a/net/nss_ldap/files/patch-ldap-grp.c b/net/nss_ldap/files/patch-ldap-grp.c
new file mode 100644
index 000000000000..5886498b8e4c
--- /dev/null
+++ b/net/nss_ldap/files/patch-ldap-grp.c
@@ -0,0 +1,11 @@
+--- ldap-grp.c.orig
++++ ldap-grp.c
+@@ -687,7 +687,7 @@
+ gid = strtoul (values[0], (char **) NULL, 10);
+ ldap_value_free (values);
+
+- if (gid == LONG_MAX && errno == ERANGE)
++ if (gid == GID_MAX && errno == ERANGE)
+ {
+ /* invalid group, skip it */
+ return NSS_NOTFOUND;
diff --git a/net/nss_ldap/files/patch-ldap-init-krb5-cache.c b/net/nss_ldap/files/patch-ldap-init-krb5-cache.c
index 7fc9aa4641ba..9352aea3a493 100644
--- a/net/nss_ldap/files/patch-ldap-init-krb5-cache.c
+++ b/net/nss_ldap/files/patch-ldap-init-krb5-cache.c
@@ -1,5 +1,5 @@
---- ldap-init-krb5-cache.c.orig 2009-11-06 11:28:08.000000000 +0100
-+++ ldap-init-krb5-cache.c 2014-03-26 21:42:54.575385677 +0100
+--- ldap-init-krb5-cache.c.orig
++++ ldap-init-krb5-cache.c
@@ -109,14 +109,14 @@
#include <gssapi/gssapi.h>
#include <gssapi/gssapi_krb5.h>
@@ -47,6 +47,15 @@
{
debug ("==> krb5_cache_kt_is_accessible: kt type = FILE");
uid_t ruid = getuid ();
+@@ -243,7 +254,7 @@
+ {
+ setreuid (ruid, euid);
+ }
+- if (rgid != rgid)
++ if (rgid != egid)
+ {
+ setregid (rgid, egid);
+ }
@@ -542,7 +553,7 @@
}
profile_release (profile);