aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2006-01-31 23:55:58 +0800
committerdinoex <dinoex@FreeBSD.org>2006-01-31 23:55:58 +0800
commit5e4335579ee6b12ce801da5be815928d21a6609e (patch)
tree7cca145cf1fa5b7fffcab569ca82d28d656b52ac /net
parent220047a94a54588de7fe413684589cbc5d5cb780 (diff)
downloadfreebsd-ports-gnome-5e4335579ee6b12ce801da5be815928d21a6609e.tar.gz
freebsd-ports-gnome-5e4335579ee6b12ce801da5be815928d21a6609e.tar.zst
freebsd-ports-gnome-5e4335579ee6b12ce801da5be815928d21a6609e.zip
- remove etc/pam.d/radius if present
Diffstat (limited to 'net')
-rw-r--r--net/radiusd-cistron/Makefile9
-rw-r--r--net/radiusd-cistron/pkg-plist2
2 files changed, 10 insertions, 1 deletions
diff --git a/net/radiusd-cistron/Makefile b/net/radiusd-cistron/Makefile
index 87bf8e1f4e5b..7dc2e2ba3263 100644
--- a/net/radiusd-cistron/Makefile
+++ b/net/radiusd-cistron/Makefile
@@ -19,11 +19,11 @@ MAKEFILE= Makefile.BSD
RADIUS_DIR= ${PREFIX}/etc/raddb
MAKE_ENV+= RADIUS_DIR="${RADIUS_DIR}"
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+PAMBASE?= etc
MAN1= radclient.1 radlast.1 radtest.1 radwho.1 radzap.1
MAN5= clients.5rad naslist.5rad
MAN8= radiusd.8 radrelay.8 radwatch.8
-
DOCFILES= COPYRIGHT INSTALL doc/ChangeLog doc/README doc/README.Y2K \
doc/README.cisco doc/README.pam doc/README.proxy \
doc/README.simul doc/README.usersfile
@@ -54,4 +54,11 @@ do-install:
.endfor
.endif
+.if exists(${DESTDIR}/etc/pam.d)
+PLIST_SUB+= WITH_PAMD=""
+.else
+PLIST_SUB+= WITH_PAMD="@comment "
+.endif
+PLIST_SUB+= PAMBASE="/${PAMBASE}"
+
.include <bsd.port.mk>
diff --git a/net/radiusd-cistron/pkg-plist b/net/radiusd-cistron/pkg-plist
index 529997dc8983..aec0d0ff5fbc 100644
--- a/net/radiusd-cistron/pkg-plist
+++ b/net/radiusd-cistron/pkg-plist
@@ -44,3 +44,5 @@ share/radius/dictionary.versanet
@unexec rm -f /var/log/radius.log
@unexec rm -f /var/run/radiusd.pid
@unexec echo "Leaving /var/run/radutmp, /var/log/radwtmp and /var/log/radacct alone."
+%%WITH_PAMD%%@cwd %%PAMBASE%%
+%%WITH_PAMD%%pam.d/radius