aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorhq <hq@FreeBSD.org>2004-11-22 08:17:34 +0800
committerhq <hq@FreeBSD.org>2004-11-22 08:17:34 +0800
commit64abf4678c654a330bff3e6a1d958b87a9914f08 (patch)
tree7a10b3e1fa25770422b4458f410a29eb9509842b /net
parent47e28072b4917d30699f8e944bae632330fb2017 (diff)
downloadfreebsd-ports-gnome-64abf4678c654a330bff3e6a1d958b87a9914f08.tar.gz
freebsd-ports-gnome-64abf4678c654a330bff3e6a1d958b87a9914f08.tar.zst
freebsd-ports-gnome-64abf4678c654a330bff3e6a1d958b87a9914f08.zip
Fix a bug in the azureus startup script installed by the port: the regex used
to determine the ECLIPSE_SWT might have more matches than intended (e.g. org.eclipse.sdk.examples_3.0.0). PR: 74200 Submitted by: maintainer Reported by: Mark Evenson <evenson@panix.com>
Diffstat (limited to 'net')
-rw-r--r--net/azureus/Makefile2
-rw-r--r--net/azureus/files/azureus2
2 files changed, 2 insertions, 2 deletions
diff --git a/net/azureus/Makefile b/net/azureus/Makefile
index 6c8300618101..f8344843f0c8 100644
--- a/net/azureus/Makefile
+++ b/net/azureus/Makefile
@@ -7,7 +7,7 @@
PORTNAME= azureus
PORTVERSION= 2.1.0.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net java
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/net/azureus/files/azureus b/net/azureus/files/azureus
index 8d45e55bbfda..d5c0ffaf198b 100644
--- a/net/azureus/files/azureus
+++ b/net/azureus/files/azureus
@@ -3,7 +3,7 @@
# $FreeBSD$
ECLIPSE_BASE=%%LOCALBASE%%/eclipse
-ECLIPSE_SWT=`find "${ECLIPSE_BASE}" -name '*swt.*' -type d | grep -e "plugins/org.eclipse.swt" | head -n 1`
+ECLIPSE_SWT=`find "${ECLIPSE_BASE}" -name '*swt.*' -type d | grep -e "plugins/org.eclipse.swt.[motif|gtk]" | head -n 1`
ECLIPSE_WS=`echo "${ECLIPSE_SWT}" | sed -e "s+^${ECLIPSE_BASE}/plugins/org.eclipse.swt.++" -e "s+_.*$++"`
ECLIPSE_SWT_JAR=${ECLIPSE_SWT}/ws/${ECLIPSE_WS}
LIB_PATH=${ECLIPSE_SWT}/os/freebsd/x86/