aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormnag <mnag@FreeBSD.org>2005-10-03 06:21:20 +0800
committermnag <mnag@FreeBSD.org>2005-10-03 06:21:20 +0800
commit665ce400dee2d7e2341eef51463311b7e33d5948 (patch)
tree786f9e24a74e42f7ae9ef2354c60e1badcff2108 /net
parent400bcbabc78135680282b775713dc09dafe73cc1 (diff)
downloadfreebsd-ports-gnome-665ce400dee2d7e2341eef51463311b7e33d5948.tar.gz
freebsd-ports-gnome-665ce400dee2d7e2341eef51463311b7e33d5948.tar.zst
freebsd-ports-gnome-665ce400dee2d7e2341eef51463311b7e33d5948.zip
Update to 1.7.0
PR: 86773 Approved by: thomas (maintainer), pav (mentor)
Diffstat (limited to 'net')
-rw-r--r--net/pptpclient/Makefile6
-rw-r--r--net/pptpclient/distinfo4
-rw-r--r--net/pptpclient/files/patch-pptp_ctrl.c20
3 files changed, 25 insertions, 5 deletions
diff --git a/net/pptpclient/Makefile b/net/pptpclient/Makefile
index 4db56a5cdda5..e8f4af427d87 100644
--- a/net/pptpclient/Makefile
+++ b/net/pptpclient/Makefile
@@ -1,12 +1,12 @@
# New ports collection makefile for: pptpclient
-# Date created: 19 June 1999
-# Whom: John Polstra <jdp@freebsd.org>
+# Date created: 19 June 1999
+# Whom: John Polstra <jdp@freebsd.org>
#
# $FreeBSD$
#
PORTNAME= pptpclient
-PORTVERSION= 1.6.0
+PORTVERSION= 1.7.0
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= pptpclient
diff --git a/net/pptpclient/distinfo b/net/pptpclient/distinfo
index 3f298d4faf9f..719eb26e3bf2 100644
--- a/net/pptpclient/distinfo
+++ b/net/pptpclient/distinfo
@@ -1,2 +1,2 @@
-MD5 (pptp-1.6.0.tar.gz) = 9a706327fb9827541d7c86d48ceb9631
-SIZE (pptp-1.6.0.tar.gz) = 225956
+MD5 (pptp-1.7.0.tar.gz) = 0bc7dbd1c265e4263008fa7883de58dd
+SIZE (pptp-1.7.0.tar.gz) = 227699
diff --git a/net/pptpclient/files/patch-pptp_ctrl.c b/net/pptpclient/files/patch-pptp_ctrl.c
new file mode 100644
index 000000000000..51aa84471f35
--- /dev/null
+++ b/net/pptpclient/files/patch-pptp_ctrl.c
@@ -0,0 +1,20 @@
+--- pptp_ctrl.c.orig Fri Sep 30 21:56:59 2005
++++ pptp_ctrl.c Fri Sep 30 21:57:27 2005
+@@ -457,6 +457,8 @@
+ void pptp_fd_set(PPTP_CONN * conn, fd_set * read_set, fd_set * write_set,
+ int * max_fd)
+ {
++ int sig_fd;
++
+ assert(conn && conn->call);
+ /* Add fd to write_set if there are outstanding writes. */
+ if (conn->write_size > 0)
+@@ -465,7 +467,7 @@
+ FD_SET(conn->inet_sock, read_set);
+ if (*max_fd < conn->inet_sock) *max_fd = conn->inet_sock;
+ /* Add signal pipe file descriptor to set */
+- int sig_fd = sigpipe_fd();
++ sig_fd = sigpipe_fd();
+ FD_SET(sig_fd, read_set);
+ if (*max_fd < sig_fd) *max_fd = sig_fd;
+ }