aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2009-04-22 17:16:47 +0800
committerclsung <clsung@FreeBSD.org>2009-04-22 17:16:47 +0800
commit666a63067d7aae90de1b57dd0ef566c9dbb89039 (patch)
treeab8f12d8f6bebb4d964e5e38ec8e3358bd92c867 /net
parent509dc0b24a668e3a34ec364d6ce4ffb77ca25c53 (diff)
downloadfreebsd-ports-gnome-666a63067d7aae90de1b57dd0ef566c9dbb89039.tar.gz
freebsd-ports-gnome-666a63067d7aae90de1b57dd0ef566c9dbb89039.tar.zst
freebsd-ports-gnome-666a63067d7aae90de1b57dd0ef566c9dbb89039.zip
Net::GitHub - Perl Interface for github.com
http://github.com is a popular git host. WWW: http://search.cpan.org/dist/Net-GitHub/
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-Net-GitHub/Makefile45
-rw-r--r--net/p5-Net-GitHub/distinfo3
-rw-r--r--net/p5-Net-GitHub/files/patch-inc-Module-AutoInstall.pm11
-rw-r--r--net/p5-Net-GitHub/pkg-descr5
-rw-r--r--net/p5-Net-GitHub/pkg-plist27
6 files changed, 92 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index dcb90743dc1f..fc4915440a85 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -508,6 +508,7 @@
SUBDIR += p5-Net-Frame-Dump
SUBDIR += p5-Net-Frame-Layer-ICMPv6
SUBDIR += p5-Net-Frame-Layer-IPv6
+ SUBDIR += p5-Net-GitHub
SUBDIR += p5-Net-Gnats
SUBDIR += p5-Net-Google
SUBDIR += p5-Net-Google-AuthSub
diff --git a/net/p5-Net-GitHub/Makefile b/net/p5-Net-GitHub/Makefile
new file mode 100644
index 000000000000..963a2ab606f2
--- /dev/null
+++ b/net/p5-Net-GitHub/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: p5-Net-GitHub
+# Date created: 2009-04-21
+# Whom: Cheng-Lung Sung <clsung@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-GitHub
+PORTVERSION= 0.11
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= Perl interface to github.com
+
+RUN_DEPENDS= ${SITE_PERL}/URI/Escape.pm:${PORTSDIR}/net/p5-URI \
+ ${SITE_PERL}/HTML/TreeBuilder.pm:${PORTSDIR}/www/p5-HTML-Tree \
+ ${SITE_PERL}/WWW/Mechanize/GZip.pm:${PORTSDIR}/www/p5-WWW-Mechanize-GZip \
+ ${SITE_PERL}/JSON/Any.pm:${PORTSDIR}/converters/p5-JSON-Any \
+ p5-Crypt-SSLeay>0:${PORTSDIR}/security/p5-Crypt-SSLeay \
+ p5-Moose>=0.57:${PORTSDIR}/devel/p5-Moose
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::GitHub.3 Net::GitHub::V1.3 \
+ Net::GitHub::V1::Project.3 \
+ Net::GitHub::V1::Project::Downloads.3 \
+ Net::GitHub::V1::Project::Info.3 \
+ Net::GitHub::V1::Project::Role.3 \
+ Net::GitHub::V1::Project::Source.3 \
+ Net::GitHub::V1::Project::Wiki.3 \
+ Net::GitHub::V1::Role.3 \
+ Net::GitHub::V1::Search.3 \
+ Net::GitHub::V1::User.3 \
+ Net::GitHub::V2.3 Net::GitHub::V2::Commits.3 \
+ Net::GitHub::V2::Issues.3 \
+ Net::GitHub::V2::Network.3 \
+ Net::GitHub::V2::Object.3 \
+ Net::GitHub::V2::Repositories.3 \
+ Net::GitHub::V2::Role.3 \
+ Net::GitHub::V2::Users.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-GitHub/distinfo b/net/p5-Net-GitHub/distinfo
new file mode 100644
index 000000000000..39ab524d2a5d
--- /dev/null
+++ b/net/p5-Net-GitHub/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-GitHub-0.11.tar.gz) = 23df9e63c63733e90a7a40e773380b16
+SHA256 (Net-GitHub-0.11.tar.gz) = 076daf1f754e4415fd30fdb5c07f85c2dcf4e6daa2ba596212680e50590349ba
+SIZE (Net-GitHub-0.11.tar.gz) = 38793
diff --git a/net/p5-Net-GitHub/files/patch-inc-Module-AutoInstall.pm b/net/p5-Net-GitHub/files/patch-inc-Module-AutoInstall.pm
new file mode 100644
index 000000000000..135a67529f45
--- /dev/null
+++ b/net/p5-Net-GitHub/files/patch-inc-Module-AutoInstall.pm
@@ -0,0 +1,11 @@
+--- inc/Module/AutoInstall.pm.orig 2009-04-20 15:31:17.000000000 +0800
++++ inc/Module/AutoInstall.pm 2009-04-22 16:08:41.000000000 +0800
+@@ -115,7 +115,7 @@
+ )[0]
+ );
+
+- $UnderCPAN = _check_lock(1); # check for $UnderCPAN
++ #$UnderCPAN = _check_lock(1); # check for $UnderCPAN
+
+ while ( my ( $feature, $modules ) = splice( @args, 0, 2 ) ) {
+ my ( @required, @tests, @skiptests );
diff --git a/net/p5-Net-GitHub/pkg-descr b/net/p5-Net-GitHub/pkg-descr
new file mode 100644
index 000000000000..66456a864240
--- /dev/null
+++ b/net/p5-Net-GitHub/pkg-descr
@@ -0,0 +1,5 @@
+Net::GitHub - Perl Interface for github.com
+
+http://github.com is a popular git host.
+
+WWW: http://search.cpan.org/dist/Net-GitHub/
diff --git a/net/p5-Net-GitHub/pkg-plist b/net/p5-Net-GitHub/pkg-plist
new file mode 100644
index 000000000000..9de23ffa0291
--- /dev/null
+++ b/net/p5-Net-GitHub/pkg-plist
@@ -0,0 +1,27 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/GitHub/.packlist
+%%SITE_PERL%%/Net/GitHub.pm
+%%SITE_PERL%%/Net/GitHub/V1.pm
+%%SITE_PERL%%/Net/GitHub/V1/Project.pm
+%%SITE_PERL%%/Net/GitHub/V1/Project/Downloads.pm
+%%SITE_PERL%%/Net/GitHub/V1/Project/Info.pm
+%%SITE_PERL%%/Net/GitHub/V1/Project/Role.pm
+%%SITE_PERL%%/Net/GitHub/V1/Project/Source.pm
+%%SITE_PERL%%/Net/GitHub/V1/Project/Wiki.pm
+%%SITE_PERL%%/Net/GitHub/V1/Role.pm
+%%SITE_PERL%%/Net/GitHub/V1/Search.pm
+%%SITE_PERL%%/Net/GitHub/V1/User.pm
+%%SITE_PERL%%/Net/GitHub/V2.pm
+%%SITE_PERL%%/Net/GitHub/V2/Commits.pm
+%%SITE_PERL%%/Net/GitHub/V2/Issues.pm
+%%SITE_PERL%%/Net/GitHub/V2/Network.pm
+%%SITE_PERL%%/Net/GitHub/V2/Object.pm
+%%SITE_PERL%%/Net/GitHub/V2/Repositories.pm
+%%SITE_PERL%%/Net/GitHub/V2/Role.pm
+%%SITE_PERL%%/Net/GitHub/V2/Users.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/GitHub
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+@dirrm %%SITE_PERL%%/Net/GitHub/V2
+@dirrm %%SITE_PERL%%/Net/GitHub/V1/Project
+@dirrm %%SITE_PERL%%/Net/GitHub/V1
+@dirrm %%SITE_PERL%%/Net/GitHub
+@dirrmtry %%SITE_PERL%%/Net