aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorbms <bms@FreeBSD.org>2009-12-02 13:59:11 +0800
committerbms <bms@FreeBSD.org>2009-12-02 13:59:11 +0800
commit673013e24656ac8d57e1760500f763b9110eb23c (patch)
tree8bad52d8dcb1e8e09e5a7f917f919ffed66c99f1 /net
parent7e11f0ebb938038e5519d87f3e5996f1699b3b41 (diff)
downloadfreebsd-ports-gnome-673013e24656ac8d57e1760500f763b9110eb23c.tar.gz
freebsd-ports-gnome-673013e24656ac8d57e1760500f763b9110eb23c.tar.zst
freebsd-ports-gnome-673013e24656ac8d57e1760500f763b9110eb23c.zip
Fix a potential buffer overflow, by increasing the size of a temporary
buffer used during BGP dump. Submitted by: Randy Bush
Diffstat (limited to 'net')
-rw-r--r--net/quagga/Makefile2
-rw-r--r--net/quagga/files/patch-bgpd__bgp_dump.c15
2 files changed, 16 insertions, 1 deletions
diff --git a/net/quagga/Makefile b/net/quagga/Makefile
index 421113450de0..c36f68a9e072 100644
--- a/net/quagga/Makefile
+++ b/net/quagga/Makefile
@@ -7,7 +7,7 @@
PORTNAME= quagga
PORTVERSION= 0.99.15
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net ipv6
MASTER_SITES= http://quagga.net/download/ \
http://www.ru.quagga.net/download/ \
diff --git a/net/quagga/files/patch-bgpd__bgp_dump.c b/net/quagga/files/patch-bgpd__bgp_dump.c
new file mode 100644
index 000000000000..759bc6534c1e
--- /dev/null
+++ b/net/quagga/files/patch-bgpd__bgp_dump.c
@@ -0,0 +1,15 @@
+--- bgpd/bgp_dump.c.orig 2009-07-28 17:35:45.000000000 +0100
++++ bgpd/bgp_dump.c 2009-12-02 05:46:16.000000000 +0000
+@@ -850,8 +850,12 @@
+ memset (&bgp_dump_updates, 0, sizeof (struct bgp_dump));
+ memset (&bgp_dump_routes, 0, sizeof (struct bgp_dump));
+
++#ifdef notsufficient
+ bgp_dump_obuf = stream_new (BGP_MAX_PACKET_SIZE + BGP_DUMP_MSG_HEADER
+ + BGP_DUMP_HEADER_SIZE);
++#else
++ bgp_dump_obuf = stream_new(16384);
++#endif
+
+ install_node (&bgp_dump_node, config_write_bgp_dump);
+