aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-05-31 19:19:32 +0800
committerbapt <bapt@FreeBSD.org>2012-05-31 19:19:32 +0800
commit68b530317704ed344f567080786046479ed054fb (patch)
tree93fe9eebc56e2451ba426603948adb8749cb38e9 /net
parentaedee365f6b7833ae31d4b673dcd979c369e4ac2 (diff)
downloadfreebsd-ports-gnome-68b530317704ed344f567080786046479ed054fb.tar.gz
freebsd-ports-gnome-68b530317704ed344f567080786046479ed054fb.tar.zst
freebsd-ports-gnome-68b530317704ed344f567080786046479ed054fb.zip
Convert to new options framework
Diffstat (limited to 'net')
-rw-r--r--net/p5-Net-SSH-Perl/Makefile6
-rw-r--r--net/p5-Net-Server/Makefile6
2 files changed, 7 insertions, 5 deletions
diff --git a/net/p5-Net-SSH-Perl/Makefile b/net/p5-Net-SSH-Perl/Makefile
index c7b469dfa063..08d18a8cf8c5 100644
--- a/net/p5-Net-SSH-Perl/Makefile
+++ b/net/p5-Net-SSH-Perl/Makefile
@@ -71,11 +71,13 @@ MAN3= Net::SSH::Perl.3 \
CONFIGURE_ENV+= PERL_MM_USE_DEFAULT="1"
PERL_CONFIGURE= yes
-OPTIONS= GMP "Use the optimized Math::BigInt::GMP backend" on
+OPTIONS_DEFINE= GMP
+OPTIONS_DEFAULT= GMP
+GMP_DESC= Use the optimized Math::BigInt::GMP backend
.include <bsd.port.pre.mk>
-.if !defined(WITHOUT_GMP)
+.if ${PORT_OPTIONS:MGMP}
GMP_DEPEND= ${SITE_PERL}/${PERL_ARCH}/Math/BigInt/GMP.pm:${PORTSDIR}/math/p5-Math-BigInt-GMP
BUILD_DEPENDS+= ${GMP_DEPEND}
RUN_DEPENDS+= ${GMP_DEPEND}
diff --git a/net/p5-Net-Server/Makefile b/net/p5-Net-Server/Makefile
index 6a22f055bd4b..b0f1496a1c38 100644
--- a/net/p5-Net-Server/Makefile
+++ b/net/p5-Net-Server/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS= p5-IO-Multiplex>=1.01:${PORTSDIR}/devel/p5-IO-Multiplex
PERL_CONFIGURE= yes
-OPTIONS= IPV6 "Enable ipv6 support patch from Debian" off
+OPTIONS_DEFINE= IPV6
MAN3= Net::Server.3 \
Net::Server::Daemonize.3\
@@ -41,14 +41,14 @@ MAN3= Net::Server.3 \
.include <bsd.port.options.mk>
-.if defined(WITH_IPV6)
+.if ${PORT_OPTIONS:MIPV6}
BUILD_DEPENDS+= p5-Socket6>=0.23:${PORTSDIR}/net/p5-Socket6
RUN_DEPENDS+= p5-Socket6>=0.23:${PORTSDIR}/net/p5-Socket6
EXTRA_PATCHES= ${FILESDIR}/extra-patch-ipv6-support
.endif
post-patch:
-.if defined(WITH_IPV6)
+.if ${PORT_OPTIONS:MIPV6}
@cd ${WRKSRC}/ && ${FIND} . -name '*.orig' -delete
.endif