aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2005-11-20 10:05:28 +0800
committerlioux <lioux@FreeBSD.org>2005-11-20 10:05:28 +0800
commit693e34d3452062d03fac67482beb1934e82ef623 (patch)
treec9fa4196a959a8ccc81c5282eef0bf21399de698 /net
parent817f0003c981b617fdd09984520604f90c75198f (diff)
downloadfreebsd-ports-gnome-693e34d3452062d03fac67482beb1934e82ef623.tar.gz
freebsd-ports-gnome-693e34d3452062d03fac67482beb1934e82ef623.tar.zst
freebsd-ports-gnome-693e34d3452062d03fac67482beb1934e82ef623.zip
o Make sure gmake upholds the port's system environment variables
C{C,XX} o Properly link against wxgtk 2.6 o Bump PORTREVISION
Diffstat (limited to 'net')
-rw-r--r--net/xmule/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/net/xmule/Makefile b/net/xmule/Makefile
index 2e0f9d35a59c..05bc65252962 100644
--- a/net/xmule/Makefile
+++ b/net/xmule/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xmule
DISTVERSION= 1.12.0
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
#MASTER_SITES= http://download.berlios.de/%SUBDIR%/
@@ -38,6 +39,7 @@ CONFIGURE_ARGS= --without-included-gettext \
--with-wx-config=${WX_CONFIG}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} ${PTHREAD_CFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS} -L${LOCALBASE}/lib"
+MAKE_ARGS= -e
MAKE_ENV= CC="${CC}" CXX="${CXX}"
# for debugging purposes
@@ -98,6 +100,10 @@ post-patch:
-e 's|<stdint.h>|<inttypes.h>|' \
${WRKSRC}/${file}
.endfor
+# wx-config -> ${WX_CONFIG}
+ @${REINPLACE_CMD} -E \
+ -e 's|wx-config|${WX_CONFIG}|' \
+ ${WRKSRC}/src/xmule.make.in
pre-configure:
@${FIND} ${WRKSRC} -type f -name "Makefile.in" | \