aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-09-23 11:13:42 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-09-23 11:13:42 +0800
commit6f74d605f77251221235bdfa2d77bd63aef6ad05 (patch)
tree1011689e4a4f1d8095f501b47a2eed0717be304d /net
parent8f7323667acb8046a91effc59dc821c23da0ccc5 (diff)
downloadfreebsd-ports-gnome-6f74d605f77251221235bdfa2d77bd63aef6ad05.tar.gz
freebsd-ports-gnome-6f74d605f77251221235bdfa2d77bd63aef6ad05.tar.zst
freebsd-ports-gnome-6f74d605f77251221235bdfa2d77bd63aef6ad05.zip
- Add LICENSE_FILE
- Use BROKEN helper - Fix build as non-root by using uidfix Approved by: portmgr blanket
Diffstat (limited to 'net')
-rw-r--r--net/userfw/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/net/userfw/Makefile b/net/userfw/Makefile
index 64930e42b400..e03fa4686156 100644
--- a/net/userfw/Makefile
+++ b/net/userfw/Makefile
@@ -12,21 +12,20 @@ MAINTAINER= gelraen.ua@gmail.com
COMMENT= Modular packet filter
LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
SSP_UNSAFE= kernel module does not support ssp
-USES= cmake:outsource kmod tar:xz
+USES= cmake:outsource kmod tar:xz uidfix
USE_LDCONFIG= yes
+BROKEN_powerpc= does not compile
+
.include <bsd.port.pre.mk>
.if !exists(${SRC_BASE}/sys/sys/module.h)
IGNORE= requires kernel source files
.endif
-.if ${ARCH} == "powerpc"
-BROKEN= Does not compile on powerpc
-.endif
-
CMAKE_ARGS+= -DDOMAIN_STUB:BOOL=OFF
CMAKE_ARGS+= -DOPCODE_VERIFICATION:BOOL=OFF
CMAKE_ARGS+= -DKMODDIR="${KMODDIR}"